Acrobat Pro DC on my Mac (OS X version 10.9.5) HELP

New Here ,
Jan 16, 2019 Jan 16, 2019

Copy link to clipboard

Copied

Just paid for Acrobat Pro DC on my Mac (OS X version 10.9.5) and it says 'Sorry Acrobat DC won’t run on your OS. To continue you’ll have to upgrade.' What am I upgrading and how? I don't have any software updates to be done. Is my version too old and so I can't use it at all?

Thanks

TOPICS
Install update and subscribe to Acrobat

Views

1.7K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 16, 2019 Jan 16, 2019

Copy link to clipboard

Copied

It is indicating that you need to upgrade your OS.

System Requirements

   

  • Mac OS X v10.11, macOS v10.12, macOS v10.13, or macOS v10.14*
  • Safari 9.0, 10.0, or 11.0 (browser plug-in for Safari supported on 64-bit Intel processor only)
  • 1GB of RAM
  • 2.75GB of available hard-disk space
  • 1024x768 screen resolution

  

   * 10.14 Support - refer to the Known Issues document for details.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 16, 2019 Jan 16, 2019

Copy link to clipboard

Copied

Thanks for your reply! How do I upgrade my OS?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 16, 2019 Jan 16, 2019

Copy link to clipboard

Copied

There are no updates available in the app store so i'm not sure how to do it!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 16, 2019 Jan 16, 2019

Copy link to clipboard

Copied

This is an Adobe forum, you need to ask Apple how to upgrade your operating system

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 16, 2019 Jan 16, 2019

Copy link to clipboard

Copied

I do not own a Mac so I do not know what is available where, but, there is a difference between "update" and "upgrade"... Updates are generally free... they are revisions to help enhance or fix a currently-in-use version of software.  Upgrades are new versions and generally you purchase them.  You have OS version 10.9.  The oldest OS version supporting Acrobat Pro DC is 10.11... though you could also upgrade to 10.12, etc...   See what the app store has in the way of purchasing those... or better yet, talk to someone who works for the app store - they might just be giving them away.  Your machine might have limitations as far as what OS version it is able to support - so it is best to check with someone who knows the products.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 16, 2019 Jan 16, 2019

Copy link to clipboard

Copied

Moving this query to Installing, Updating, & Subscribing to Acrobat​ community.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 02, 2019 Feb 02, 2019

Copy link to clipboard

Copied

I have the update of Mojave 10.14.2 and can't open any PDF's with the Adobe Acrobat DC program. Can create something in it, but once closed after saving it won't open. I've uninstalled and reinstalled to see if it will fix the issue.

2 days later, still have the same issue. Acrobat Professional was just as good...why this major upgrade to DC just so we don't have to use a bunch of plugins...hmmm. 

When will this get fixed?!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 06, 2022 Aug 06, 2022

Copy link to clipboard

Copied

LATEST

I am having the same problem. Both of my systems (Mac OS High Sierra 10.13.3) and Acrobat Pro DC are up to date on my computer. Did you ever find a solution to this problem?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines