• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
34

Acrobat scrolling is incredibly laggy and slow

Community Beginner ,
Oct 06, 2019 Oct 06, 2019

Copy link to clipboard

Copied

Hello,

 

For the last two years I have had consistent problems with Acrobat Pro DC being extremely slow/stuttery while scrolling, highlighting, commenting on a document. This happens no matter what the size of the PDF is from less than 1 MB to 10+ MB. It appears to be very poorly optimized compared to other professional software titles which all run smoothly on macOS: Word, Excel, Pages, Numbers, etc. I have tried deleting the prefernce files outlined in other topics, which did nothing to alleviate the issue at all.

 

My computer is a relatively powerful: 2016 15-inch MacBook Pro connected to an eGPU with Radeon RX 580 and an LG 4K monitor (more than enough power to edit PDFs). I am running the latest version of Adobe Acrobat Pro DC and macOS Mojave and have never seen these issues alleviated by two years of updates.

 

Given the cost of this software, I would really appreciate some help from Adobe's support team, as well as an indication that they are planning on doing something about what is clearly an egregious lack of concern over glaring optimization issues. Having spoken with other macOS users (I work in I.T.), this is not merely an individual user issue but a broader problem plaguing Adobe Acrobat in general.

 

P. S. I have disabled the Show Online storage while opening and saving files, as suggested in other threads to no avail.

TOPICS
Crash or freeze , General troubleshooting

Views

198.0K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 5 Correct answers

New Here , May 04, 2020 May 04, 2020

Here's what finally worked for me:  Switch to Read Mode (Ctrl-H).  It scrolls the way you expect it to in this mode.  But it gets better... hit  Ctrl-H again to get back to the normal view, and like magic, scrolling is now fixed!!

 

Votes

Translate

Translate
Community Beginner , Feb 22, 2022 Feb 22, 2022

Thank you!  Control-H worked perfectly.

Votes

Translate

Translate
New Here , May 16, 2022 May 16, 2022

Hi after trying the various things in this thread I found another solution that worked for me

[i]Accessibility[/i] was the problem -- in particular, it appears that Acrobat was rotating, deskewing, etc. as part of its insistence on "Inferring Reading Order" page-by-page.

The solution was:

* Edit > Preferences... > Reading
* Reading Order: "Use reading order in raw print stream".
* Page vs Document: "Only read the currently visible pages".

From this thread https://community.adobe.com/t5/acrobat-discussions/the-message-quot-converting-scanned-page-to-searchable-image-quot-shows-when-i-am-paging/td-p/8893190

...

Votes

Translate

Translate
New Here , Dec 20, 2022 Dec 20, 2022

Ok I had the exact same issues, This is what worked for me:

Go to Preferences -> General -> Enable native OS mode for optimal performance (check this )

 

Screenshot at Dec 20 11-14-07.png

Votes

Translate

Translate
New Here , Sep 21, 2023 Sep 21, 2023

What worked for me (based on suggestion from another user here) was to uncheck "Smooth images" in Preferences > Page Display > Rendering.

Votes

Translate

Translate
replies 142 Replies 142
New Here ,
Sep 12, 2022 Sep 12, 2022

Copy link to clipboard

Copied

I gave up on Acrobat Pro DC and just got PDF Expert. Then I find out it's going to cost me $110 to cancel my Adobe subscription. Not like I've been paying them for a decade or so to waste my time with their uselessly performing product. 

 

I will probably never buy or subscribe to another Adobe product again. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 14, 2022 Sep 14, 2022

Copy link to clipboard

Copied

Envoyé pas pour moi

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 05, 2022 Nov 05, 2022

Copy link to clipboard

Copied

Hi! Switching to Read Mode with Ctrl-H to Read Mode and back (again with Ctrl-H) works. BUT WHY? and WHY NOT in Macs. It seems this double switching sets the Page View to Scroll Mode instead of a single Page View. So, basically, you can do that directly: Just go to View>Page Display>Enable Scrolling and then it is fixed. (at least in my case and I guess in the cases where Ctrl-H works)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 05, 2022 Dec 05, 2022

Copy link to clipboard

Copied

Neither Control H nor the other proposed solutions work. 

There is a simple solution: Ditch Acrobat reader. It is totally unusable on a latest generation Mac.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 20, 2022 Dec 20, 2022

Copy link to clipboard

Copied

Ok I had the exact same issues, This is what worked for me:

Go to Preferences -> General -> Enable native OS mode for optimal performance (check this )

 

Screenshot at Dec 20 11-14-07.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 02, 2023 Jan 02, 2023

Copy link to clipboard

Copied

I do not have this option available on my General settings.  Adobe is beginning to really anoy me with this

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 02, 2023 Jan 02, 2023

Copy link to clipboard

Copied

I moved to PREVIEW as my default PDF READER and I have to make do with it.
It’s a pain when it comes to trying to read comments made to a PDF
document.. virtually non existent .. but I don’t have anymore scrolling
lags--
- -
Denham

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 03, 2023 Jan 03, 2023

Copy link to clipboard

Copied

oops sorry.. I have just found out how to preview comment using MacOs
Preview.. Now I am officially moved from acrobat to Preview.. so many cool
features!!

--
*-*
*Denham Pereira *

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 12, 2023 Jan 12, 2023

Copy link to clipboard

Copied

For a VERY long time, Acrobat was one of my most stable pieces of software from Adobe. Over the last six months, this has become increasingly more and more problematic. It regularly freezes on start and just stops responding. Plus, heaven forbid I don't have the internet, because Acrobat won't work at all then. I don't know what's going on with the development team, but they've done something to make this software worse... much worse. I'm really getting frustrated with it and thinking of using an alternative PDF software out of necessity. I use it too much for it to be so glitchy all the time.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 03, 2023 Jan 03, 2023

Copy link to clipboard

Copied

I could not have said it better. The problems with slow functionality is more than scrolling; slow functionality has an impact on downloading, saving, viewing, editing, -- everything. One should not have to be an IT expert to fix what is clearly an Adobe issue.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 04, 2023 Jan 04, 2023

Copy link to clipboard

Copied

Hi @Colleen277864442m7t 

 

We are sorry to hear that.

 

What is the version of the Acrobat DC you are using? To check the version go to Help > About Acrobat and make sure you have the recent version 22.3.20281 (Mac) or 22.3.20282 (Win) installed. Go to Help > Check for updates and reboot the computer once.

Also try to repair the installation from the help menu (Win Only) and see if that works.

Please try to reset the Acrobat preferences as described here https://community.adobe.com/t5/acrobat-discussions/how-to-reset-acrobat-preference-settings-to-defau...

You may also try to create a new test user profile with full admin rights in Win or enable the root account in MAC and try using the application there and check.

 

Regards

Amal

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 06, 2023 Jan 06, 2023

Copy link to clipboard

Copied

Come on, this is a problem for years…

and yes, i am using the latest version and checked all the native options etc. etc.

Just have a look at the awful performance in comparison to Apple preview:

https://vimeo.com/786926568/b35ed0f699

 

This is "Bildschirmaufnahme 2023-01-06 um 16.21.11" by Karsten D. Wolf on Vimeo, the home for high quality videos and the people who love them.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 10, 2023 Jan 10, 2023

Copy link to clipboard

Copied

Hi @kaadeewee 

 

Thank you for sharing the video recording of the issue. Would you mind collecting the Adobe CC logs https://helpx.adobe.com/creative-cloud/kb/cc-log-collector.html and share them via any cloud storage, just upload the log file to the cloud, generate the link and share that link with us, for further investigation.

 

Regards

Amal

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 19, 2023 Jan 19, 2023

Copy link to clipboard

Copied

Control+H (switching to read-only mode) removes the markup tools, so it's NOT an answer if you are editing or proofing a PDF. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
May 23, 2023 May 23, 2023

Copy link to clipboard

Copied

I guess Adobue is using some old depricated api for displaying and scrolling pages. If it was written using proper tools there wouldn be a problem. Scrollig is also crap on Windows, slow and lagging. Using hand tool should be as usabe as on mobile devices but after dragging the page it just stops after releasing mouse button. The only smooth experience is on mobile devices where it uses proper API for scrolling content.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 14, 2023 Jun 14, 2023

Copy link to clipboard

Copied

Any news on this? same problem here...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 03, 2023 Sep 03, 2023

Copy link to clipboard

Copied

Same here. I cannot believe after so many users reported the exact same problem again and again to Adobe, they still have not fixed it. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 21, 2023 Sep 21, 2023

Copy link to clipboard

Copied

What worked for me (based on suggestion from another user here) was to uncheck "Smooth images" in Preferences > Page Display > Rendering.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines