Can't save: "The file may be read-only, or another user may have it open. Please save the document with a different name or in a different folder."

New Here ,
Jan 06, 2017 Jan 06, 2017

Copy link to clipboard

Copied

I've seen this issue all over the internet when I've searched for an answer. And it looks like it has been around for years. The only solution I've seen is to close the window pane in Windows. But what about for Mac users?

I just bought a new macbook pro. I had a 2011 macbook pro previously, with Acrobat Pro X. I backed up my computer in time machine, started up the new computer, and restored the old computer's data to the new one. Everything is the same and works fine except that I cannot save PDFs when I edit them. The only workaround I've found is to open a new folder, which  I can "save as" to the new location, but then I can't save future edits there unless I send them to yet another new folder.

The error message is: "The file may be read-only, or another user may have it open. Please save the document with a different name or in a different folder."

This is driving me crazy. Someone please help.

TOPICS
Create PDFs

Views

143.9K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

New Here , Aug 10, 2017 Aug 10, 2017

Thank you Michael, and I would like to just map out these instructions for windows users,  as it worked superbly!

1. Click on File Explorer

2. At the top of the page, go to the far left pull down menu call "View" (it's the last in the row of File_Home_Share_View)

3. Click on View

4. To the right, the first box is the "Panes" box and gives you 3 icons to choose from. Click once on the "Preview Pane" option.

5. Like Michael said above, you can also use ALT P to toggle this choice on and off.

This worked

...

Likes

Translate

Translate
New Here , Feb 28, 2018 Feb 28, 2018

This worked for me

If your file/asset is in a folder that is synced with Google Drive, Drop Box, One drive or the like simply quit the backup/sync utility and then hit save on the file. Note: "Pausing" the sync may not allow a file save. You must quit the sync app.

Likes

Translate

Translate
LEGEND ,
Jan 08, 2017 Jan 08, 2017

Copy link to clipboard

Copied

I have occasionally seen this crop up but not regularly. Acrobat X is not really Sierra compatible. It mostly works, but maybe you are seeing where it does not.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 08, 2017 Jan 08, 2017

Copy link to clipboard

Copied

Thank you. So does that mean that the solution is getting an updated version of Acrobat Pro?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 15, 2017 Jan 15, 2017

Copy link to clipboard

Copied

Download a trial of the new version and see if it still happens. I have seen this happen even with Acrobat DC but it is not a regular occurrence. I don't know if the problem is the software or the fact that my files are are constantly being synced to the cloud. It doesn't happen regularly, but it does happen more with Acrobat, but some other software once in a while.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 20, 2017 Jul 20, 2017

Copy link to clipboard

Copied

I too have been searching for an answer for this for a long time, in vein. None of the usual tricks like hiding the review pane, closing the folder, etc. worked for me. 

Desperate to solve the problem, I tried changing permissions in the folder properties in which I was trying to save the pdf files, and to my amazement, it actually worked.

After that, I went ahead and  changed permission to the users folder in which all my documents are located, and it solved my seemed to have solved my pdf saving problem once for all.

How to change permissions - Right click on the folder where your files are located, select properties, select security tab, edit permissions,  change it to full control.

A note of caution - this makes all files accessible for anyone to copy, modify, etc. - may not be a wise thing to do on a public computer or network.I did it for all users, since I am the only one who uses my laptop. If the internet is private and secure, selecting 'anyone' would be the best thing to do.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 08, 2019 Feb 08, 2019

Copy link to clipboard

Copied

Brilliant! That security setting worked for me! Been trying to find a fix for ages. Thank you

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 31, 2021 Jan 31, 2021

Copy link to clipboard

Copied

You saved my job man, thank you!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 02, 2021 Feb 02, 2021

Copy link to clipboard

Copied

Not working for me. When I went to change my permissions, they were on Full Control already.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 02, 2021 Feb 02, 2021

Copy link to clipboard

Copied

I found when I turned off the preview file option before opening, I was
finally able to save!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 18, 2021 May 18, 2021

Copy link to clipboard

Copied

Yes, this worked for me as well! I was already in Full Control for the folder, but closing the File Explorer window that I used to open the pdf did the trick. I assume it was related to the preview view that I like to have in my File Explorer... good call!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 16, 2022 Jun 16, 2022

Copy link to clipboard

Copied

This actually didn't solve my issue on Windows 11. Even quitting OneDrive didn't work. I ended up creating a network share to myself, and it was able to save it that way *derp*

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 17, 2021 Feb 17, 2021

Copy link to clipboard

Copied

I have been struggling!!!  Thank you!  This worked.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 16, 2021 Dec 16, 2021

Copy link to clipboard

Copied

I followed these steps and the folder got dissapeared 😕

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 16, 2022 Jun 16, 2022

Copy link to clipboard

Copied

So this doesn't work for me. I tried all these steps with reboots with no luck. 

My Setup: Clean install of Windows 11 and using a company OneDrive sync'd folder sharing a Sharepoint team folder with asset files managed by the company.

Now I can't uncheck the read-only option, OneDrive/Windows keeps putting it back to read-only 😒. So my only workaround with this, which could possibly be more secure than enabling Full Control for everyone is to create a network share to myself.

 

Setup the shared folder
1. Right-click folder enter properties
2. Click Sharing Tab
3. In Network File and Folder Sharing -> click the Share button
4. Add your account as owner. Everyone else can be read-write -> Click DONE

5. Advanced Sharing section -> Click the Advanced Sharing button

6. Click Permissions, add your account and choose allow Full Control. Everyone else can just read, screw them 😂😁.
7. Click Okay after adding yourself -> then click Apply -> click Okay -> click close on Properties window

 

This next part can be tricky if you never set up a network share before, but I'll add some steps for you, it's actually pretty easy

 

1. Open Command Prompt and type HOSTNAME and hit enter

2. A name will display something like Desktop-abc123 (note this, and you can always change this too, just Google Windows Change Desktop Name)

(Future note: If you have problems doing these steps with the host name. You can use the command IPCONFIG and get your local IP address which will be soomething like 192.168.x.x or 10.19.x.x isntead of the hostname)

3. Open FILE EXPLORER -> click in the address bar at the top and type \\[hostname]. Backslash is not the one with the question mark key on your keyboard; it's the one right above the ENTER key. So the typed out address in the File Explorer address bar should look like the blocktext below:

\\desktop-abc123

  

Note: You may be prompted to ender your credentials (most likely not, because you're the owner)

 

4. the File explorer will now display the shared folder you just created above. Right-click the folder and choose MAP NETWORK DRIVE

5. Choose a drive letter of your choice -> enable Reconnect at sign-in

6. Click Finish and navigate to THIS PC in File Explorer where you can find the USB Flash drives and local C: Drive.

7. You will now see the new mapped network drive, and you can bookmark in your quick access pane on the left.

8. HUZZAH! You can now save securely to your shared OneDrive (and probably your other cloud service drives too), and there's no performance issues since it's all done locally on the computer. You're just creating a logical network path to yourself. It's not going out to the network/router/internte and then back to you - for those who are wondering.

It also doesn't mean you have to start working through this shared folder, it's really just a secure work around for fixing the Illustrator issue. 

I sure hope this helps everyone.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 22, 2017 Jul 22, 2017

Copy link to clipboard

Copied

I was having the same issue and just realized this was being caused by having "FILE PREVIEW" enabled in my File Explorer. Not sure about on Mac, but on Windows you can turn this option OFF by hitting ALT+P in the Explorer.

As soon as I turned this off, I am now able to Edit AND Save without seeing that annoying "read-only" error message.


Hope this helps and good luck!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 10, 2017 Aug 10, 2017

Copy link to clipboard

Copied

Thank you Michael, and I would like to just map out these instructions for windows users,  as it worked superbly!

1. Click on File Explorer

2. At the top of the page, go to the far left pull down menu call "View" (it's the last in the row of File_Home_Share_View)

3. Click on View

4. To the right, the first box is the "Panes" box and gives you 3 icons to choose from. Click once on the "Preview Pane" option.

5. Like Michael said above, you can also use ALT P to toggle this choice on and off.

This worked for me perfectly.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 18, 2020 Aug 18, 2020

Copy link to clipboard

Copied

Thank you so much for directions! It worked

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 31, 2019 Jan 31, 2019

Copy link to clipboard

Copied

Thank you so much Michael!  This worked great and so simple!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 12, 2019 Dec 12, 2019

Copy link to clipboard

Copied

This SOLVED my problem!!!! Thank you, this was driving me crazy.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 04, 2020 Jun 04, 2020

Copy link to clipboard

Copied

You are a amazing!!! I have been having this issue for EVER and the Alt-P suggestion fixed my issue! Thank you so so much 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 18, 2020 Aug 18, 2020

Copy link to clipboard

Copied

Thank you so much Michaeld! it worked

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 17, 2020 Nov 17, 2020

Copy link to clipboard

Copied

This worked perfectly thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 02, 2021 Feb 02, 2021

Copy link to clipboard

Copied

Not working for me. The preview pane was off already.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 03, 2021 Feb 03, 2021

Copy link to clipboard

Copied

Update, bad news, good news.


Bad news: my usual workaround (saving the document with a new name each time) stopped working, with one document.

 

Good news: I was able to save the document to my desktop (Windows 10) instead of the folder where it belongs. I've now re-saved updated versions to the desktop, several times, no problems. No name change necessary.

 

When I finish with the document, I will try dragging it from the desktop to the appropriate folder.

 

Adobe: complaints about this go back YEARS. Please fix it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 14, 2022 Jan 14, 2022

Copy link to clipboard

Copied

This workaround worked for me, all the others failed. Thanks, a game changer to be sure!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines