Embedded video in a PDF file won’t play in adobe reader.

Community Beginner ,
Mar 20, 2021 Mar 20, 2021

Copy link to clipboard

Copied

When I embed a MP4 video in a PDF file, it plays nicely on Adobe Acrobat Pro, but not on Adobe Reader. (Both are the most recent edition, and run on Windows 10 Pro.) On reader, just the audio of the MP4 plays, but the image doesn’t show.

(I really don’t understand how Adobe add a feature to it’s PDF format that would be great if it worked, but turns out completely worthless since its own viewer can’t handle it.)

Does anyone know a solution or workaround?

TOPICS
Rich media and 3D

Views

6.7K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Community Beginner , Mar 01, 2022 Mar 01, 2022

Hi,

I don't if that helps as I'm using Windows but I might be able to help you with the sound only/black sceen video. 

You need to change the graphic settings used by Adobe Acrobat Reader/Pro. I don't know where it is on Mac, but on Windows, you change it to power saving/integrated graphics instead of Nvidia for instance.

Likes

Translate

Translate
Community Beginner , Mar 30, 2022 Mar 30, 2022

Hi Thomas,

It's in your OS/graphic card settings.

Here's the way to change it in Windows: 

  1. Search for Graphic Settings.
  2. In Choose an app to set preference, select Classic app, browse to your acrobat.exe file and click Add.
  3. In the Settings window, click Adobe then Options, and select Power Saving.

 

Adobe Troubleshooting soluce.png

 

If you have NVIDIA, you can also do it from the Control Panel, in Manage 3D settings > Program Settings.

 

ManonD_0-1648625399195.png

I hope this helps!

Likes

Translate

Translate
Adobe Employee ,
Mar 22, 2021 Mar 22, 2021

Copy link to clipboard

Copied

Hi Sérgio

 

Hope you are doing well and sorry for the trouble.  As described you are unable to play the video in Acrobat Reader DC application but the same video plays well in Acrobat DC.

 

Do you get any error message when you try to open the video in Acrobat Reader DC application? If yes, please share the screenshot of the same for a better understanding.

 

Please try to turn off the protected mode for testing (Win Only) and see if that helps. Go to Edit > Preference> Enhanced Security > uncheck 'Enable protected mode at startup' Turn off the protected mode and uncheck 'Enhanced Security' > Click OK and reboot the computer

Note: Please turn on the security after testing to avoid security risks.

 

Also, please check out the troubleshooting steps provided in the help page: https://helpx.adobe.com/acrobat/using/playing-video-audio-multimedia-formats.html and see if that works

 

Regards

Amal

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 23, 2021 Mar 23, 2021

Copy link to clipboard

Copied

Hi, Amal.

 

There’s no error message at all. Adobe Reader simply treats the video file as an audio file.

 

I did what you suggested. It was worse: Reader just crashed when I tried to play the video.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 24, 2021 Mar 24, 2021

Copy link to clipboard

Copied

Hi there

 

We are sorry to hear that. Please try to repair the installation and reboot the computer once. Go to Help > Repair Installation. 

 

Also make sure you have the latest version 21.01.20145 installed. Go to Help > Check for updates and reboot the computer. 

 

Also, please share the pdf file with us so that we can check it at our end.

Upload the file to document cloud, generate the link and share that link with us. 

 

Regards

Amal

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 25, 2021 Mar 25, 2021

Copy link to clipboard

Copied

We are sorry to hear that. Please try to repair the installation and reboot the computer once.

I did it, to no avail.

 

Also make sure you have the latest version 21.01.20145 installed.

Yes, that’s the version.

 

Also, please share the pdf file with us so that we can check it at our end.

Upload the file to document cloud, generate the link and share that link with us. 

Here it is:

https://documentcloud.adobe.com/link/review?uri=urn:aaid:scds:US:5f69c807-33c5-4e8c-9b10-f6501838a2f...

 

Thanks for your attention.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 28, 2021 Mar 28, 2021

Copy link to clipboard

Copied

Hi there,

 

Thank you for sharing the PDF file. I have tried to reproduce the issue on my end and opened the PDF file with Acrobat Reader DC and the video is playing fine.

 

Please try the following preference settings and see if that help:

Go to Edit (Windows), Adobe Acrobat (Mac) > Preferences > 3D and Multimedia Select 'Enable playing of 3D and multimedia content.' Also , go to Trust Manager under preferences and select Allow opening of non PDF file attachments with external applications > Click OK and reboot the application and check.

 

Regards

Amal

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 29, 2021 Mar 29, 2021

Copy link to clipboard

Copied

 

Please try the following preference settings and see if that help:

Go to Edit (Windows), Adobe Acrobat (Mac) > Preferences > 3D and Multimedia Select 'Enable playing of 3D and multimedia content.' Also , go to Trust Manager under preferences and select Allow opening of non PDF file attachments with external applications > Click OK and reboot the application and check.

 

I was using this exact settings already.

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 02, 2021 Sep 02, 2021

Copy link to clipboard

Copied

Hello, 

 

I have the same issue. The exported videos (embedded in powerpoint) play on my computer because I have Acrobat Pro. However, I've received reports that computers with Adobe Reader don't play the videos (retested today). 

Has it been solved? Or is there a workaround?

 

Thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 19, 2022 Jan 19, 2022

Copy link to clipboard

Copied

Same issue here and I am sending the files to clients and I can't mess with their settings. Trying to link video from YouTube, but that doesn't work either. So eventually I have placed link on the page that should be video and it has opened in YT... pretty lame 😞

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 19, 2022 Jan 19, 2022

Copy link to clipboard

Copied

Hi Lukak,

 

Hope you are doing well and sorry for the trouble. Would you mind sharing the version of the Acrobat Reader DC You are using? To check the version go to Help > About Acrobat and make sure you have the recent version 21.11.20039. Go to help > Check for updates and reboot the computer.

 

You may also try to create a new test user profile with full admin rights in Windows or enable the root account in Mac and try using the application there and check.

 

Regards

Amal

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 28, 2022 Feb 28, 2022

Copy link to clipboard

Copied

Has there been a work-around yet? Having the same issue, running version 2021.011.20039.  Added mp4 video to PDF using "Rich Media" Adobe Acrobat Pro DC on my Mac.  Then installed a clean version of Reader on a Windows 10 VM to test. When I first open the pdf with the embedded video it prompts me to allow 3D content. Once allowed nothing happens, all that is displayed is one frame from the video and no video controls. I close the PDF and re-open it, all that auto-plays is the sound and the video portion is black (still no video controlls).  Note, when I embedded the video I set it to play when in view and to stop when out of view. Any help on this is greatly apretiated. This process used to work a year or so ago, but ever since I noticed it asking to allow 3D content it has not worked for me...

 

Thank you

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 01, 2022 Mar 01, 2022

Copy link to clipboard

Copied

Hio there

 

Hope you are doing well and sorry to hear that.

 

Would you mind sharing the workflow/steps you did to create this PDF file with video? A small video recording of the same would be very helpful?

 

Also please share the version of the OS and the application and the PDF file in question with us so that we can check it at our end. https://helpx.adobe.com/document-cloud/help/sharing-pdfs.html

 

Regards

Amal

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 01, 2022 Mar 01, 2022

Copy link to clipboard

Copied

Hi,

I don't if that helps as I'm using Windows but I might be able to help you with the sound only/black sceen video. 

You need to change the graphic settings used by Adobe Acrobat Reader/Pro. I don't know where it is on Mac, but on Windows, you change it to power saving/integrated graphics instead of Nvidia for instance.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 07, 2022 Mar 07, 2022

Copy link to clipboard

Copied

Thank you Manon, that really worked!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 29, 2022 Mar 29, 2022

Copy link to clipboard

Copied

I am having the same issue (vidoe clips playing as audio only).
Where can one find the "power saving/integrated graphics" option?
I assume it is under Edit > Preferences > ?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 30, 2022 Mar 30, 2022

Copy link to clipboard

Copied

Hi Thomas,

It's in your OS/graphic card settings.

Here's the way to change it in Windows: 

  1. Search for Graphic Settings.
  2. In Choose an app to set preference, select Classic app, browse to your acrobat.exe file and click Add.
  3. In the Settings window, click Adobe then Options, and select Power Saving.

 

Adobe Troubleshooting soluce.png

 

If you have NVIDIA, you can also do it from the Control Panel, in Manage 3D settings > Program Settings.

 

ManonD_0-1648625399195.png

I hope this helps!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 03, 2022 Mar 03, 2022

Copy link to clipboard

Copied

I tried everything Amal suggested, and nothing worked for me. I just gave up.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 03, 2022 May 03, 2022

Copy link to clipboard

Copied

Same issue here, and after reading the whole thread I came to the same conclusion concerning embedding video in a pdf. -It's just not a robust product..

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 08, 2022 May 08, 2022

Copy link to clipboard

Copied

Adobe are being blatantly economical with the truth about this function in their software. It's about time Adobe told us plainly what's going on. I know for a fact that it's something to do with the Security settings in Acrobat Reader. But they insist on leaving the audio and video functionality in Acrobat knowing that no one can use it! How pathetic. Audio and Video in PDFs is so nice. So exciting to be able to share a PDF document with a video, or an ebook with a narration.My God, we should not be forced to go down the .epub route, and having to do it in InDesign. We lost Flash abilities in PDFs, now video and audio. Come on Adobe, make PDFs great again!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 19, 2022 Jul 19, 2022

Copy link to clipboard

Copied

I am having the same issue (vidoe clips playing as audio only), with Adobe Acrobat Pro DC (64 bit).

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 19, 2022 Jul 19, 2022

Copy link to clipboard

Copied

Hi there

 

Hope you are doing well and sorry to hear that. Is this an issue with a particular video that you embed into the PDF file or with all the Videos? Please try with a different video file and check. 

 

Also, try the steps shared in the correct answer marked above and see if that works for you.

 

Regards

Amal

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 19, 2022 Jul 19, 2022

Copy link to clipboard

Copied

Amal, with respect, please stop this nonsense with try this and try that. You, I and everybody knows that video and audio stopped working in PDFs a couple of years ago. Why? Please just be sincere and tell us why. In fact, post a PDF that you have created recently or do it now, it's really easy, just click add rich media and browse for a video. Then please attach it to your next post. I'm sure I'm not alone in eagerly awaiting your PDF with embedded audio and video. Made today. Come on, it's a 5 min job. Prove that you can still embed audio and video in a PDF today.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 20, 2022 Jul 20, 2022

Copy link to clipboard

Copied

Hi @Bernard5ED8 

 

Hope you are doing well. I have tried to reproduce the issue on my end and created the PDF with Video and its working fine.

 

You may please find the sample PDF file here https://acrobat.adobe.com/link/review?uri=urn:aaid:scds:US:1a7c9475-b3b1-49ab-94b7-9216fa1f0d04 

 

Regards

Amal

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 20, 2022 Jul 20, 2022

Copy link to clipboard

Copied

Thanks Amal! Yes your video works.

I am using Adobe Acrobat btw, not Adobe Reader.

I have also added a video of mine underneath yours. It plays but there are no transport controls on either video. To control the videos in the PDF you have to right-click on the video and click 'disable content' or 'enable content' then you'll see a play button. Even after the video has stopped you still have to disable content and it will be ready to play. 

So, what about the controls? Inside the Properties of the file you can see that 'all controls' have been enabled, yet no controls to be seen.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 21, 2022 Jul 21, 2022

Copy link to clipboard

Copied

Hi there

 

Please go through the help page https://helpx.adobe.com/acrobat/using/playing-video-audio-multimedia-formats.html and see if that works.

 

Regards

Amal

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines