• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
Locked
5

Hyperlinks not working in PDFs exported from Indesign [2016 and CS6]

New Here ,
Aug 23, 2016 Aug 23, 2016

Copy link to clipboard

Copied

I'm running Indesign CS6, I've created hyperlinks in the Indesign documents and have selected to include hyperlinks in the print dialogue when exporting the PDF. However, in the PDF the hyperlink doesn't work. I know I can add the link directly from the PDF, but we end up frequently recreating the PDF and it's a hassle to recreate the links each time since there's about 10 different links we have to create on multiple pages. I've tried exporting interactive PDFs and Adobe PDF (Print) and neither works. I've tried creating the links two ways in Indesign:

 

1) selecting text > right clicking > selecting Interactive > selecting new hyperlink destination;

 

2) also tried creating the hyperlink by selecting a grouped box (text and frame) > selecting drop down Object menu > Interactive > Convert to Button > Event "On Click" "Go to URL" > Entered URL desitination > Entered value into Description.

 

Using both methods in a PDF I created both Interactive and Print PDFs. Links did not work in either PDF.

TOPICS
Rich media and 3D

Views

124.0K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Community Beginner , Sep 13, 2016 Sep 13, 2016

I've had trouble before with this until I started unchecking the "Shared Hyperlink Destination" every time I create a new link. Maybe that will help you.

Votes

Translate

Translate
Community Beginner , Apr 19, 2021 Apr 19, 2021

checking "include hyperlinks" when creating the pdf is what worked for me. Thank you!   Indesign 2021

Votes

Translate

Translate
LEGEND ,
Aug 23, 2016 Aug 23, 2016

Copy link to clipboard

Copied

"selected to include hyperlinks in the print dialogue when exporting the PDF." Printing and exporting are different things, and the difference is crucial to hyperlinks. Which are you actually doing?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 18, 2019 Nov 18, 2019

Copy link to clipboard

Copied

Thanks, this one works for me!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 19, 2021 Apr 19, 2021

Copy link to clipboard

Copied

checking "include hyperlinks" when creating the pdf is what worked for me. Thank you!   Indesign 2021

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 20, 2022 Nov 20, 2022

Copy link to clipboard

Copied

Thank you so much!  This solved all my hyperlink problems.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 13, 2016 Sep 13, 2016

Copy link to clipboard

Copied

I've had trouble before with this until I started unchecking the "Shared Hyperlink Destination" every time I create a new link. Maybe that will help you.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 23, 2018 Aug 23, 2018

Copy link to clipboard

Copied

Many thanks. That worked for me.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 24, 2020 Aug 24, 2020

Copy link to clipboard

Copied

That did not work for me.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 27, 2020 Aug 27, 2020

Copy link to clipboard

Copied

Yessss, It worked for me too. Thanks a lot!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

Didn't work for me. I'm going to try clearing the cache. What an irritating problem! I've never had this before today.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 01, 2021 Oct 01, 2021

Copy link to clipboard

Copied

Could you please share exactly where "Shared Hyperlink Destination" is? I'm having the same problem as OP and none of these solutions are working for me, but I cannot locate where to uncheck "Shared Hyperlink Destination". Thank you. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 25, 2021 Oct 25, 2021

Copy link to clipboard

Copied

Try highlighting the hyperlink, righrt click Hyperlink then Edit Hyperlink. The dialogue box has a check box.

defaultvawtv3bxc5st_0-1635216784718.png

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 25, 2018 Feb 25, 2018

Copy link to clipboard

Copied

after an hour trying to solve the problem i cleared browser cache and it worked!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 26, 2019 Mar 26, 2019

Copy link to clipboard

Copied

Same here in some cases. I discovered that a hyperlink needed to be unique. We use a kind a CMS system to generate book documents, and requires in the non-scripted book-part unique url's. You can create one by adding a hashtag or utm code, like www.adobe.com#, we discovered

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Nov 24, 2021 Nov 24, 2021

Copy link to clipboard

Copied

Thank you!! This was the only thing that worked for me. I've used so much time on this.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 26, 2019 Nov 26, 2019

Copy link to clipboard

Copied

Sometimes, the hyperlink just gets "hinky." I believe that is the technically correct term. And you just need to delete the whole hyperlink and start over. I figured this out after trying all of the suggestions offered here - and then some -with none of them working. I could have saved myself an hour+ of frustration if I had known this. Hope this helps someone else. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 09, 2020 Jul 09, 2020

Copy link to clipboard

Copied

Amazing, thank you! This was the only thing that worked for me too. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 25, 2021 Jun 25, 2021

Copy link to clipboard

Copied

You must export to an interactive document PDF from indesign. And not all links from indesign work on all devices in the pdf. So what I mostly do is make some links afterwards in Acrobat DC on my created indesign PDF. I useed to spend a lot of time recreating all the links when I had to change my original indesign document. But now when I make the links in acrobat on my pdf, I save this final interactive version as a different file with _i in the name. Then, when I have to make text of graphic changes in the indesign document, I save a new PDF, then open my _i interactive PDF and just simply change all pages to the new PDF pages I just made from indesign. Then you don't have to make all the links again. You always have two files. The PDF made in Indesign, that I call your workdocument, and can change to newer versions. And the _i interactive final clickdocument where you once make all the links and then replace pages as needed.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 25, 2021 Jun 25, 2021

Copy link to clipboard

Copied

Wow! Thank you, that makes perfect sense and I would not have thought of it. I usually avoid doing any actual work in Acrobat as much as possible.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 08, 2022 Aug 08, 2022

Copy link to clipboard

Copied

THIS is the best and ONLY answer! Thank you. I have hundreds of links in a resources book that weren't working in the exported pdf-- if I had to go back to every single one to uncheck sharing as the 'correct' answer says, I'd be pulling my hair out.  NO! All you need to do is save it as an interactive pdf. THANK YOU!!!!

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 15, 2022 Sep 15, 2022

Copy link to clipboard

Copied

Unchecking the Shared Hyperlink option didn't work for me either.
However, I found a trick to deal with the problem= I get rid of the hyperlink altogether and create a white bloc with the hyperlink on top of the area I want to be clickable, then I set the block to multiply. So far it's always worked!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 17, 2022 Nov 17, 2022

Copy link to clipboard

Copied

None of the other solutions worked so I'm going to share mine:

Add "www." to the URL. For example, instead of https://adobe.com use https://www.adobe.com 

It's so ridiculous, but it works!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 07, 2023 Jul 07, 2023

Copy link to clipboard

Copied

The hyperlink were correctly set in InDesign, when I exported it to pdf file, the link were not clickable. 

Check if your page have transparency of images with trasnparency, remove those transparency. This works for me. Just sharing.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 29, 2023 Sep 29, 2023

Copy link to clipboard

Copied

Quitting and restarting InDesign and Acrobat fixed this for me.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 08, 2023 Nov 08, 2023

Copy link to clipboard

Copied

LATEST

Bonkers, restarting InDesing and Acrobat fixed it for me too, thanks!!!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines