Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Microsoft Edge Keeps Hijacking My .pdfs

New Here ,
Nov 21, 2019 Nov 21, 2019

Copy link to clipboard

Copied

Has anyone else had trouble with their Windows 10 machine resetting their default program for .pdfs to Microsoft Edge no matter how many times you tell it Adobe Acrobat Pro DC?  If so, have you found a fix or do I just have to "deal with it".  It's getting to be very frustrating -- some days I change it back a dozen times or more.  If anyone has any suggestions, I will be very grateful.  Thank you.

TOPICS
General troubleshooting

Views

2.9K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Adobe Community Professional , Dec 07, 2020 Dec 07, 2020
 But to be sure you can try the same guidance as mentioned above with a new user profile account in the same computer. If it works in the new user account but not in the current user account, then we can assume something is wrong in a temporary cache folder or similar of the current user account that may need to be cleaned or deleted for good (but I may be wrong). However, I am more inclined to think that you may be missing a step. When you right-click on a PDF file, select from the contex...

Likes

Translate

Translate
New Here , Feb 15, 2021 Feb 15, 2021
None of the various registry hacks or Edge file renaming/removal tricks worked for me. What did work was:Launch EdgeEllipsis (…) in upper rightSettingsCookies and site permissionsPDF documentsSet Always open PDF files externally to ON

Likes

Translate

Translate
Adobe Community Professional ,
Nov 21, 2019 Nov 21, 2019

Copy link to clipboard

Copied

Hi,

 

Try the following work around through registry editing:

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\System

and paste the following string value DisablePDFHandlerSwitching   then add 1 in the value field

 

idea taken from this link : https://www.adobe.com/devnet-docs/acrobatetk/tools/AdminGuide/pdfviewer.html

 

 
 

pdf ownership-registry.png

 

If the method above doesn't work try these other steps:

 

https://appuals.com/how-to-disable-edge-pdf-viewer-in-windows-10/

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 07, 2020 Dec 07, 2020

Copy link to clipboard

Copied

Thank you for posting this. I am having the same issue. I followed all of the steps above, and it worked, but ultimately did not fix the problem.

My application settings no longer reset to Edge as the default application, but the files themselves still do . I will go in to the settings and choose adobe acrobat as the default application for .pdf's, but then a few minutes later Windows will reset and no default application will be listed. Therefore, the files will still default to Edge. 

I've been trying to fix this problem for over a year and it is driving me crazy. I'm sure it is intentional on Windows part, but there has to be a solution by now!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 07, 2020 Dec 07, 2020

Copy link to clipboard

Copied

 But to be sure you can try the same guidance as mentioned above with a new user profile account in the same computer.

 

If it works in the new user account but not in the current user account, then we can assume something is wrong in a temporary cache folder or similar of the current user account that may need to be cleaned or deleted for good (but I may be wrong).

 

However, I am more inclined to think that you may be missing a step.

 

When you right-click on a PDF file, select from the context menu "Open with"  and then from the next context menu select "Choose another app".

 

The slide below shows the following options:

 

defaultPDFhandler.png

 

 

Left-click once on "Adobe Acrobat DC" to select the desired PDF handler from the list of programs, and then tick the checkbox below (lower left corner of that context menu) then click OK.

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 15, 2021 Feb 15, 2021

Copy link to clipboard

Copied

None of the various registry hacks or Edge file renaming/removal tricks worked for me. What did work was:

Launch Edge

Ellipsis (…) in upper right

Settings

Cookies and site permissions

PDF documents

Set Always open PDF files externally to ON

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 15, 2021 Feb 15, 2021

Copy link to clipboard

Copied

Thank you for sharing that feedback.

 

I think that is actually the correct answer.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 02, 2021 Aug 02, 2021

Copy link to clipboard

Copied

I have a GPO pushing that, and I still see Edge taking over.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 17, 2021 Aug 17, 2021

Copy link to clipboard

Copied

LATEST

That's nice. Unforetunately, that setting no longer exists. This is what you see now:

 

Derek5CFC_0-1629211330618.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 15, 2021 Feb 15, 2021

Copy link to clipboard

Copied

The problem is that when MS updates Windows, it is wiping out the user preferences and, consequently, hijacking PDFs to MS Edge rather than Acrobat (or any other brand of PDF reading program). Your preferred program for reading PDFs is ignored by the new version of Windows.

 

MS's action could be interpreted as "anticompetitive conduct" by the US government's FTC Technology Enforcement Division.

 

If you are a US citizen, file a complaint with the FTC! See this webpage for information about how to do this. Just takes a simple email to the address listed: https://www.ftc.gov/about-ftc/bureaus-offices/bureau-competition/inside-bureau-competition/technolog...

 

Personally, I'm sick of this s*** from Microsoft. It's been happening for 2-3 years. Let's get it stopped.

 

Design + Accessibility | Author | Designer | Programmer | Trainer

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 28, 2021 Jul 28, 2021

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 02, 2021 Aug 02, 2021

Copy link to clipboard

Copied

Thanks for posting that.

Planned

Edge should respect the default PDF viewer

49 weeks

 

Wow, that's nearly a year away...  <sigh>

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 02, 2021 Aug 02, 2021

Copy link to clipboard

Copied

That's how long it's been on the list, not an expected change date.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines