Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Odd nested <xfa:data> nodes in answer files exported from an XFA

Community Beginner ,
Aug 11, 2021 Aug 11, 2021

Copy link to clipboard

Copied

On most documents we have developed our exported answer xml files look like this:

<?xml version="1.0" encoding="UTF-8"?>
<topmostSubform>

  <txt_int_client_forename/>

  <txt_int_client_middlename/> etc...

 

However, occasionally they come out like this:

<?xml version="1.0" encoding="UTF-8"?>
<xfa:data xmlns:xfa="http://www.xfa.org/schema/xfa-data/1.0/">

<xfa:data>

<topmostSubform>

  <txt_int_client_forename/>

  <txt_int_client_middlename/>

 

Why are these additional nodes being inserted, please? It would be easier to use the data files if we could keep the top level nesting consistent.

 

Thank you for any advice.

 

TOPICS
Edit and convert PDFs, General troubleshooting, PDF forms, Standards and accessibility

Views

29

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Aug 11, 2021 Aug 11, 2021

Copy link to clipboard

Copied

Am I right that this is a form made in Designer (LiveCycle Designer/AEM Designer)?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 11, 2021 Aug 11, 2021

Copy link to clipboard

Copied

LATEST

Yes, Livecycle designer.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines