Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


PDF File causes Adobe Acrobat DC Pro to lag when attempting to edit it

New Here ,
Aug 02, 2021 Aug 02, 2021

Copy link to clipboard

Copied

I have a user who is constantly making edits to a PDF document that tracks the floorplans and seating arrangements of the office. The document is about ~22mb (36in x 24in) and can be viewed easily but as soon as edits are being made to the document the Adobe Acrobat DC Pro application starts to lag or freeze for several seconds for each character/number added to the document. 

TOPICS
Crash or freeze, Edit and convert PDFs

Views

31

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 03, 2021 Aug 03, 2021

Copy link to clipboard

Copied

LATEST

Hi Syedn

 

Hope you are doing well and sorry for the trouble. As described the Acrobat Pro DC starts to lag and freeze when you try to edit the PDF file.

 

- Is this a behavior with a particular PDF file or with all the PDFs? Please try with a different PDF file and check. If te file is stored on a shared network/drive, please download it top your computer first and then try to edit and see if that helps.

 

- What is the version of the Adobe Acrobat DC you are using? To check the version go to Help menu > About Adobe Acrobat and make sure you have the latest version 21.05.20060 installed. Go to Help menu > Check for Updates and reboot the computer once.

 

Also, go to Edit (Win), Adobe Acrobat (Mac) > Preferences > Page Display > Under , Rendering Uncheck 'Use Page Cache' > Click OK  and reboot the application and see if that makes any difference.

 

You may also try to turn off the protected mode for testing (Win only) Go to Edit > Preferences > Enhanced Security > Uncheck 'Enable protected mode at startup' Turn off the protected mode and Uncheck 'Enhanced Security' . Click OK and reboot the computer once.
Note: Please turn on the security after testing to avoid any security risk.

 

Regards

Amal

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines