• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

"Cannot use adobe reader to view pdf in your web browser" error in Windows 7 and Acrobat pro 8.1.7

New Here ,
Oct 22, 2009 Oct 22, 2009

Copy link to clipboard

Copied

I get the error "Cannot use adobe reader to view pdf in your web browser.  Reader will now exit.  Please exit your browser and try again" in Windows 7 x32 and Windows 7 x64 with Acrobat pro 8.1.7.  This happens when trying to open  a PDF file in Internet explorer 8.0.760 or when I open a PDF in Quickbooks 2008.  If I answer ok or cancel the file opens normally.  If I open acrobat 8 first then the pdf files open as expected.  I also tried a copy of Acrobat reader with no difference in the outcome.  Since this happens on two different computers one fresh copy of windows 7 x64 the other an upgrade to windows 7 x32 and they used to work before the change to windows 7, I assume there is some kind of incompatibility with windows 7 and acrobat.  Is this a known issue and will it be fixed in an update to acrobat in the near future?

TOPICS
Create PDFs

Views

254.5K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Nov 04, 2009 Nov 04, 2009

For Windows 7 you will need Adobe Acrobat 9.1.

Likes

Translate

Translate
replies 112 Replies 112
Explorer ,
Nov 12, 2009 Nov 12, 2009

Copy link to clipboard

Copied

So I paid $xxx for Acrobat 8.x, yet I can't use it to view PDFs from websites.  And even the free Acroreader 9.x doesn't work.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 14, 2009 Nov 14, 2009

Copy link to clipboard

Copied

Easy fix:

1. Open Acrobat 8

2. Go to Edit > Preferences > Internet

3. Uncheck "Allow fast web view"

...

vlad

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 14, 2009 Nov 14, 2009

Copy link to clipboard

Copied

Thanxs Vlad,

But..... that doesn't work. Maybe after a restart.... but I have no high hopes.

To bad !

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 18, 2009 Nov 18, 2009

Copy link to clipboard

Copied

I've done some more experimenting, my solution (post 16) worked only because I had Acrobat open when I clicked a link to a PDF. That seems to be the trick, have Acrobat open, as impractical as that is.

...

vlad

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 18, 2009 Nov 18, 2009

Copy link to clipboard

Copied

Hi Vlad,

Thanxs, it's inpractical yes, but this works !

thanxs !

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 14, 2009 Nov 14, 2009

Copy link to clipboard

Copied

Here is the workaround/fix.

1. Open Acrobat 8.1.7

2. Go to Edit > Preferences > Internet

3. Uncheck "Display PDF in Browser"

Now when you click on a PDF link in a browsing session it will launch Adobe Acrobat Pro in a separate window to view the PDF instead of trying to view it inside of Internet Explorer.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 15, 2009 Nov 15, 2009

Copy link to clipboard

Copied

Sorry, that is not going to work.

I am a developer in SAP Webdynpro and I have to open PDF forms within the webpage. ( I interact with a server backend)

So it might work for some of us. But not for me.

Thanxs

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 08, 2009 Dec 08, 2009

Copy link to clipboard

Copied

I am using Acrobat Standard 8.1 with Windows 7. In Acrobat: Edit, Preferences, Internet: unchecking both Display PDF in browser and Allow fast web view solved what has been this annoying problem for me. (I did also verify that IE 8 showed Acrobat as the PDF viewer).

Adobe Help includes this statement:

You can view PDFs in a supported web browser, or you can set your Acrobat Internet preferences to open linked or downloaded PDF files in a separate Acrobat window. If you open PDFs in Acrobat outside the browser, you cannot use Fast Web Viewing, form submittal in a browser, or search highlighting on the web.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 15, 2009 Nov 15, 2009

Copy link to clipboard

Copied

I simply registered the product and the error went away... I tried all of the above fixes but registering seemed to be what fixed it.  Be sure to restart your browser afterwards.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 18, 2009 Nov 18, 2009

Copy link to clipboard

Copied

I have this issue several times on various users PC's. What I've done to resolve is the following Registry import:

1. Create a .reg file using Notepad

2. Copy the following in document (all in between the hashmarks) or use registry doc i attached to this response

--------------------

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\acrobat\DefaultIcon]
@="C:\\Program Files\\Adobe\\Reader 9.0\\Reader\\AcroRd32.exe"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\acrobat\shell]

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\acrobat\shell\open]

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\acrobat\shell\open\command]
@="C:\\Program Files\\Adobe\\Reader 9.0\\Reader\\AcroRd32.exe /u \"%1\""

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\SOFTWARE\Adobe\Acrobat\Exe]
@="\"C:\\Program Files\\Adobe\\Reader 9.0\\Reader\\AcroRd32.exe\""

-----------------------

3. Save as something like AdobeFix.reg

4. Run regedit and import this entry into your registry then restart PC.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 19, 2009 Nov 19, 2009

Copy link to clipboard

Copied

People don't use blakmoon71 sollution unless you are working on a test machine.

On my machine it totally screwed my adobe reader.

I get more errors than ever, and no more pdf viewing inside a webbrowser.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 19, 2009 Nov 19, 2009

Copy link to clipboard

Copied

You could try a "modificated" version of blackmoons suggestion:

1) In Windows Explorer change the default application for the file type pdf to the Adobe Reader.

2) In the registry edit only this key "[HKEY_CLASSES_ROOT\Software\Adobe\Acrobat\Exe]" manually

to the full path to the Adobe Reader.


E.g. "C:\Program files\Adobe\Acrobat [version]\Reader\AcroRd32.exe"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 19, 2009 Nov 19, 2009

Copy link to clipboard

Copied

tvandersluijs - I'm sorry if that screwed up your machine however:

1. What version of Adobe Reader are you using because as you can see the registry entry is for Adobe Reader 9, if ur using Adobe Reader 8 then u need to specify ur version as PAllens entry suggested - "E.g. "C:\Program files\Adobe\Acrobat [version]\Reader\AcroRd32.exe""

2. I've used this solution significantly because I have come across this specific issue for multiple users.

3. All the registry entry does is tell Windows what program to use by default to open/view PDF documents.

My intention wasn't to screw up ur machine or anybody elses as I said I've used this solution many times however what I've should gave is the disclaimer to backup ur registry before u make mods so u can revert back in case. Also the ony other thing I can think of is that this solution was for Windows XP using registry editior 5, I'm noticing that the title of this thread is Windows 7.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 19, 2009 Nov 19, 2009

Copy link to clipboard

Copied

Don't Worry blakmoon71. (yes I am using version 8, or I was using version 8... read on... read on....)

It could not get any worse anyway, right ?

And it actually helped at the end.

First I could not use Reader 8 or 9 having the "cannot use adobe reader to......" error.

After your so called fix, it was totally screwed.

So I did a uninstall of 8. Restarted, did a clean of my register with CCleaner, did another restart, started Windows 7 into save mode, did another clean of my register with CCleaner, did a restart.

Then I installed Adobe Reader 9 for windows 7.

And guess what !

The problem is gone !

No more "Cannot use adobe reader to view pdf in your web browser" error !

Wowowowooo !!!!!!!!!!!!!!!!!!!!!

Finally it is gone. Don't know if the error would be gone if I installed reader 8 again. But for now I'm a happy person.

So blakmoon71, thank you very much after all !!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 19, 2009 Nov 19, 2009

Copy link to clipboard

Copied

And I'm sure if Adobe would ever have a fix for this bug it would be to first do a reformat and reinstall of Windows.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 20, 2009 Nov 20, 2009

Copy link to clipboard

Copied

Had the exact same problem on my computer running Windows 7 and Acrobat Pro 8.1. I also have both Firefox and IE 8.

The solution that worked for me was really simple, just open Firefox and in the Tools menu, choose Internet options, goto the programs tab and change the associated action for PDF files to Use Adobe Acrobat 8.1.

This solved the problem both in IE and Firefox. Hope this helps.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 21, 2009 Nov 21, 2009

Copy link to clipboard

Copied

I've also been experiencing this same issue, for about three months now. (http://forums.adobe.com/thread/480371?tstart=0).  I'm not exactly an expert in these things, but I'm guessing the issues track back to the nppdf32.dll plugin.  For Firefox, it has not been updated since 8.1.3.  For Internet Explorer, the plugins appear to be from 8.1.  I opened nppdf32.dll with a hex editor, and although I couldn't find much of anything of any use to me, I did find the error message we're all seeing buried in the code.  Perhaps all that needs done is an update to the browser plugins?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 22, 2009 Nov 22, 2009

Copy link to clipboard

Copied

After years of living with this problem, I finally found an easy solution!!

This page contains a simple .reg file that fixes Adobe's PDF preview handler on 64-bit versions of Windows.

  • Open RegEdit and go to:

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Classes\CLSID\{DC6EFB56-9CFA-464D-8880-44885D7DC193}

  • There should be an existing AppID value, incorrectly set to {6d2b5079-2f0b-48dd-ab7f-97cec514d30b}

  • Change the AppID value to {534A1E02-D58F-44f0-B58B-36CBED287C7C}

  • Credit--> http://www.pretentiousname.com/adobe_pdf_x64_fix/index.html and Maximum PC December 2009 issue page 26

    Likes

    Translate

    Translate

    Report

    Report
    Community guidelines
    Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
    community guidelines
    New Here ,
    Nov 22, 2009 Nov 22, 2009

    Copy link to clipboard

    Copied

    Thanks for the information, but this does not cure the issues I am experiencing with opening PDF's in a web browser with Windows 7 64-bit.  This may very well cure other issues involving preview handlers on 64-bit Windows, but I think the browser issues are related to the browser plugin and its compatibility with Windows 7, and not preview handlers.  After applying both registry edits discussed in the article, and then rebooting, I still get the "Cannot use Adobe Reader..." when trying to open PDF's in Firefox and IE8 on Windows 7 x64.

    I did not experience this problem on Vista x64 - only 7 x64.  Is this issue limited to 64-bit Windows 7, or are users also experiencing it on 32-bit Windows 7?

    Likes

    Translate

    Translate

    Report

    Report
    Community guidelines
    Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
    community guidelines
    Explorer ,
    Nov 22, 2009 Nov 22, 2009

    Copy link to clipboard

    Copied

    The original posting in this thread says the problem is in Win7 32 bit.  None of the "fixes' posted in this thread have fixed the problem for me.

    Likes

    Translate

    Translate

    Report

    Report
    Community guidelines
    Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
    community guidelines
    New Here ,
    Nov 22, 2009 Nov 22, 2009

    Copy link to clipboard

    Copied

    Same here. None of the solutions above work for me.

    Actually the only workaround I found is to disable the PDF to open inside the browser's windows (instead it open into Acrobat program window).

    Likes

    Translate

    Translate

    Report

    Report
    Community guidelines
    Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
    community guidelines
    New Here ,
    Nov 23, 2009 Nov 23, 2009

    Copy link to clipboard

    Copied

    I had a similar problem using Firefox as a browser in Vista with Adobe Reader 9.2. The message says "The Adobe Acrobat

    /Reader that is running can not be used to view PDF files in a web browser. Please exit Adobe Acrobat/Reader and exit your web browser and try again"

    This is completely useless as advice and Adobe support is no help either. However, using the advice from this forum, I have tried various combinations to arrive at a solution that works:

    • Open Adobe Reader and uncheck the box "Display PDF in browser"; restart computer (only need to do this once)

    • Open Adobe Reader
    • Open the message website in Internet Explorer (not Firefox)
    • Go to the message; if a security message comes up as a banner, check OK to allow the file download
    • Go back to the message and it will open in Adobe Reader

    Not the cleanest solution but it's solved six months of headaches for me!

    Having read a little more, I also tried the Firefox solution from above. In my version:

    • In Firefox open 'Tools'
    • Open 'Options'
    • Change the option for opening 'Adobe Acrobat Document' to 'use Adobe Reader 9.2 (default)'

    I can now use both IE and Firefox - thanks for your suggestions!

    Likes

    Translate

    Translate

    Report

    Report
    Community guidelines
    Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
    community guidelines
    New Here ,
    Jun 12, 2010 Jun 12, 2010

    Copy link to clipboard

    Copied

    Thank you for this posting. I was able to solve my problem.

    Likes

    Translate

    Translate

    Report

    Report
    Community guidelines
    Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
    community guidelines
    Guest
    Nov 30, 2009 Nov 30, 2009

    Copy link to clipboard

    Copied

    After many hours of dealing with this problem, I finally got it to work.  I am using Windows 7 w/ 64 bit on a Sony Vaio.

    I had Adobe Acrobat 8 Pro and Acrobat Reader 9.2 loaded.  I noticed that when I got the error box, it was Acrobat 8 Pro that was generating it, not Reader 9.2.

    I checked file associations and it was associating pdf and pdfxml files to 8.1.  I changed it to 9.2.  No difference.  I went into Manage Add Ons and saw that my plug ins were mostly being used from 8.1, not 9.2.  Disabled and enabled the lot in many different ways, to no avail.

    I finally uninstalled 9.2 so that I only had 8.1 running anything pdf and it would work sometimes....but not without the error box first.  I basically gave up hope and was awaiting Adobe to fix their little problem.

    Then during the day, my Sony Vaio care went off and said it was time for a scheduled maintenance.  It cleans the registers, defragments etc etc, so I activated the maintenance.

    Later that evening, I decided to exercise futility once more and downloaded and installed Abobe Reader 9.2 once again to try and figure out this problem.

    Well....after the download, it works flawlessly everywhere it previously failed.  I rechecked the file associations in Windows 7 and they are now associated with 9.2...one of them still 8.1.  I checked the plug ins and they are still operating out of 8.1 except for one that is using 9.1.

    So the fix for me was uninstall 9.2, do a registry clean, re install 9.2.  I doubt if Adobe drummed up a fix between my problem and no problem.

    Good luck.

    Likes

    Translate

    Translate

    Report

    Report
    Community guidelines
    Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
    community guidelines
    New Here ,
    Nov 30, 2009 Nov 30, 2009

    Copy link to clipboard

    Copied

    I have been watching this forum post since I started it and so far the only thing that has mostly worked for me is setting the following; in Adobe acrobat preferences under Internet, uncheck "Display PDF in browser".  This brings up a separate PDF window without the error.  I have tried checking and un-checking it and every time it is checked the error comes up.  So at this point to avoid getting the annoying error I just leave the "Display PDF in browser" box unchecked and get a separate window with no errors.  I haven't been able to try it on my 64 bit system as I had to send it in for other unrelated issues, I will let you all know when I get it back.

    Likes

    Translate

    Translate

    Report

    Report
    Community guidelines
    Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
    community guidelines