• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
3

“Reading Options” for screen readers

Community Beginner ,
Dec 27, 2023 Dec 27, 2023

Copy link to clipboard

Copied

Hi!

 

I've been tagging documents and testing them with JAWS; they read fine and perform as expected. However, I noticed in the Accessibility menu that there's a "Reading Options" button. The default setting is "do not read the document" for screen reader options. And for reading order, "tagged reading order" is the default. I DO want screen readers to be able to access this content, but changing the screen reader setting to anything but the default results in it returning to the default...

 

I know that the Acrobat "full check" isn't perfect but it does make sure the minimum things for screen readers are there, like: Does this document have tags, and is the read order set to follow the tags? So I can't believe this toggle makes documents invisible to screen readers... and I've never seen this toggle mentioned on any help site / forum as something that MUST be clicked. And like I said, JAWS reads the documents fine with "do not read the document" selected.

 

So my question is: What is this setting, and how do I use it? Thank you!!

 

 

TOPICS
Standards and accessibility

Views

183

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 27, 2023 Dec 27, 2023

Copy link to clipboard

Copied

Additional information--

 

From this page: https://helpx.adobe.com/reader/using/accessibility-features.html

 

It sounds like this feature is most in use for untagged documents, when Acrobat’s reading tool is attempting to relay the document to a screen reader—either the whole document at once, or page by page… is that right? So for a properly formatted and tagged document, this setting isn’t an impediment to accessibility?

 

Like I said, I’ve had no issues testing documents with JAWS. I know screen readers aren’t the final test in that regard, but it does make me think that having “do not read document” selected doesn’t actively prohibit screen readers from reading the document and accurately conveying headers, lists, and other content set up in the tags.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 27, 2023 Dec 27, 2023

Copy link to clipboard

Copied

And one more bit of additional info—

 

The "default" option in the "Accessibility > Reading Options" menu is determined by the setting on page 4 of the accessibility setup assistant menu. So when I was changing this setting in the "Reading Options" menu, I wasn't really changing it... Clicking "confirm" there doesn't actually change anything—each time I reopened the menu, it had reverted. So I updated my Setup Assistant and now I can choose something other than the terrifyingly named "do not read" option!

The setup assistant contains options for tagged and untagged documents explicitly (e.g. on page 3 where you set an order for untagged documents). So I still think my initial theory is correct that this setting is primarily for untagged documents... It tells Acrobat's built in reader how to present info to screen readers and that it's not the case that it prevents screen readers from going through a tagged document. At least, this seems to be the case from my testing with JAWS.

 

Can anyone confirm this definitively? Thank you!

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 27, 2023 Dec 27, 2023

Copy link to clipboard

Copied

LATEST

Ok, last update, because I think I’ve solved it. I had a test doc where I changed the settings. Then I opened up the document I’d been working on before to find the setting was already updated there…

 

And I opened up a doc someone else had sent me and found the same thing (I'd checked the settings on this doc previously and it had previously said "do not read" as well).

 

Then it hit me: Reading Option. Like, if I’m using Acrobat to read stuff (not just to remediate stuff), it’s the setting for how I want to read docs. So I think that’s the solution—it’s my personal setting, not a “do not read!” stamp on PDFs.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines