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Problem:
When IT administrators intend to deploy Reader and Acrobat using App-V 5.0 SP3 on client machines, users may face an issue with Acrobat if they haven't initiated it at least once on their devices.
Cause of the problem:
The issue arises because App-V Reader includes several "HKCU/Adobe/*" hives in the App-V pass-through list. This inclusion creates these registry keys outside the VREG on client machines.
Solution:
For the pass-through registry keys to function correctly, the presence of HKCU/Adobe/Adobe Acrobat/{DC|2015} in the local registry hive on the machine is essential. This key is generated upon the initial launch of App-V Reader using the Runtime.bat script, similar to the one outlined in the Acrobat Reader Sequencing Guidelines.
Consider one of the following workarounds:
Runtime.bat
@echo off
SET ChannelName=2015
REM Set the ChannelName to DC to run this script on the Continuous track.
SET NativeKey="HKEY_CURRENT_USER\Software\Adobe\Adobe Acrobat\%ChannelName%"
REG QUERY %NativeKey%
IF %ERRORLEVEL% EQU 0 GOTO EXIT
REG ADD %NativeKey%
:EXIT
DeploymentConfig.xml
<UserScripts>
<StartVirtualEnvironment RunInVirtualEnvironment="false">
<Path>cmd.exe</Path>
<Arguments>/c "[{AppVPackageRoot}]\..\Scripts\Runtime.bat"</Arguments>
<Wait RollbackOnError= "false"/>
</StartVirtualEnvironment>
</UserScripts>
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