Text in a text box disappears upon clicking outside the text box

Community Beginner ,
Jun 07, 2012 Jun 07, 2012

Copy link to clipboard

Copied

I am working on a Macbook Pro in Lion 10.7.  I am using Adobe Acrobat X Pro. 

I create a text box and type words in the text box.  As soon as I click outside the text box, the text in the textbox disappears.  The text box is still there.  As soon as I click back inside the text box the text reappears.  I've confirmed that the text is black.

I've seen multiple posts on the same problem but none of the solutions I've seen work.

This is so frustrating that I'm giving up on Adobe Acrobat X Pro and using a free PDF editing program in using Windows 7 in Parallels on my Macbook.  Given how much Acrobat X Pro cost, I'm pretty fed up with Adobe generally.

I followed a link to a solution to modify the register in Windows but I don't know how to do that on a Mac.  Morever, it's simply absurd that Acrobat Pro X is utterly useless for editing a simple PDF document.  This isn't a form.  It's a PDF document with no other fields.  I just want to add text.

Any help would be appreciated.

TOPICS
PDF forms

Views

147.2K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

LEGEND , Jul 24, 2012 Jul 24, 2012
Well, there's a lot going on here. Part of the confusion is the different terms that are being used, and where you posted. Although you've confirmed you aren't working on a form, you DID post in the Forms forum, so it isn't too surprising you got a lot of advice about forms.I think I've discovered something by looking at your file and experimenting. You're adding text, probably the only way you've found so far. This is something rather old and creaky called the 'typewriter tool', which not so ma...

Likes

Translate

Translate
Explorer ,
Apr 20, 2013 Apr 20, 2013

Copy link to clipboard

Copied

Actually, this is not just a work-around. This is the answer!

I tried it and realized that the point seemed to be that I needed to verify that I trusted/wanted access to the data. Once I created the .fdf document, I got a bright yellow banner across the top where the purple one used to be and clicking on that to "access the data" gave me a properly filled out form. Not very intuitive, but I guess in the interest of verifying that I really wanted to access data from a downloaded file...I guess that was the solution?

Anyway, you are CORRECT! It worked. My form is now readable, printable, etc., just the way it was when it left the filler-outer's desktop and took off toward my computer.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 24, 2012 Jul 24, 2012

Copy link to clipboard

Copied

So you're saying Adobe Acrobat X Pro doesn't work on the Mac OS?! That's hard to imagine but apparently all too true.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Jul 24, 2012 Jul 24, 2012

Copy link to clipboard

Copied

OK,  the problem is that the annotations, of which there are three, are using transparency in an odd way for Acrobat 4 compatibility. I know it's made by Acrobat X but stay with me if you want to workaround the issue. 

Preflight.png

Whether that transparency was on purpose or not it really doesn't matter.  What you need to do to fix the file that you posted and probably any others that display this behavior is:

1.   Go to the "Print Production" panel.

2.  Select "Preflight"

3.  In the Preflight window, select "Compatible with Acrobat 4"

4.  Click the "Analyze and Fix" button

5.  Save the file to a new name

6.  Click the Save button.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jul 24, 2012 Jul 24, 2012

Copy link to clipboard

Copied

Well, there's a lot going on here. Part of the confusion is the different terms that are being used, and where you posted. Although you've confirmed you aren't working on a form, you DID post in the Forms forum, so it isn't too surprising you got a lot of advice about forms.

I think I've discovered something by looking at your file and experimenting. You're adding text, probably the only way you've found so far. This is something rather old and creaky called the 'typewriter tool', which not so many use today. However, in Acrobat X it's easy to find under "Add or edit text box". What you add isn't like ordinary text on the page, it's really a kind of comment.

There are lots more kinds of comments under the Comment tab, including some much more powerful tools for adding text. You might find you prefer these, but let's look at the Typewriter problem.

Your problem is that your comments are less than 1% opaque. That is, pretty much transparent, and so they are invisible. How did it happen? Don't know, but I have a guess. Doesn't matter, I may have a fix. The problem is that this opacity thing is a real setting but with no tools for setting it. Now it's set, you have to get rid of it somehow.

1. You say, I think, you have a computer where all is well. On that computer, make a Typewriter text box. Save the PDF, and get it to the problem computer.

2. Open the good PDF on the problem computer.

3. Select the Comment tab. Look for the one you added under the comments list.

4. Double Click on the entry in the comments list and make sure it selects the right one. It must be the typewriter box.

5. Right click on the entry in the comments list and choose Properties.

6. Click on "Make Properties Default" and click OK.

If all is well, the good (100% opacity) setting will now apply to all future typewriter boxes.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 24, 2012 Jul 24, 2012

Copy link to clipboard

Copied

This didn't work.  I saved the document created on the other computer and the text box was fine on the computer with the problem.  The text box was visible on the problem computer and I saved the properties as default.  I used the same document on the problem computer and created a new text box under the visible text box on the document.  When I clicked outside the new text box, the text became invisible.  The text in the text box created on the other computer remains visible.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jul 24, 2012 Jul 24, 2012

Copy link to clipboard

Copied

Rats. Worked for me, to the extent I could fake up the problem. You seem to have something different.

I have two more suggestions.

1. Try using a different way to add text. Maybe the text box tool, first under Drawing Markups.

2. Give Adobe a chance to help you by contacting tech support. This will probably cost.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 24, 2012 Jul 24, 2012

Copy link to clipboard

Copied

My mistake.  This worked!!!!!!!!

It didn't at first but then I closed Adobe, reopened and did it again.  It now works in all Adobe documents.

I can't believe Adobe hasn't posted a fix but THANK YOU SO MUCH!!!!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 24, 2012 Jul 24, 2012

Copy link to clipboard

Copied

THANK YOU, THANK YOU, THANK YOU!!!!!!!!!!!!!!!!!!!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 11, 2013 Jan 11, 2013

Copy link to clipboard

Copied

I'm pretty sure I'm having the same problem described, although the fix did not work. Recently, on my Win 7 machine, using Acrobat X Pro I started having trouble. Whenever I open a javascript interface window, type in the box, and either move my mouse into or out of the window, the white background turns grey and the text becomes invisible. This happens whether I'm using the Console, Document Javascripts, Edit All Javascripts, or the javascript window associated with a given textbox.

The text is still there, because if I select it all, it becomes visible momentarily, until I mouse of the window.

I have reinstalled Acrobat X Pro, and tried the compatability Analyze and Fix suggested above, but no conflicts were found.

Help would be appreciated!

RL

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 11, 2013 Jan 11, 2013

Copy link to clipboard

Copied

Can you see the text box comment listed in the Comments Pane > Comments List panel?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 14, 2013 Jan 14, 2013

Copy link to clipboard

Copied

Hi Lori- the comments pane works fine.

The issue is only with the javascript interfaces. If I open a field's javascript window, or a document javascript, etc, the window acts funny. Initially, depending on my mouse position, the text either disappears when I mouse into or mouse out of the window.

With the text not showing, if I resize the window, the text becomes visible. If I then move the curser into the window, the text disappears, and the background of the window goes from white to grey.

So, my workaround has been to resize window to show, and then perform all navigation with the keyboard arrows.

Also, if I stretch the window "too" large, the entire program freezes, and I need to hard restart it.

-RL

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 30, 2018 Aug 30, 2018

Copy link to clipboard

Copied

This did work!!! i went back to the part of the document where the text comment did work, I RIGHT CLICKED on the text and selected show comment app and over to the right of the page it list all the comments, and for the comment i selected on the left it says Text Comment and i right clicked and selected properties and UNLOCKED THE LOCKED BOX  and it worked !! Then my text comments were visible and i could add my comments again!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 29, 2013 Jul 29, 2013

Copy link to clipboard

Copied

While this is not directly responsive to the question above, here is the fix for Windows machines.

1.  Close all runnning instances of Acrobat

2.  Open regedit

3.  Navigate in regedit to HKCU\Software\Adobe\Adobe Acrobat\10.0\Annots\cAnnots

4.  Search for "opacity"

5.  You should find key with the name "dopacity" underneath something like "cFreeText_003aFreeTextTypewriter"

6.  Change the "dopacity" value to "100.000000" (that's six zeros after the decimal point)

7.  Restart Acrobat and it should work.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 27, 2016 May 27, 2016

Copy link to clipboard

Copied

anon11786This worked PERFECTLY! Thank you!!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 01, 2016 Nov 01, 2016

Copy link to clipboard

Copied

This worked! Thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 05, 2020 Apr 05, 2020

Copy link to clipboard

Copied

6 ZEROS !!!  thanks so much for the fix - odd, that after migrating X to 64bit - this would start to happen.  Shows how long it's been since I made a form, then added a text box (sigh).  It was WORTH having to drill down through all of the ridiculous "doesn't happen to me" or iduno 'answers.  I'd buy you a beer if you were near by!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 29, 2013 Aug 29, 2013

Copy link to clipboard

Copied

I found an easy answer...

Click into each text box > Select all text > Right Click > "Text Style" > Select "Clear Formatting" > Fixed, repeat for all textboxes.

Enjoy

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 13, 2014 Jan 13, 2014

Copy link to clipboard

Copied

A friend of mine found that adding a space after the text in each field fixed the problem for him.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 16, 2019 Aug 16, 2019

Copy link to clipboard

Copied

Try Chrome.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 27, 2020 Feb 27, 2020

Copy link to clipboard

Copied

the solution worked! -- use of "Make Properties Default" from a visible Comment Text produced from another source to override a hidden system setting in Acrobat.

 

I am a windows user and had this problem with inadvertent set of 0 - opacity somehow somewhere for a very long time - this is not isolated to Mac.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 11, 2020 Jun 11, 2020

Copy link to clipboard

Copied

Hi guys, 

I am new here but after 2 days working with Adobe Pro Dc I get really frustrated.

Could you help me please with 2 things that really drive me crazy:

1.  Deleting text fields in a form - I just cannot delete it complete, borders still remains in the form.

How can I just delete a field without so much troubles?

2. Text in the field dissapears after typing and clicking out of the box it and shows the default values instead.

Hre you have a link to the pdf with the problems:

http://test.urom-services.de/wp-content/uploads/2020/06/Kassen%C3%BCbergabe.pdf 

you can see rest from fields in the lower part of the doc.

Thanks a lot for help.

 

Madalin

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 12, 2020 Jun 12, 2020

Copy link to clipboard

Copied

I already had to deal with this very annoying bug, the only way I found was to redo a new form…

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 12, 2020 Jun 12, 2020

Copy link to clipboard

Copied

Why does you use so many fields with the name "Logo_af_image" ?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 15, 2021 Mar 15, 2021

Copy link to clipboard

Copied

LATEST

I figured out a very simple answer:

 

Click on the text box you made.  

 

On the second tool bar at the top, (where all the T text option buttons are,) You'll see a Circle, 4 lines, and Aa.  Click on the Circle.

 

There, set the background color to White, and drag the opacity up to 100%.

 

Click out of the text box, and if need be, select your text and set it to black.  It will now show up!

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines