• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Unable to access eSignature services

New Here ,
Jan 12, 2023 Jan 12, 2023

Copy link to clipboard


Hi, I recently activated an enterprise license for Acrobat Pro, which should give me access to eSignature. However, I am unable to access it both from desktop and web apps, even though I am logged in. 


When clicking "Request E-Signature" through the web app, it only allows me to sign and fill for myself. 


When requesting through the app, the document remains stuck in the "Uploading" page. 


If I try to manage my eSignature settings through the desktop app, it directs me to this page that says "Request e-signature services are not available at this time". 



I suspect this may have to do with personal and enterprise accounts conflicting. For some Adobe pages, it will show that I'm logged into my personal account, and for some, it will show that I'm logged into my enterprise account. I have tried logging out of all accounts and using incognito mode, but neither solved the problem. 


Any help would be greatly appreciated.

Security digital signatures and esignatures






Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation