• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Acrobat Reader DC "There was an error opening this document. Failed to load an application resource (internal error)."

New Here ,
Nov 28, 2017 Nov 28, 2017

Copy link to clipboard

Copied

Currently experiencing an issue with Adobe Acrobat Reader DC (18.009.20044) and Adobe Acrobat DC (218.009.20044). 

When opening documents that have been digitally signed or have a digital signature block, both will open but with the below error:

"There was an error opening this document. Failed to load an application resource (internal error)"

In order to view the document I have to click "OK" to close the error then reopen the same document again.

Working on Windows 10.

I've already tried the Repair Adobe tool, also this is affecting way more then just my machine.

Been on the Google for a good bit, but not finding anything relevant.  Any assistance greatly appreciated.

TOPICS
General troubleshooting , View PDF

Views

18.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , Feb 09, 2018 Feb 09, 2018

Tariq,

This is the solution we ended up going with to help keep this error from popping up.  Basically just define whitelisted locations in registry using group policy and everyone will have them.  I added whitelisted locations here in User Policy:

HKCU:\SOFTWARE\Adobe\Adobe Acrobat\DC\TrustManager\cTrustedFolders

HKCU:\SOFTWARE\Adobe\Adobe Acrobat\DC\TrustManager\cTrustedSites

I had to add strings in each key underneath both of those keys named t(whatever number you like) and put the value of the s

...

Likes

Translate

Translate
New Here ,
Nov 30, 2017 Nov 30, 2017

Copy link to clipboard

Copied

I've fixed this problem by adding common folder paths as Privileged Locations under Edit, Preferences, Security (Enhanced).  I still get the error message when someone sends me a PDF file, but most of my work involves getting digital signatures on files stored on just a few server locations.  I hope this helps!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 04, 2017 Dec 04, 2017

Copy link to clipboard

Copied

Sadly this solution does not work for us, I appreciate the tip though. Still looking for a resolution to this issue.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 05, 2017 Dec 05, 2017

Copy link to clipboard

Copied

Hi matthew,

Thank you for reporting the issue. Please go to Help -- check for updates , and update to the latest version.

Is this problem not observed on Windows 10? What are the platforms on which you are see the issue

If the problem is still resolved, please let us know, if this is happening for any particular file or for all the files.

Please try creating a signature with the latest Acrobat version and opening it with the same.

We cannot reproduce the issue in house. Also, you could share the file incase the document doesn't contain any confidential information.

Thanks ,

Chandrima

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 12, 2017 Dec 12, 2017

Copy link to clipboard

Copied

We're on Windows 10.

There seems to be no issues Opening PDF’s created on the current version of Acrobat, though this is not an option for the amount of Documents used.

All Docs here have this issue (The ones with Signature Blocks);

http://www.apd.army.mil/ProductMaps/PubForm/DAForm.aspx

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 01, 2018 Feb 01, 2018

Copy link to clipboard

Copied

Chandrima,

Having the same issue at our organization when opening signed PDFs or PDFs with form fills.  Issue appears to only happen on one of our networks using the same package built with Creative Cloud Packager.  Any further input would be greatly appreciated!

-Mike

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 09, 2018 Feb 09, 2018

Copy link to clipboard

Copied

Hi all,

We wouldn't recommend disabling what ereadslc has mentioned above in response no# 6.

Rather I would suggest/recommend try whitelisting the location/path under Security(enhanced) Preference for Reader/Acrobat.  Let us know if that helps.

-Tariq Dar

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 09, 2018 Feb 09, 2018

Copy link to clipboard

Copied

Tariq,

This is the solution we ended up going with to help keep this error from popping up.  Basically just define whitelisted locations in registry using group policy and everyone will have them.  I added whitelisted locations here in User Policy:

HKCU:\SOFTWARE\Adobe\Adobe Acrobat\DC\TrustManager\cTrustedFolders

HKCU:\SOFTWARE\Adobe\Adobe Acrobat\DC\TrustManager\cTrustedSites

I had to add strings in each key underneath both of those keys named t(whatever number you like) and put the value of the site or path.

Thanks for replying!

-Mike

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 09, 2018 Feb 09, 2018

Copy link to clipboard

Copied

Hi Mike,

I totally agree

That is great and as I mentioned this is the recommended solution for such scenarios.

-Tariq Dar

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 13, 2017 Dec 13, 2017

Copy link to clipboard

Copied

We are seeing this same issue on version 18.009.20050.  Several thousand installs all with the exact same result.  Our users are not happy and we have no solution yet.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 03, 2018 Jan 03, 2018

Copy link to clipboard

Copied

We have solved this issue by changing some registry keys.  For our purposed we needed to change the following registry keys to the settings below.

  1. "HKLM\SOFTWARE\Policies\Adobe\Adobe Acrobat\DC\FeatureLockDown   -     iProtectedView” to “1”.
  2. “HKLM\SOFTWARE\Policies\Adobe\Adobe Acrobat\DC\FeatureLockDown   -     iFileAttachmentPerms” to “2”.
  3. “HKU\.DEFAULT\Software\Adobe\Adobe Acrobat\DC\AVGeneral   -     bFIPSMode” to “0”

Specifically this key seems to be the main problem:

  1. HKLM\SOFTWARE\Policies\Adobe\Adobe Acrobat\DC\FeatureLockDown   -     iProtectedView” to “1”

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 07, 2018 Jan 07, 2018

Copy link to clipboard

Copied

Even though those registry changes make the program work you are disabling the security.

iProtectedView to “1”

0=Off

1=files from potentially unsafe location

2=All files

Is there a way to verify the digital data,  When opening the PDF reader tries to authenticate the signatures (for Example) and install the certs automatically but fails.  If you open reader and then open the PDF the signatures work with out acknowledgment.  Is there a way to make this work by double clicking the PDF? Can we use Directory Servers to authenticate per system?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 17, 2021 Sep 17, 2021

Copy link to clipboard

Copied

LATEST

This is a problem as our PDFs go to our clients. We have no control over their systems. Or are you saying that changing our registry will eliminate the problem when we save the forms? For us, it happens because of form-fills. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines