Android Files "Open with" doesn't show Adobe Reader

Explorer ,
Mar 31, 2020

Copy link to clipboard

Copied

On my Pixel 3XL, I do the following:

 

  1. Open the default "Files" app (Files by Google 1.0.297653579)
  2. Go to the downloads folder.
  3. Tap on a PDF file.
  4. "Open with" panel slides up with only two options: Drive PDF viewer and Adobe Digital Editions. 

 

I want Adobe Acrobat Reader to also show up as an option, but it does not. How do I fix this? 

 

Note: I can open the same file with Adobe Acrobat Reader if I first open the app, navigate to the file, and open it. Also, I've cleared all defaults in all three apps (Adobe Reader, Digital Editions, and Files). 

TOPICS
Android, General troubleshooting

Views

426

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Apr 03, 2020

Copy link to clipboard

Copied

Google drive doesn't let you do that. If you want this method to open your PDFs natively in the Adobe Reader mobile app they woukd have to be downloaded directly from the Document Cloud.

 

Google have their own PDF viewer and don't support this method.

 

As long as you continue to use Google drive cloud service you need to download and use the long method that you described.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Dec 03, 2020

Copy link to clipboard

Copied

I have the same problem, and I want to clarify a couple things...  I'm not using "Google Drive", nor is the OP.  We're using Google's "Files" app.  And we're using it to access LOCAL FILES, not ones stored on the cloud.  In the "Files" app, when I click on a local PDF file (say in the "Downloads" folder), the "open with" list shows other apps that are capable of opening PDF files, but inexplicably does NOT show my Adobe Reader app.  This is infuriating, and I cannot understand any reason for it.  Anybody have any suggestions for how to fix this??

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Dec 07, 2020

Copy link to clipboard

Copied

Can you try to scroll up the app listing of the Google Files app? The app should then get listed.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Dec 07, 2020

Copy link to clipboard

Copied

No dice.  I think you're suggestion assumes I have more apps associated with PDF than will fit in the initial app listing window.  I do not.  Only two apps show in that list for me:  "Drive" & "PDF Maps".  When I swipe up to expand the window, only those same two apps show...  plus a bunch more blank space.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Dec 07, 2020

Copy link to clipboard

Copied

Sorry, my above reply was in response to Shubham5E5A.  Tried ls_rbls's suggestion too just to double-check that Adobe Reader is the default app for PDF, and yes, it is, and has been for some time on my phone.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
ls_rbls LATEST
Adobe Community Professional ,
Dec 08, 2020

Copy link to clipboard

Copied

I think that the inability to open these PDFs in the Acrobat Reader mobile app natively is because Google File is integrated with Google Drive and Google Docs. When you try to view PDFs from the Google Files app, Google Drive or using a Google Docs,  these platforms expect Google's  own PDF viewer to open these files by default. It doesn't respect what is the default PDF viewer set in your mobile device.

 

I recreated the scenario that you mentioned in my mobile device and the problem is not present if I uninstall Google Files.

 

Using  AndroidOS's built-in file manager handles pretty well all of my files in a less restrictive way, and I can also tap once on a PDF file which will open with the Acrobat Reader mobile app on the fly (if it is set as the default PDF handler of course)... I may be totally wrong with this opinion though.

 

I am gonna say no thank you to Google Files. 

 

But going back to why this app is not showing in "Open with",    does it happen if you uninstall the app, power off the phone, then power it back on and download and install it afresh again?  That said, before you install do thorough cleanup of temp folders and such.

 

Also, there are some Android OS versions that doesn't have the same features. Have you checked with someone who has the same model of your mobile device and same update version of AndroidOS (to include the Acrobat Reader mobile app) as you and see if the problem happens in that device as well?

 

Also, from what I 'm reading there is no way to add apps manually to the "Open with" list.

 

The apps add themselves automatically to the "Open with" list when you install them. So, that is why I would suggest to uninstall ad reinstall.

 

Last above all these verbage said, I think that you have to unhide the app.

 

If you notice in your Android Home Screen, there is an app drawer icon (white square or circle with six or nine dots on it). Tap on it once to open the App Drawer. 

 

This is were all of your apps are found, including the hidden apps.

 

In the screen that will open  after you've tapped on the app drawer icon, observe from top to bottom, right below the clock and the Wi-Fi signal bars theere is a search bar labeled "Search phone. To the far right  margin of this search bar there is an additional "More options" menu (or the three dots icon). Tap on more options and select from the context menu "Settings". And from the next screen select "Hide apps".

 

A list of app icons will open up next in alphabetical order, and if you have indeed  Adobe Acrobat installed in your phone, it should appear aslisted as the very first app.  

 

Note that if this icon is checked that means the app  is hidden. 

 

If that is the case, tap once to uncheck it and then tap on "Apply".

 

I don't think this would make any difference but it is worth trying it out.

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Dec 07, 2020

Copy link to clipboard

Copied

++Adding to the suggestion of Shubham,

 

You may also want to verify if the Acrobat Reader Mobile app is set as the default PDF viewer in your mobile device.

 

You can do so by tapping once, hold and  long-press on the Acrobat Reader icon.

 

Then select "App info" from the context menu that will pop up next.

 

In the next screen you'll be presented with a few options. Scroll or swipe down until you see "Set as default".

 

Tap on it to set your app as the default PDF handler.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more