Adobe Digital Windows Certification Store Signatures not working

New Here ,
Dec 10, 2020

Copy link to clipboard

Copied

When attemping to use a digital signature (using CERTIFICATIONS, not Fill and Sign), the final page where you click "Sign" it does nothing. We use the Windows Certificate Store so it uses our LDAP system to validate credentials. 
Ive tried:
Uninstalling and reinstalling the newest version of Adobe Reader
Deleting the Digital ID, and recreating it. 
Turning off "Enable Protected Mode at Startup" under Security (Enhanced)
I have tried everything in all of these support pages that i can find as well. 

It DOES sign if you use the normal PKCS#12 Digital ID file, but Windows Certificate Store does not. 
I am able to 100% recreate this on every computer that uses adobe reader
Doesnt matter what PDF file it is, it does not work. 

 

Using my Administrator account on Acrobat pro DC, I AM able to digitally sign, using the way above with zero issues. 
We have been using adobe reader to do this for years and now all of a sudden it no longer works. We need this function due to our companies compliance and security. 

568677777_0-1607626871651.png

 



TOPICS
General troubleshooting, Security digital signatures and esignatures

Views

44

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Have something to add?

Join the conversation