app.alert Adobe ActiveX

New Here ,
Nov 19, 2020

Copy link to clipboard

Copied

With the latest build of Windows 10 (19042) the app.alert functionality no longer works inside of IE 11 (yes, we are moving away from IE 11) when the PDF is presented inside of the browser. The sound notification is present but the pop up box no longer shows up. I've rolled back to the previous Windows 10 build and it works. Has anyone encountered this or have any ideas on how to program it to work?

 

Here is the code:

strJS = "if (app.alert('Are you sure you want to delete this document?',2,2) == 4){" & vbcrlf &_
"this.getField('" & strName & "').readonly = true;" & vbcrlf &_
"this.submitForm({" & vbcrlf &_
"cURL: '" & strURL & "', " & vbcrlf &_
"cSubmitAs: 'HTML' " & vbcrlf &_
"});" & vbcrlf &_
"}"

TOPICS
PDF and browsers, PDF forms, View PDF, Windows

Views

37

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

1 Correct Answer

New Here , Nov 20, 2020
johnw89733537 New Here , Nov 20, 2020
In case someone encounters this issue in the future. Here is a workaround. Adobe Reader DC must be installed AND set as the default.Open Adobe Reader DCFrom the menus, select “Edit” then “Preferences”In the preferences dialog, select “Security (Enhanced)” from the list of categoriesIn “Sandbox Protections” uncheck “Enable Protected Mode at startup” Something in the latest build in Windows 10 broke this process. Nevertheless, here is a solution.

Likes

Translate

Translate
Jump to answer Jump to answer
New Here ,
Nov 20, 2020

Copy link to clipboard

Copied

In case someone encounters this issue in the future. Here is a workaround.

 

  1. Adobe Reader DC must be installed AND set as the default.
  2. Open Adobe Reader DC
  3. From the menus, select “Edit” then “Preferences”
  4. In the preferences dialog, select “Security (Enhanced)” from the list of categories
  5. In “Sandbox Protections” uncheck “Enable Protected Mode at startup”

 

Something in the latest build in Windows 10 broke this process. Nevertheless, here is a solution.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more