Latest Version 11.0.10 - RunOnce Entry for Speed Launcher

Explorer ,
Dec 09, 2014

Copy link to clipboard

Copied

1) Pretty stupid that the only way I can submit a bug report on a problem with your software is to sign up for this forum and 50 clicks later post a topic which may or may not be reviewed by Adobe.

2) Just downloaded the latest version and on two computers, Speed Launcher is adding a HKCU RunOnce entry over and over again and assigning a random number to it.  This is then of course alerting WinPatrol who is monitoring new startup programs and flags it every time I reboot.  Looks to be an error and not intentional design because a.) it shouldn't be in RunOnce if it's meant to be there and b.) the details aren't correctly populated such as publisher name etc.

So is this a bug or new design... if it's new design, how do I shut it off because I don't need a random number popping into my registry every time I reboot

Thanks

Views

13.8K

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

1 Correct Answer

Adobe Employee , Dec 24, 2014
AshuMittal Adobe Employee , Dec 24, 2014
Hi all,We have rolled out a fix for this issue.Please log off and log back in to your machine and the issue should be resolved automatically. In case that does not work, please manually run the msi installer posted here (may require reboot).For details, please refer to the KB article here: Multiple RunOnce keys created 11.0.10 and 10.1.13 Acrobat | ReaderPlease let us know if you still face any issues.Thanks,Ashu Mittal

Likes

Translate

Translate
Jump to answer Jump to answer
Guru ,
Dec 09, 2014

Copy link to clipboard

Copied

You could always disable speed launcher by renaming the EXE but it will slow the PDF rendering opening a file.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
dprout69 AUTHOR
Explorer ,
Dec 09, 2014

Copy link to clipboard

Copied

I can try that, however I'm not so sure that would work.  This reg entry doesn't point to a file... it just changes to a random number every time you reboot.  This is different than in the past where there was a startup entry under Run which pointed to the file.

UPDATE:  Didn't work.  I don't know from where this entry loads however the way this is setup now is obviously incorrect.  I've even deleted the entry and it just puts it right back into RunOnce.  If it was a valid entry it shouldn't be in RunOnce, it would be in Run.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
dprout69 AUTHOR
Explorer ,
Dec 09, 2014

Copy link to clipboard

Copied

Is this really the only way to report a bug?  Does Adobe monitor this forum?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Guru ,
Dec 09, 2014

Copy link to clipboard

Copied

No, it isn't.  You can report them here without ever having to log into anything:  Adobe - Feature Request/Bug Report Form

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
dprout69 AUTHOR
Explorer ,
Dec 09, 2014

Copy link to clipboard

Copied

Cool... submitted.  Much easier... thanks.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Dec 15, 2014

Copy link to clipboard

Copied

But what if you're not sure whether it's a bug or not, and simply want some information so that you can understand what is happening and why, so that you can then decide whether or not to allow something to happen on your computer, or if it is a case of outright malware attack?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Dec 15, 2014

Copy link to clipboard

Copied

I have the exact same issue as dprout69.  I was made aware of it the exact same way (i.e., via WinPatrol).  And solved it the exact same way, by disabling the adobe UPDATER (not the speed launcher, that didn't work).

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
dprout69 AUTHOR
Explorer ,
Dec 09, 2014

Copy link to clipboard

Copied

So I performed an audit on the reg key and noted adobearm.exe is the process creating the entry; this is the exe responsible for updating adobe reader.  Why the updater is creating the speed launch I have no clue however if anyone needs a workaround:

Turn off the update feature in reader (I do it manually more often than not anyway)

Delete the entry in HKCU RunOnce for Adobe Speed Launcher

Disable (Using CCleaner or some other program which can disable startup entries) or delete (in HKLM Run) the Adobe ARM entry.

I submitted a bug report, but no telling how long that will take to fix.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Most Valuable Participant ,
Dec 17, 2014

Copy link to clipboard

Copied

This is worrying me because it's very similar to a piece of malware from a couple of years ago which called itself "Adobe Speed Launcher". Certainly there is such a thing, it is called ADOBE_SL.EXE in the Adobe program files folder. But do we know for sure that this is real Adobe's software? You indicated that it was put there by ADOBEARM.EXE. Well, there used to be an ADOBEARM.EXE but I just installed Reader 11 and don't have one. Where is yours and is it digitally signed?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Most Valuable Participant ,
Dec 17, 2014

Copy link to clipboard

Copied

Update: I did find an ADOBEARM.EXE. It was in c:\Program files (X86)\Common files\Adobe\ARM\1.0. It is digitally signed with a timestamp of 20 Nov 2014 and a size of 1,021,128 bytes.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Most Valuable Participant ,
Dec 18, 2014

Copy link to clipboard

Copied

Here is an example of malware which installs itself claiming to be Adobe Speed Launcher. Not new, but it could have been revised. RDN/Generic.dx!CA8CF0480942 | Virus Profile & Definition | McAfee Inc.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Dec 18, 2014

Copy link to clipboard

Copied

Hi all,

Thank you for reporting this issue with the latest Adobe Reader 11.0.10 update. Our engineering team has been able to identify the cause of this issue and are investigating a potential fix for the same.

Please stay tuned for details of the resolution.

Regards,

Ashu Mittal

Adobe Systems

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Dec 16, 2014

Copy link to clipboard

Copied

I too experience this issue with Acrobat Pro since the update. Could someone from Adobe please provide a fix for this?

Bug report was filed.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Dec 19, 2014

Copy link to clipboard

Copied

howdy,

this is just 2 confirm that i had same recent issue on two win7sp1x64 both with Acrobat Pro 11.0.10 installed, although there was no any visible problem for regular use of neither Acrobat itself nor other Adobe apps like Photoshop or Illustrator, when this issue has been found incidentally thru z irregular check by Autoruns.

a disabling of AdobeARM.exe from win7 boot by Norton 360 startup manger solved this issue. CCleaner is also nice to do this.

remain awaiting for Acrobat Pro 11.0.11

rgds,

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Dec 20, 2014

Copy link to clipboard

Copied

I realize that a staff member Ashu Mittal has replied that they're able to identify the cause of the problem and are investigating a solution.  Nevertheless, I wanted to say that I have the exact same problem (and was alerted to it the exact same way, by WinPatrol) so that it's clear that the problem isn't as isolated as might be assumed with only a couple of people reporting it.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Dec 20, 2014

Copy link to clipboard

Copied

Same problem, WinPatrol is great.  Is this just a programming bug, or is this an indication of a new Acrobat function or operation?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Dec 21, 2014

Copy link to clipboard

Copied

Hi all,

You can find the details of this issue here: http://helpx.adobe.com/acrobat/kb/runonce-key-created-every-user.html

This page will be updated as soon as the fix is ready to be rolled out.

Regards,

-Ashu

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Dec 24, 2014

Copy link to clipboard

Copied

Hi all,

We have rolled out a fix for this issue.

Please log off and log back in to your machine and the issue should be resolved automatically. In case that does not work, please manually run the msi installer posted here (may require reboot).

For details, please refer to the KB article here: Multiple RunOnce keys created 11.0.10 and 10.1.13 Acrobat | Reader

Please let us know if you still face any issues.

Thanks,

Ashu Mittal

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Participant ,
Jun 13, 2018

Copy link to clipboard

Copied

I ran the RunOnce Entry for Speed Launcher, two days ago. Restarted the computer, and then, still, the next day and today, that speed launcher started up again, sneaking in their horrid little program TWICE (I have both Adobe Acrobat Professional and Acrobat Reader). I have to keep the task manager open, each morning when I start up my computer,  to see when that darn thing loads, and then I hit "end process" when it shows up. That gets rid of the damn thing until the next day. Really slows me down, extremely aggravating.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
dprout69 AUTHOR
Explorer ,
Dec 29, 2014

Copy link to clipboard

Copied

Ran the installer and all seems ok now... thanks

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Jan 04, 2015

Copy link to clipboard

Copied

Thanks very much for confirming.

Best,

-Ashu

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Most Valuable Participant ,
Jun 13, 2018

Copy link to clipboard

Copied

Why does it slow you down? It's supposed to speed up launches of the products.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Participant ,
Jun 13, 2018

Copy link to clipboard

Copied

I thought this entire thread was about the "speed launcher" starting at start-up. THAT's where it slows me down, when my machine is starting up. I don't want the so-called speed launcher starting when I start up my machine! Makes my morning machine boot-up about 15-20 minutes longer. THAT's why I've been keeping an eye on the task  manager, to see when the "speed launcher" starts trying to run. Can you all at adobe not give a way to disable it on "start-up"???

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Most Valuable Participant ,
Jun 13, 2018

Copy link to clipboard

Copied

Actually the thread is four years old and about an ancient version, with s bug that was fixed in 2014. Do you see this problem with the current version? And what do you mean by “makes the boot 20 minutes longer”? What do you see happen exactly?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more