• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Dynamic Stamp sometimes gets auto-sized too small when placed on page

New Here ,
Oct 05, 2020 Oct 05, 2020

Copy link to clipboard

Copied

We have several custom dyanamic stamps that our users use on PDF documents.  They usually come out to be about 524x244pixels or 1.747x0.813inches, which is the page size of the stamp pdf itself (the 2nd page, first is 8.5x11 as per most stamps).  Sometimes however, when placed on a incoming PDF they are sized down to a speck and have to be manually resized.  Almost all of the time they get placed without issue at the default size... so it is difficult to readily replicate or identify the root cause.  I checked the javascript on the stamp itself and the only code there is for the dynamic events (name & date).  Nothing to indicate size, orientation, or placement coordinates.  I haven't been able to find any other articles with the same issue.

 

Thanks, if anyone has seen this sizing issue or knows how to prevent this going forward.

TOPICS
Acrobat SDK and JavaScript

Views

202

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

LEGEND , Oct 06, 2020 Oct 06, 2020

BTW, to replicate this, select the stamp tool and click and hold the mouse button down, and with the button held down drag out a rectangle. You will see that you can set the size of the stamp to whatever you want. In the case where the stamp appears very small, this process happens so fast you don't notice and think all you've done is clicked, but you've actually clicked and dragged a very small amount.

Likes

Translate

Translate
Community Expert ,
Oct 06, 2020 Oct 06, 2020

Copy link to clipboard

Copied

Stamps don't get resized when applied. My guess is that the page you're placing them on is very large, so they look small.

Compare the page size and zoom level of both files when applying the stamp to them.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 06, 2020 Oct 06, 2020

Copy link to clipboard

Copied

This can happen if you move the mouse slightly at the time you click to apply the stamp. The fix is to not move the mouse.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 06, 2020 Oct 06, 2020

Copy link to clipboard

Copied

BTW, to replicate this, select the stamp tool and click and hold the mouse button down, and with the button held down drag out a rectangle. You will see that you can set the size of the stamp to whatever you want. In the case where the stamp appears very small, this process happens so fast you don't notice and think all you've done is clicked, but you've actually clicked and dragged a very small amount.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 06, 2020 Oct 06, 2020

Copy link to clipboard

Copied

So doing that we were able to readily replicate.  Is there a way to turn this "feature" off?  The users who semi-regularly run into this move very fast when going through and stamping documents, and would like for this to simply not happen.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 06, 2020 Oct 06, 2020

Copy link to clipboard

Copied

LATEST

Sorry, I'm not aware of a way to disable or adjust the sensitivity of this.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines