• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Exported Word document not launched when AVAppSaveDialogSEL is replaced.

New Here ,
Mar 18, 2020 Mar 18, 2020

Copy link to clipboard

Copied

Hi guys, In my Acrobat plugin I have replaced the AVAppSaveDialogSEL. I do this to track what happens after my customers issue a Save As on a document. My customers have noticed that when they export a PDF to Word that the resulting Word file is no longer launched automatically. If you remove my plugin and export a PDF to Word, the new Word document is launched. Is this a limitation of overriding the AVAppSaveDialog?

Thanks.

TOPICS
Acrobat SDK and JavaScript

Views

101

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 18, 2020 Mar 18, 2020

Copy link to clipboard

Copied

Hi Hgordon

 

We are sorry for the trouble. As described the PDF file when exported to Word is not launching automatically. it is the MS Word workflow. Please get in touch with the MS office to further get this issue resolved. Have it been the other way around (converting MS word file to PDF) then it would be Adobe's workflow.

 

Regards

Amal

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 25, 2020 Mar 25, 2020

Copy link to clipboard

Copied

LATEST

Thanks Amal,

The "View Result" check box on the AVAppSaveDialog no longer works when the dialog is called from code:

 

if(CALL_REPLACED_PROC(gAcroViewHFT, AVAppSaveDialogSEL, gcbAVAppSaveDialog)
(dialogParams, outFileSys, outASPathName, ioChosenFilterIndex)) {
bRet = true;
}

 

Results are not viewed regardless on the setting of "View Result" when called from code. Natively (without a plugin) it works fine.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines