Automation error, the remote procedure call failed

Explorer ,
Feb 01, 2021 Feb 01, 2021

Copy link to clipboard

Copied

Hi.

I have created a tool that does the following using the OLE Automation interface.

 

(1)Divide the pdf file page by page(PDDoc.GetJSObject.extractPages)
(2)The divided pdf file's name is from the contents of each page(PDDoc.GetJSObject.getPageNumWords)
(3)Get the contents from each divided pdf file(about 250 divided files) and

  check if the file name match(PDDoc.GetJSObject.getPageNumWords).

 

When getting the contents of each file in (3), run-time error '-2147023170(800706be)' occurs,
that says automation error, the remote procedure call failed.
When the error occured, acrobat application was terminated even though there was no process to terminate the application.
The error does not occur in the DC version, but in other versions(XI, 9)

 

What can I do to solve this? Please give me some advice.

TOPICS
Acrobat SDK and JavaScript, Windows

Views

73

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Feb 01, 2021 Feb 01, 2021

Copy link to clipboard

Copied

Seems as if you have a fix - don't use the end-of-life versions. Bug fixes won't be applied retrospectively.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 01, 2021 Feb 01, 2021

Copy link to clipboard

Copied

Sorry I'm not good at English.

So, do you mean that this is a bug and has been fixed in DC version??

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Feb 01, 2021 Feb 01, 2021

Copy link to clipboard

Copied

I do not know if it is a bug that is fixed. It seems a good guess. 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 01, 2021 Feb 01, 2021

Copy link to clipboard

Copied

I understand.Thank you for your reply.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines