SignPlugin in MacOS Catalina

Community Beginner ,
Mar 17, 2020 Mar 17, 2020

Copy link to clipboard

Copied

Hi,

When I try to sign my Adobe Reader plugin in MacOS Catalina I get this error

 

zsh: bad CPU type in executable: ./SignPlugin

 

SignPlugin supports two architectures  [ppc,i386]. However Catalina doesn't support 32bit

Is there a x64 version of SignPlugin?

 

/Carsten

TOPICS
Acrobat SDK and JavaScript, General troubleshooting

Views

212

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 17, 2020 Mar 17, 2020

Copy link to clipboard

Copied

Hi Carsten_Pedersen,

 

We are sorry for the trouble. As described you are getting the error 'bad CPU type in executable: ./SignPlugin'

 

Please try the following steps and see if that helps:

 

 

Let us know how it goes. 

 

Regards

Amal

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 17, 2020 Mar 17, 2020

Copy link to clipboard

Copied

Hi Amal,

 

It isn't a problem with the Adobe Reader application.

When developing a  Plugin for Adobe Reader you must sign the plugin before it can be used in Adobe Reader DC.

The tool for that is in the Adobe Acrobat SDK (https://www.adobe.com/devnet/acrobat/sdk/eula.html)

 

The tool SignPlugin is located in Actrobat SDK/Version 1/PluginSupport/Tools/Reader-enabling-Tools/mac

 

Catalina removed support for 32bit programs,  and I'm unable to sign my plugin

 

/Carsten

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Mar 18, 2020 Mar 18, 2020

Copy link to clipboard

Copied

LATEST

You may need to keep a 32 bit system for this. Perhaps in a VM. I need to keep all sorts of systems for running dev tools. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines