What are the versions of Windows & Visual Studio for Acrobat SDK 9.0?

Community Beginner ,
Oct 23, 2018

Copy link to clipboard

Copied

I downloaded "Adobe Acrobat XI SDK for Windows" on the official website and tried to compile the sample "BasicPlugin" with VS2015 on Win7, but the generated API file is incomplete and the Output window does not prompt the PDB file generation. Then I trid again with the same IDE on Win10, it worked. Here are some screenshots:

VS2015 on Win7

3.PNG

4.PNG

VS2015 on Win10

6.PNG

7.PNG

I wanna know what caused the difference? Please do not hesitate to enlighten, thanks!!!

Thank you very much, I upgraded my OS from Win7 to Win10, it worked. Maybe my system environment has some problems, just as you said. Anyway, the api file worked at last.I really appreciate your responses,3Q!!!

TOPICS
Acrobat SDK and JavaScript

Views

233

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

What are the versions of Windows & Visual Studio for Acrobat SDK 9.0?

Community Beginner ,
Oct 23, 2018

Copy link to clipboard

Copied

I downloaded "Adobe Acrobat XI SDK for Windows" on the official website and tried to compile the sample "BasicPlugin" with VS2015 on Win7, but the generated API file is incomplete and the Output window does not prompt the PDB file generation. Then I trid again with the same IDE on Win10, it worked. Here are some screenshots:

VS2015 on Win7

3.PNG

4.PNG

VS2015 on Win10

6.PNG

7.PNG

I wanna know what caused the difference? Please do not hesitate to enlighten, thanks!!!

Thank you very much, I upgraded my OS from Win7 to Win10, it worked. Maybe my system environment has some problems, just as you said. Anyway, the api file worked at last.I really appreciate your responses,3Q!!!

TOPICS
Acrobat SDK and JavaScript

Views

234

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 23, 2018 0
Adobe Community Professional ,
Oct 23, 2018

Copy link to clipboard

Copied

Version 9 or XI?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2018 0
Community Beginner ,
Oct 23, 2018

Copy link to clipboard

Copied

The application is Adeobe Acrobat XI Pro

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2018 0
Community Beginner ,
Oct 23, 2018

Copy link to clipboard

Copied

The application is Adeobe Acrobat XI Pro

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2018 0
Adobe Community Professional ,
Oct 23, 2018

Copy link to clipboard

Copied

Look for "Supported environments" in the documentation of the SDK.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2018 0
Community Beginner ,
Oct 23, 2018

Copy link to clipboard

Copied

OK, thanks for your suggestion, I'll try.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2018 0
Most Valuable Participant ,
Oct 23, 2018

Copy link to clipboard

Copied

Both screen shots show an API file being made, I notice. Why do you care about the PDB?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2018 0
Community Beginner ,
Oct 23, 2018

Copy link to clipboard

Copied

Yeah, but the API file(46kb) can run witn the application well, while the other one(45kb) failed to install. All  configrations are the same, so I guess the API file generated by VS2015 on Win7 is uncompleted. The only difference, I noticed so far, is the PDB file information in Output window. I don't konw if I'm clear?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2018 0
Most Valuable Participant ,
Oct 24, 2018

Copy link to clipboard

Copied

I understand your reasons but I think you are wrong. A plugin cannot be incomplete if it has linked. The difference may be because  is a Debug build (which makes PDB and larger files) and the other is a Release build (no PDB).

If the plugin does not load you may be missing a Microsoft VC runtime DLL. The tool DEPENDS.EXE is useful to diagnose.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 24, 2018 0
Community Beginner ,
Oct 24, 2018

Copy link to clipboard

Copied

Thank you very much, I upgraded my OS from Win7 to Win10, it worked. Maybe my system environment has some problems, just as you said. Anyway, the api file worked at last.I really appreciate your responses,3Q!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 24, 2018 0