• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Power Apps / Automate asking for Adobe PDF Tools credentials for users

Community Beginner ,
Apr 19, 2021 Apr 19, 2021

Copy link to clipboard

Copied

I have shared a Power App connected to a Power Automate flow that uses the Adobe PDF Tools api. The app is using an Power Apps per app plan.

For me (as the owner) of the flow the connection is working as I have provided all the necessary credentials.

MPhelpdesk_0-1618826460708.png

But when a user wants to open the app, he is prompted for credentials for the connection:

MPhelpdesk_1-1618826669650.png

I currently have a trial version of the pay-as-you-go tool.

 

How can I share the app/flow with users without them having to need credentials for the Adobe PDF Tools connection please?

TOPICS
PDF Services API , Power Automate

Views

313

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 19, 2021 Apr 19, 2021

Copy link to clipboard

Copied

Hi @MPhelpdesk ,

 

I understand the issue that you are running into. I can definitely see where that could be problematic. I don't have any quick answers on that, however I have passed your issue on to our Engineering team.

 

Adobe Engineering team is looking into it to see what would be a good way to solve your problem. We'll update you when we have an update. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 22, 2021 Apr 22, 2021

Copy link to clipboard

Copied

Hi,

Any news on this please?

Because normally when sharing a PowerApp or Power Automate flow with colleagues, all the used connectors got shared also, no?

MPhelpdesk_0-1619094179974.png

But alas the Adobe connector keeps asking for credentials ...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 22, 2021 Apr 22, 2021

Copy link to clipboard

Copied

Hi @MPhelpdesk ,

I don't have an answer at this time. It has been reported and escalated to our engineering. It appears it may be a bug related to the connector. I can give an update when I have a better estimate.

 

In the mean time, one workaround you could consider is one which is very common with Power Apps, which is to create an HTTP Request trigger that initiates the flow and pass the parameters through that. That way, it would not be identifying with that unique user to trigger PDF Tools.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 28, 2021 Apr 28, 2021

Copy link to clipboard

Copied

In the mean time my Adobe trial expired, so I have made another trial-account. But I am still having the same problem! 😞

And in the mean time that trial also expired... so now I have activated a 30-days trial with Encodian and I will try that in the mean time.

 

But if there is any update of solution (not a workaround) soon from the engineering team, I woud like to hear it!

 

Thanks.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 23, 2022 Mar 23, 2022

Copy link to clipboard

Copied

Was solution to this ever found?  I too am having this issue and am unable to find a workaround.  I have contacted Adobde support several times with no response.  Need a solution ASAP or will need to find another service to use.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 23, 2022 Mar 23, 2022

Copy link to clipboard

Copied

Hi All,

 

I believe you need to define "Run only users", which would allow you to centralize the credentials and not have the person have to key them in when they launch the app:

BenVanderberg_0-1648062447301.png

 

Ben

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 23, 2022 Mar 23, 2022

Copy link to clipboard

Copied

Hi All,

 

I believe you need to define "Run only users", which would allow you to centralize the credentials and not have the person have to key them in when they launch the app:

BenVanderberg_0-1648062447301.png

 

Ben

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 23, 2022 Mar 23, 2022

Copy link to clipboard

Copied

But shouldn't it also work if another was added as a flow owner?  I have added them as an owner and they aren't able to run the flow...not sure why a run only user would be able to when another owner can't.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 24, 2022 Mar 24, 2022

Copy link to clipboard

Copied

Hello,

 

After deleting every connection to the Adobe service in Power Automate, I tried the Encodian pdf service for a while. Great service, but little expensive for our means.

After a month or so Adobe sales contacted me to let me know that they offered a pay-as-you-go model for the Adobe pdf tools api. That's why I gave it another try. And suddenly everything worked as it should.

I only shared the app in PowerApps, not the flow. I am the only owner of the flow. I also don't have the option Run only Users. I suppose because my flow is automatically shared through the sharing of the app.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 07, 2022 Apr 07, 2022

Copy link to clipboard

Copied

LATEST

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources