• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Protect PDF Rest API - Not Working

New Here ,
May 18, 2023 May 18, 2023

Copy link to clipboard

Copied

As the title states, a call to operation/protectpdf endpoint is running without any issues, but the resulting pdf in AWS does not have any permissions set on it. At one point, this process was working. It was only until a few days ago that it stopped. I have attached some screenshots that show the following to confirm the process is running without issues.

 

1.) Fiddler capture showing initial call to .../operation/protectpdf. Shows request body and resulting 201 Created with pooling url

2.) Fiddler capture cont. showing final call to pooling url with status = done

3.) Resulting PDF generated from the process. You can see that there are no permissions set

4.) Last correctly generated PDF before this process stopped working. Clearly shows that permissions have been set on the file in the header

 

We are currently trialing Adobe PDF Services and have loved the product so far. Have not run into any other issues except this one. We appear to have sufficient quota, so I dont think thats an issue. We never receive a 429 HTTP code either. At this point, I am not sure what the issue could be. Are we incorrectly defining the information in the body of the request?

 

TOPICS
Document Generation API , PDF Services API , REST APIs

Views

659

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , May 26, 2023 May 26, 2023

Engineering worked on this, and the issue should be resolved. Please try again.

Votes

Translate

Translate
Adobe Employee ,
May 26, 2023 May 26, 2023

Copy link to clipboard

Copied

I'm sorry for the delay in reesponding. I did some testing and I believe I recreated the bug. I'm going to file a report immediately.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 26, 2023 May 26, 2023

Copy link to clipboard

Copied

Engineering worked on this, and the issue should be resolved. Please try again.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 30, 2023 May 30, 2023

Copy link to clipboard

Copied

LATEST

Hi Raymond,

Thank you for the response. I can confirm that it is now working as expected.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources