Addressing 'updated version .. is needed' without updating

New Here ,
Mar 17, 2021 Mar 17, 2021

Copy link to clipboard

Copied

I have a Windows 7 PC (no, this will not be upgraded) and running on this computer is the CS3 version of Adobe Photoshop. Included with this package is version 9.5.5 of Acrobat.
Today, and not the first time, I tried opening a PDF file and was greeted with the following: There was an error opening this document. An updated version of Acrobat is needed in order to open this document.
I do not plan on upgrading the Adobe suite (too much money!) and so my question is simply this: Is there something I can do, at no dollar cost, that would allow me to open and view the document?

Thanks.

TOPICS
How to, Standards and accessibility

Views

38

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 17, 2021 Mar 17, 2021

Copy link to clipboard

Copied

LATEST

If it is just for opening and viewing a PDF all you need is Adobe Reader DC, which is free to download and use, or use a web browser like Chrome, for example, to view the PDF.

 

That said, if you're opening PDFs that have custom calculations, JavaScript scripts, and other Acrobat built-in features set in those PDFs , you may not be able to work with them properly via web browser.

 

You may need Reader DC or an equivalent third-party PDF viewer.

 

You are also using  very old versions of both the OS and the PDF handler which doesn't get any type of support, updates, fixes, or patches from their vendors anymore.

 

Due to security flaws, those platforms have undergone many migration paths  to address those flawd in  more recent versions.

 

That said, the error you're getting is also related to some PDFs that were probably saved to support version X or above of Acrobat Pro. 

 

If that is the case, there's is nothing you can do about with your current software, unless the creator of the source PDF lowers the security standard to anything below version IX just for you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines