Highlighted

Audio object in pdf asks to enable 3d content

New Here ,
Aug 25, 2020

Copy link to clipboard

Copied

The audio/rich media tool in Acrobat DC is not behaving as intended.

If i insert an audio file (mp3) into a PDF document all appears to go well until its saved. Then BINGO a yellow box appears with "3D content has been disabled. Enable this feature if you trust this document".

This is amazingly irrelevant since i added an audio file and followed instructions for it to play when the page appears on screen. No 3D at all.

That is enough of an interruption but then the audio doesn't function at all even if you allow 3d objects 🙂

 

TOPICS
Rich media and 3D

Views

49

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Audio object in pdf asks to enable 3d content

New Here ,
Aug 25, 2020

Copy link to clipboard

Copied

The audio/rich media tool in Acrobat DC is not behaving as intended.

If i insert an audio file (mp3) into a PDF document all appears to go well until its saved. Then BINGO a yellow box appears with "3D content has been disabled. Enable this feature if you trust this document".

This is amazingly irrelevant since i added an audio file and followed instructions for it to play when the page appears on screen. No 3D at all.

That is enough of an interruption but then the audio doesn't function at all even if you allow 3d objects 🙂

 

TOPICS
Rich media and 3D

Views

50

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 25, 2020 0
Adobe Community Professional ,
Aug 25, 2020

Copy link to clipboard

Copied

Does this happen with every document - and with other MP3 files? I have not seen this behavior before, but I don't work with audio files a lot, so it's possible that this is new. Which version of Acrobat are you using, and on what operating system? You can find the exact version on the About dialog, it's a long string of numbers (for example, mine is 2020.012.20043).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 25, 2020 0
Adobe Community Professional ,
Aug 25, 2020

Copy link to clipboard

Copied

Ah, I just did this, and I now see what you mean. The problem is not that the yellow box pops up, but that the message is wrong. This is to protect the user from potentially harmful (or in the case of audio annoying) side effects. You need to allow the document to display/play multi-media content. When you look at the toolbar when you add your audio file, you will notice that the tool set is acutally called "Rich Media", and it allows you to add 3D content, audio and video - the software should either label this as "Rich media" on the yellow bar, or be more specific and call it auido, video or 3D. If you allow the audio file to be played without further check (and not just once), the next time you open the file, you should be able to just play it. This has to be done by every user. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 25, 2020 0
New Here ,
Aug 25, 2020

Copy link to clipboard

Copied

Thanks for the quick responnse! I have problems playing the audio even when the message is cleared and either way doesn't seem to work. In preferences Play 3d using Flash seems to be checked by default.

 

System info

Mac OS 10.15.6

Acrobat:
Architecture: x86_64
Build: 20.12.20043.396433
AGM: 4.30.103
CoolType: 5.14.5
JP2K: 1.2.2.46820

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 25, 2020 0
Adobe Community Professional ,
Aug 25, 2020

Copy link to clipboard

Copied

The Preference setting "Enable 3D Content" seems to prevent the yellow bar from showing up. I just tried this on my Mac (I am running macOS 10.14.6, so I am a bit behind vs. what you have), and it does indeed play MP3 files. Have you tried different MP3 files? 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 25, 2020 0
New Here ,
Aug 25, 2020

Copy link to clipboard

Copied

Ok it just worked! So theres spurious alert and the awkwardness of the interface is challenging. Now to test it in a few places. Thanks for the 'extra pair of eyes'. 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 25, 2020 0