Highlighted

Comment format changing when copying from Word document

Community Beginner ,
Oct 09, 2019

Copy link to clipboard

Copied

Hi, I am using Adobe Acrobat Pro DC version 2019.012.20040

 

The comments I wanna add are in a different format in a MS word document and when I copy paste them, the bold and italicized words in the original word document are originally there in the word document style and remain so when I click post, but when I close the comment pop up, the format resets.

I have shown this issue in a video here: https://www.youtube.com/watch?v=oGS1s4u2ojI 

 

Why is this happening and is there a way I can preserve the font style when transferring content from a MS word document to the comments box in Adobe Acrobat Pro DC? It is very time consuming italicizing and making words bold again. 

I am really in need of help and will appreciate a permanent resolution to this. Thank You! It has been months. 

Enjoy the videos and music you love, upload original content, and share it all with friends, family, and the world on YouTube.
TOPICS
Comment review and collaborate PDF, Edit and convert PDFs, General troubleshooting

Views

468

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Comment format changing when copying from Word document

Community Beginner ,
Oct 09, 2019

Copy link to clipboard

Copied

Hi, I am using Adobe Acrobat Pro DC version 2019.012.20040

 

The comments I wanna add are in a different format in a MS word document and when I copy paste them, the bold and italicized words in the original word document are originally there in the word document style and remain so when I click post, but when I close the comment pop up, the format resets.

I have shown this issue in a video here: https://www.youtube.com/watch?v=oGS1s4u2ojI 

 

Why is this happening and is there a way I can preserve the font style when transferring content from a MS word document to the comments box in Adobe Acrobat Pro DC? It is very time consuming italicizing and making words bold again. 

I am really in need of help and will appreciate a permanent resolution to this. Thank You! It has been months. 

Enjoy the videos and music you love, upload original content, and share it all with friends, family, and the world on YouTube.
TOPICS
Comment review and collaborate PDF, Edit and convert PDFs, General troubleshooting

Views

469

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 09, 2019 0
Adobe Community Professional ,
Oct 09, 2019

Copy link to clipboard

Copied

Please refer to the following slides:

 

richtext-comments1.png

 

 

 

richtext-comments2.png

 

 

richtext-comments3.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 09, 2019 0
Community Beginner ,
Oct 09, 2019

Copy link to clipboard

Copied

Hey, thank you for posting these photos! If you don't mind, can you demonstrate the process in a video by recording it via screengrab software, uploading it on Youtube and share the link? I can't understand how to allow Rich text formatting which is step 1 of the process. Thank you and bless you mate!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 09, 2019 0
Adobe Community Professional ,
Oct 09, 2019

Copy link to clipboard

Copied

I don't have a screen recorder at this time, but here is an additional slide to cover the step 1 that I did not illustrated:

 

richtext-comments4.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 09, 2019 0
Community Beginner ,
Oct 09, 2019

Copy link to clipboard

Copied

Hi so I am confused, is this step done in the wordpad or in the Adobe Reader?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 09, 2019 0
Adobe Community Professional ,
Oct 10, 2019

Copy link to clipboard

Copied

Wordpad is the program that I used in the example to copy the text from. Like in your case you were using MS word. So wordpad dont have anything to do in this procedure. Maybe you are confused because I placed both program windows next to each other in the slides. The important thing hete is just to enable rich tezt formatting. You can do that by right clicking on any text field of your PDF document. That is really all you have to do. After that just copy and paste normally like you were doing ut in your video

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 10, 2019 0
Community Beginner ,
Oct 12, 2019

Copy link to clipboard

Copied

Hey man. Sorry for the late answer so, the thing is when I right click in the PDF, I ain't getting the text field properties. How are you getting this? Are you using a different version of Adobe? Is there an alternative way I can reach the exact same settings?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 12, 2019 0
Adobe Community Professional ,
Oct 12, 2019

Copy link to clipboard

Copied

In the bottom right corner of this slide below there is an icon like purple-pink color that I forgot to highlight for you. Look to the  right margin of your Acrobat work space and click on the search icon and type Prepare, you will see the "Prepare Form" action toolwill be listed.

 

When You select prepare form that enables the edit mode of your document which will allow you to right click on your form fields and access their properties

 

Screenshot_20191012-201940.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 12, 2019 0
Community Beginner ,
Oct 13, 2019

Copy link to clipboard

Copied

Hey man, thank you for all these wonderful screenshots. The problem again remains the same, the text in the sticky notes changes formatting as soon as I close the comment pop-up. What you advise is more directed again towards the text already written in the PDF which we wanna change and not towards the text we write as comments in a sticky note. I still appreciate your help, and hope some senior staff admin notices my problem and helps out! 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 13, 2019 0
Adobe Community Professional ,
Oct 13, 2019

Copy link to clipboard

Copied

What work for me was just to change the properties on any text field of the document by checking the accept Rich Text format. That is the only way you can retain text with formatting when copying text from another application i. To Adobe Acrobat. You wont be able to paste text with formatting in a text field if rich text is not selected in the adobe acrobat. So what you are saying is that you were able to select the Rich Text option in your documents texts field and this work around was not useful?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 13, 2019 0
Adobe Community Professional ,
Oct 13, 2019

Copy link to clipboard

Copied

The text you write as comment is the text that you are copying and pasting from MS Word. The text that you copy from MS Word should retain the original formatting with this method.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 13, 2019 0
Community Beginner ,
Oct 13, 2019

Copy link to clipboard

Copied

Yeah, I was originally able to copy the text with formatting originally too even when the box was unchecked as you can see in my Youtube video. The problem was as soon as I clicked Post and closed the sticky note pop-up, the format reset. One more thing, this book I am adding comments to already has around 1590+ comments of mine so probably adobe isn't able to handle processing the new comments and resets the formatting maybe.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 13, 2019 0
Most Valuable Participant ,
Oct 13, 2019

Copy link to clipboard

Copied

I think you two are discussing different things. Comment boxes and form fields. Quite different. Rich text formatting is only for form fields. The original question is certainly about pop-up comment boxes, and no text fields even exist.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 13, 2019 0
Community Beginner ,
Oct 13, 2019

Copy link to clipboard

Copied

Yup, my original problem pertains to comment boxes. As seen in the video, don't know why this is happening and really has me frustrated.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 13, 2019 0
Adobe Community Professional ,
Oct 13, 2019

Copy link to clipboard

Copied

I struggle a little with English, Ive noticed how often I am misunderstood im these forums because of my horrible spelling and the lack of necessary slang to be fluent , brief and to the point. I am aware that the problem you are experiencing is entirely related to comment boxes. However, what you are looking to achieve is not possible the way you are trying to do it. What I offered is a work around that allowed me to retain the formatted text in mu comment boxes, even when i save and close my pdf document, the next time I open the file my comment boxes have retained the formatted text that was copied into them from another application. What I have been trying to explain all along is that, unless a person here knows how to do it in another way, I was able to proove that you can retain text formatting when copying and pasting, ONLY, AND ONLY IF, you go to any text field available in the page that you want to insert the comment, select properties and check the option that says enable Rich text formatting. After that click Ok close the properties dialogue box and you should be able to insert comments with formatted text that is copied from another program. If your form does not have a text field then you have to create one and apply my suggestion. If you dont need that text field to be visible make it hidden, you have to be a little creative here. And like I said , this is a work around that seems to enable that. Comme t boxes per se dont have that option when you choose properties.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 13, 2019 0
Adobe Community Professional ,
Oct 13, 2019

Copy link to clipboard

Copied

The short answer is , you have to enable rich text in a text field.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 13, 2019 0
Adobe Community Professional ,
Oct 13, 2019

Copy link to clipboard

Copied

Any text field, not a comment box, if you dont do that in a text field , you wont be able to get it to work in a comment box

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 13, 2019 0
Community Beginner ,
Oct 13, 2019

Copy link to clipboard

Copied

Hey man, firstly thank you for all the effort you have made in trying to help me out and I'm sorry if I don't sound very appreciative. I am. Deeply. Secondly, don't apologise for the language barrier, you have very good English. I did try your method, the rich text formatting applies only for the text box I create and not for anything else. The comments sticky note is from what I understand a separate thing entirely. I've PMed the folks over at Adobe Support on Twitter. Hoping they can see the problem too. Once again, thank you very much for helping me out man. Whoever you are, you are an absolute gentleman (Or gentlewoman if you're a woman)!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 13, 2019 0
Adobe Community Professional ,
Oct 13, 2019

Copy link to clipboard

Copied

You're welcome , hope fully you get this resolved

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 13, 2019 0
Adobe Community Professional ,
Oct 14, 2019

Copy link to clipboard

Copied

So I went ahead and did a little more homework.

 

These are the additional steps I would try while we wait for additional tech support guidance:

 

1) Save a copy of this document back to MS Word (or back to its original source file, then convert back to PDF)

 

This doesn't work try next step

 

2) review the following link https://helpx.adobe.com/acrobat/using/importing-exporting-comments.html

 

And explore if the problem you are experiencing can be resolved with a step in importing comments from MS Word and how to tagg them properly in the MS Word document before they are imported to the PDF document.

 

3) Creating and modifying presets, useful quick video here: https://m.youtube.com/watch?v=-dQArR2b02w

 

4) since the problem you brought up seems to be related to the comment boxes per se, and taking into account that you are able to copy and paste formatted text into a comment box, but the comment box resets itself to plain text, would it make sense if you open thumbnail view for all the pages in the document, select them all, right-click to open "Page Properties" and tick use Document Structure.

 

These are ny best suggestions at this time.

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 14, 2019 0
New Here ,
Oct 15, 2020

Copy link to clipboard

Copied

What if I am copying text from WORD like below and trying to paste in a PDF.  I can not get the formatting to stay and I am in a TEXT FIELD with rich text.

A.  s;fsd;lfsl;dkfj

      1. a;dslkfjs;ldkgjsdlf

           a.  a;dlkjsdf;lsjdflkjdlgkj

      2. a;dklgjsl;dkgjsdl

B.  a;sjkdg;lkjdg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 15, 2020 0
Adobe Community Professional ,
Oct 15, 2020

Copy link to clipboard

Copied

Can you be more specific .

 

When exactly are losing the formatting of the copied text, after you cloe Acrobat and reopen the document?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 15, 2020 0
New Here ,
Oct 15, 2020

Copy link to clipboard

Copied

the minute I paste it is all left sided with no indent or spacing.  Look below

D. Procedure
1. Inspection Requirements
a. Inspect each PPR and PS area on a quarterly basis, i.e., approximately every three months. Exceptions to this schedule must be authorized and approved by the EPL contract Principal Investigator (PI) and EPL Management and documentation to this effect included in the inspection records.
b. The inspection will take place near the end or immediately following the quarter being inspected.

 

There is no indention of the 1 or a. or b.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 15, 2020 0
Adobe Community Professional ,
Oct 15, 2020

Copy link to clipboard

Copied

Yes, I get the same issue unless you paste to Notepad which will paste in plain text with no MS Word formatting. See image below.

 

The image of the textfield  to the left  is using the copy to Notepad method first  where I set my textfield as multi line with Rich Text formatting enabled.. The image to the right is displays the same problem that you're describing when I copy from MS Word directly into a textfield with the same properties as the one on the left.

 

richtext-problem.png

 

 

The image in the center above the textfields is a free text annotation. It takes the indentations formatting but not the line spacing.

 

This could be a bug. Bu t I am still unconvinced. I am still testing.

 

 

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 15, 2020 0
ls_rbls LATEST
Adobe Community Professional ,
Oct 15, 2020

Copy link to clipboard

Copied

Ok , so this is what I found and is not related to Acrobat.

 

I think we finally got the correct answer to this old thread.

 

You can set a textfield in Acrobat as multi-line and with Rich Text Formatting. Then you need to modify the cut, copy, paste preferences in MS Word advanced options.

 

To do so go to "File" --->>> "Options" --->>> "Advanced" --->>> "Cut, copy, and, paste.

 

See image below to modify settings:

 

smartcopy-msword.png

 

 

And below is my original document in MS Word with some text formatted:

 

word-richtext.png

 

 

And the result in Acrobat using textFields with multi-line and Rich Text Formatting enabled:

 

result-richtextinAcrobat.png

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 15, 2020 0