Enterprise Deployment: Disabling "Use Flash Player for playing 3D and multimedia content" in Acrobat

New Here ,
Nov 30, 2020 Nov 30, 2020

Copy link to clipboard

Copied

I'm attempting to find the RegKey associated with disabling and locking the "Use Flash Player for playing 3D and Multimedia Content" preference in Adobe Acrobat. This corresponds to the 20.013.20064 Planned update, Nov 03, 2020 version of the application.

 

Summary of Version/Category/Setting:

  • Version (of Adobe Acrobat): 20.013.20064 Planned update, Nov 03, 2020
  • Category: 3D & Multimedia 
    • Setting: Use Flash Player for playing 3D and Multimedia Content 
      • Disabled (enabled by default)

Mpeterson9_0-1606767778306.png

The only place I can seem to anything even semi-related to the setting is: HKEY_CURRENT_USER\SOFTWARE\Adobe\Adobe Acrobat\DC\3D

 

It appears to coorespond to the b3DEnableFlashPlayer REG_DWORD (screeenshot below):Capture.PNG

 

These RegKeys are not created immediately following a successful installation. They are written upon opening the application > entering active Adobe Login credentials > then accessing the Prefrences menu (under the edit pulldown)

 

I've searched Adobe's Enterprise Registry/plist Reference but there are only options for enabling 3D content at this time.

 

Note:I understand that this is in the HKCU hive. Generally, these settings can be locked down in the HKLM hive. Specifically,  'HKLM\Software\Policies\Adobe\Adobe Acrobat\DC\FeatureLockDown'.

 

I've attempted adding the following entries within the 'Registry' area of Acrobat Customization Wizard, while configuring the MSI/MST but neither appeared to work following the installation 

  • DWORD: b3DEnableFlashPlayer
    •  Value: 0
  • Key name: c3D
    • DWORD: b3DEnableFlashPlayer
      • Value: 0

 

TOPICS
Acrobat, Admin console, Deploy and package apps, Enterprise

Views

108

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 14, 2021 Jan 14, 2021

Copy link to clipboard

Copied

I am facing a similar issue, did you get any solution

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 26, 2021 Jan 26, 2021

Copy link to clipboard

Copied

You can disable by creating a registry key like this :[HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Adobe\Adobe Acrobat\DC\3D]
"b3DEnableFlashPlayer"=dword:00000000

It worked for me.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines