Highlighted

Form fields overlap with hidden content when revealed

New Here ,
Sep 21, 2020

Copy link to clipboard

Copied

I'm working on a document that has form fields on the main body of the page, but also has two popup windows that will open when the gold buttons at the bottom are selected. However, when the popups are revealed, the form fields that should be below them are on top. I am unable to select the form fields or the popup as an object to rearrange them that way, and the "Content" view already shows the popups as being above the form fields. I want the forms to just stay behind the popups when they are revealed, or barring that to just hide the form fields when the popup is revealed. Is there any way to do what I'm trying to accomplish here? I made the file in InDesign if there might be something to try there. (I tried to export with PDF layers but that didn't help either.)

 

Lauren5EAE_0-1600715971990.png

 

Adobe Community Professional
Correct answer by George_Johnson | Adobe Community Professional

The stacking order for form fields has always (24 years) been the same as the tab order for Adobe PDF viewers, but as TSN mentioned, there is no guarantee since it isnt part of the PDF spec. But one thing you can do is hide the fields that are beneath the button when you choose to display it, and unhide them when you hide the button, in addition to setting the tab order to what makes sense for your form. I've never had a problem with just setting the tab order. 

TOPICS
Edit and convert PDFs, PDF forms

Views

85

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Form fields overlap with hidden content when revealed

New Here ,
Sep 21, 2020

Copy link to clipboard

Copied

I'm working on a document that has form fields on the main body of the page, but also has two popup windows that will open when the gold buttons at the bottom are selected. However, when the popups are revealed, the form fields that should be below them are on top. I am unable to select the form fields or the popup as an object to rearrange them that way, and the "Content" view already shows the popups as being above the form fields. I want the forms to just stay behind the popups when they are revealed, or barring that to just hide the form fields when the popup is revealed. Is there any way to do what I'm trying to accomplish here? I made the file in InDesign if there might be something to try there. (I tried to export with PDF layers but that didn't help either.)

 

Lauren5EAE_0-1600715971990.png

 

Adobe Community Professional
Correct answer by George_Johnson | Adobe Community Professional

The stacking order for form fields has always (24 years) been the same as the tab order for Adobe PDF viewers, but as TSN mentioned, there is no guarantee since it isnt part of the PDF spec. But one thing you can do is hide the fields that are beneath the button when you choose to display it, and unhide them when you hide the button, in addition to setting the tab order to what makes sense for your form. I've never had a problem with just setting the tab order. 

TOPICS
Edit and convert PDFs, PDF forms

Views

86

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 21, 2020 0
Adobe Community Professional ,
Sep 21, 2020

Copy link to clipboard

Copied

These pop-ups that you describe… Are you building them as buttons? In PDF documents, form fields are always on top of other elements in the stacking order of objects. You'll never get those buttons to appear on top of the form fiels. Now your buttons look designed visually but you could instead use JavaScript to display a real pop-up window that would actually appear on top of everything including form fields. But they would be informational only, not designed.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 21, 2020 0
New Here ,
Sep 22, 2020

Copy link to clipboard

Copied

Yes, the popups are built as buttons within InDesign. Ugh, what an annoying limitation! I don't know the first thing about Javascript, so I think I'll have to just make the popups new pages that the gold buttons redirect to.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 22, 2020 0
Most Valuable Participant ,
Sep 22, 2020

Copy link to clipboard

Copied

Not only that.... you must never overlap VISIBLE buttons or other form fields. You cannot control which ones are on top, even if it seems to reliably be a particular order. It can change any time, or for anyone else.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 22, 2020 0
Adobe Community Professional ,
Sep 22, 2020

Copy link to clipboard

Copied

The stacking order for form fields has always (24 years) been the same as the tab order for Adobe PDF viewers, but as TSN mentioned, there is no guarantee since it isnt part of the PDF spec. But one thing you can do is hide the fields that are beneath the button when you choose to display it, and unhide them when you hide the button, in addition to setting the tab order to what makes sense for your form. I've never had a problem with just setting the tab order. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 22, 2020 1
New Here ,
Sep 22, 2020

Copy link to clipboard

Copied

How can I hide the form fields? Do I set that up within Acrobat or in InDesign?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 22, 2020 0
New Here ,
Sep 22, 2020

Copy link to clipboard

Copied

Never mind, I changed the hide/show settings in InDesign and that did the trick!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 22, 2020 0