How to automatically resize text in a form text box

Community Beginner ,
Jun 02, 2016 Jun 02, 2016

Copy link to clipboard

Copied

How can I make the text a user types into a forms text box automatically resized so when they type more text in than will fit it shrinks and resizes so it still all fits?

TOPICS
Macintosh, PDF forms

Views

45.5K

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Community Beginner , Jun 02, 2016 Jun 02, 2016
Thanks for replying Michael but that does not work.With "Scroll long text" unchecked but with "Multi-line" either checked or unchecked in Acrobat Pro DC, the text field when accessed in Reader, only allows as much text as fits at the chosen point size then no more typing is accepted.Mark

Likes

translate

Translate

Translate
LEGEND ,
Jun 02, 2016 Jun 02, 2016

Copy link to clipboard

Copied

In the text field property box unchec scroll long text.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 02, 2016 Jun 02, 2016

Copy link to clipboard

Copied

Thanks for replying Michael but that does not work.

With "Scroll long text" unchecked but with "Multi-line" either checked or unchecked in Acrobat Pro DC, the text field when accessed in Reader, only allows as much text as fits at the chosen point size then no more typing is accepted.

Mark

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Jun 03, 2016 Jun 03, 2016

Copy link to clipboard

Copied

Set the font size to Auto.

On Fri, Jun 3, 2016 at 5:14 AM, markc13813473 <forums_noreply@adobe.com>

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 01, 2018 Feb 01, 2018

Copy link to clipboard

Copied

No way to just have it resize horizontally only ( ie. not reduce font size, but merely  scale it horizontally to make it squished.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Feb 01, 2018 Feb 01, 2018

Copy link to clipboard

Copied

No.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 29, 2018 Aug 29, 2018

Copy link to clipboard

Copied

Hello Try67. Been looking everywhere once i have the text in text box selected where do you find the auto size? Can't seem to find it? Think I may need readers soon

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Aug 30, 2018 Aug 30, 2018

Copy link to clipboard

Copied

Do you have Acrobat or the free Reader?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 30, 2018 Aug 30, 2018

Copy link to clipboard

Copied

I have the Acobat DC not Reader.

Brigitte Duchesne

Print Support Specialist I

Kroger National Support Team

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Aug 30, 2018 Aug 30, 2018

Copy link to clipboard

Copied

Go to Prepare Form mode, right-click the field, select Properties, switch to the Appearance tab and set the font size setting to Auto.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 30, 2018 Aug 30, 2018

Copy link to clipboard

Copied

Thank you Try67.Will try!

Brigitte Duchesne

Print Support Specialist I

Kroger National Support Team

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 29, 2020 May 29, 2020

Copy link to clipboard

Copied

THANK YOU!!!

This can also be done prior to exporting an interactive PDF in InDesign ❤️

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 25, 2019 Jun 25, 2019

Copy link to clipboard

Copied

Try67 with the actual correct answer. Thank you kind soul.

(And yes, I feel silly for not remembering, too.)

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 08, 2020 Jun 08, 2020

Copy link to clipboard

Copied

Hello,

For some reason Auto isn't an option when I try to change the font size? I've unchecked "scroll down" and have checked/unchecked the other options of rich text and multi line to see if any of that helps to make it appear and it is still not an option?  Any help is very very appreciated.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 08, 2020 Jun 08, 2020

Copy link to clipboard

Copied

What can you see at Font Size?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 08, 2020 Jun 08, 2020

Copy link to clipboard

Copied

Good Morning,

 

Not meaning to jump in, but for the life of me, I cannot post a question (I can only reply!) - when trying to post a question in the Acrobat page, I'll type my question, hit post, and I get an error saying topics.JPG

but I'm not able to click (select) any of those things to provide a topic.  I also did not see where I could select the topic from thei get-go.  Again, apologies for jumping in but I'm so new I can't even get a question posted.  If someone could help with that portion, then I'll ask my question in the appropriate spot.

 

Thanks in advance,

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 05, 2016 Jun 05, 2016

Copy link to clipboard

Copied

Derrhhh! I am so blind.

Knew there had to be a simple way.

Thanks heaps "try67"

Mark

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 24, 2020 Mar 24, 2020

Copy link to clipboard

Copied

I have the font size set to auto, the scroll long text unchecked, allow rich text formatting checked, multi-line is checked but it doesn't amend the font size and only lets me type as much as will fill the box. I can only write more with the scroll long text ticked.

How can I get it to reduce the font size automatically to write unlimited amount of text in the field?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 24, 2020 Mar 24, 2020

Copy link to clipboard

Copied

fixed it by unticking 'allow rich-text formatting'.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 30, 2020 Mar 30, 2020

Copy link to clipboard

Copied

Not working for me. I've clicked and unclicked the above in different combinations, but I still get fields that won't resize. Auto size, on/off multiple lines, on/off scroll to the right, on/off rich text. In fact, when I activate Rich Text things get HUGE but never shrink back down. I'm at a loss. That + box inside the form field is the bane of my existence!!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 31, 2020 Mar 31, 2020

Copy link to clipboard

Copied

What field type is it you're using and what property settings do you have?

 

It worked for me with these settings for a Text Field:

Appearance: Font size = Auto

Options:

Multi-line = ticked

Scroll long text = unticked

Allow Rich Text Formatting = unticked

Limits = unticked

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 16, 2020 Jun 16, 2020

Copy link to clipboard

Copied

I am having the same issues,  my fields won't resize when set to auto. This has worked for me in the past with no problems but it doesn't seem to work anymore.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 12, 2021 Mar 12, 2021

Copy link to clipboard

Copied

I've been fighting this problem and reading all the answers and nothing was working until I did the following:

• Appearance: Font size=Auto

• Options: Everything unchecked

 

With this setup, the text in the interactive field reduces in size automatically to fit the field as more letters are typed in. 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 12, 2021 Mar 12, 2021

Copy link to clipboard

Copied

The only remaining question I still have is how to get the automatically-reducing text in the interactive field to always align to the top of the text field? It's aligning centered, which means as more text is entered, the top of the text moves downward.

 

Anyone have an answer for that?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 30, 2021 Apr 30, 2021

Copy link to clipboard

Copied

When you right click on a field, under Options there should be an alignment option at the very top of the box. Also, for whatever reason, once I unclicked all the options and then selected mult-line again with Auto selected for text, the text box resized and worked properly. 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines