How to fix a SERIOUS lag issue for Acrobat and Reader on a Macbook Pro for forms? Please.

Community Beginner ,
Dec 06, 2011

Copy link to clipboard

Copied

Both adobe reader 9 and 10 as well as Acrobat 10 are INSANELY slow on my brand new Macbook Pro when I try and fill out forms.

It laggs like crazy. I cant even believe how slow it is.

I have 2 gigs of ram available so thats not the problem.

I am also running the latest version on lion 10.7.2 i think

I cant find information on this anywhere and I am desperate. I was forced to download parrarels and use the windows reader and acrobat because this is just crazy

Someone please help

Views

49.6K

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

1 Correct Answer

New Here , Dec 21, 2011
STCopper97 New Here , Dec 21, 2011
http://superuser.com/questions/242576/adobe-reader-unusably-slow-on-mac-os-x-10-6-6The solution to my problem with lagging Reader and Acrobat were solved by following the above link. The only difference was I was not able to exclude RightZoom app from Adobe, so instead of allow a/exlcude this one. I excluded all/only allow these. If you have RIghtZoom app installed on you MAC (regardless of the version of OS you're using) this fix work. After 9 months of fustrations, problem solved.

Likes

Translate

Translate
Jump to answer Jump to answer
Adobe Community Professional ,
Dec 10, 2011

Copy link to clipboard

Copied

Hi,

is the lag issue occurs with only one form*, some forms* or all forms ?

If * : are they simple forms (one page, a few fields) or complex forms (many pages, many fields with many calculations) ?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Dec 10, 2011

Copy link to clipboard

Copied

Actually, revently I have noticed that it is not just forms. Its all PDF documents. I ununstalled Acrobat X and tried just using Reader to preview the docs and same thing. I then uninstalled Reader 10 (or whtever the latest version is) and installed 9.4 and the problem still persists.

The mac is having no problems other than that, it runs like a dream. But this Reader problem is driving me crazy. I cant even scroll through a document because its just so laggy

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Dec 11, 2011

Copy link to clipboard

Copied

Did you try to run Reader and/or Acrobat in 32 bits mode ?

(Right-clic the app icon : Show info : then tick the 32 bits checkbox)

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Dec 11, 2011

Copy link to clipboard

Copied

Yes, I did. Then I ran it in 64 bit mode and same thing...

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Dec 12, 2011

Copy link to clipboard

Copied

I can't help futhermore.

You should ask Adobe, may be there is a conflict with another software…

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Dec 21, 2011

Copy link to clipboard

Copied

http://superuser.com/questions/242576/adobe-reader-unusably-slow-on-mac-os-x-10-6-6

The solution to my problem with lagging Reader and Acrobat were solved by following the above link. The only difference was I was not able to exclude RightZoom app from Adobe, so instead of allow a/exlcude this one. I excluded all/only allow these. If you have RIghtZoom app installed on you MAC (regardless of the version of OS you're using) this fix work. After 9 months of fustrations, problem solved.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
markymark6922 AUTHOR LATEST
Community Beginner ,
Dec 30, 2011

Copy link to clipboard

Copied

Holy crap. You have no idea how much youve helped, no homo but i love you. I was ready to call apple support.

YESSSS!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more