Highlighted

PDF UTF8 Character rendering Issue - some charaters have overlaps with unwanted inverted color

Community Beginner ,
Nov 02, 2020

Copy link to clipboard

Copied

Hi there all,

i have an unexpected rendering behaviour when i open a PDF with special Charaters (polnish) in Acrobat.

These PDFs are intended for print-use and generated by PDF Reactor (service to generate PDF from Webpages/css) the encoding is UTF8, the concerning Font is "Montserrat bold" (https://fonts.google.com/specimen/Montserrat)

 

The issue is, these unexpected rendering glitch does appear in Acrobat Pro (and on import to Photoshop) but NOT if i open the same PDF in Chrome (native PDF view)

(See attached Screenshot)

did anybody know this issue and can provide help /workaround or an explanation?

 

thanks in advance!

best,

 

 

inversCharacters-PDF.png

 

**** SOLVED ****

meanwhile i've solved the issue - intuitively 🙂

 

Here is what happend:

 

tldr: This Issue was - assumetly - from a bad font conversion.

 

Originally, the Font Family Montserat was downloaded from google fonts (ttf format) 

To use it for web, i once utilized a online font converter (font-converter.net) to get web-compatible formats; Open Type, woff, woff2, svg... etc. This online Tool does not just convert any ttf-Font, it creates a @Font-face-css snippet accordingly. Comes in handy!

 

As i've said, the PDFs were created on a server utilizing PDF Reactor (really great service by the way). After some reasearching (RTFM! 😉 i've found out, PDF Reactor can use ttf format alone, there is no need to have fonts converted to web-font-formats.

 

So, my idea was "use the original ttf, conversion is likely to have issue of those kind". Seems it has indeed. I put on the original, non-converted ttf-Font file from the original source Montserrat.zip online, editied the css that the ttf Format is loaded only @Font-face- and ... Bingo! My issue was gone. 🙂

 

thanks everyone for helping me as being a total newbie on this forum. 🙂

best,

TOPICS
Create PDFs, General troubleshooting, Print and prepress

Views

92

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

PDF UTF8 Character rendering Issue - some charaters have overlaps with unwanted inverted color

Community Beginner ,
Nov 02, 2020

Copy link to clipboard

Copied

Hi there all,

i have an unexpected rendering behaviour when i open a PDF with special Charaters (polnish) in Acrobat.

These PDFs are intended for print-use and generated by PDF Reactor (service to generate PDF from Webpages/css) the encoding is UTF8, the concerning Font is "Montserrat bold" (https://fonts.google.com/specimen/Montserrat)

 

The issue is, these unexpected rendering glitch does appear in Acrobat Pro (and on import to Photoshop) but NOT if i open the same PDF in Chrome (native PDF view)

(See attached Screenshot)

did anybody know this issue and can provide help /workaround or an explanation?

 

thanks in advance!

best,

 

 

inversCharacters-PDF.png

 

**** SOLVED ****

meanwhile i've solved the issue - intuitively 🙂

 

Here is what happend:

 

tldr: This Issue was - assumetly - from a bad font conversion.

 

Originally, the Font Family Montserat was downloaded from google fonts (ttf format) 

To use it for web, i once utilized a online font converter (font-converter.net) to get web-compatible formats; Open Type, woff, woff2, svg... etc. This online Tool does not just convert any ttf-Font, it creates a @Font-face-css snippet accordingly. Comes in handy!

 

As i've said, the PDFs were created on a server utilizing PDF Reactor (really great service by the way). After some reasearching (RTFM! 😉 i've found out, PDF Reactor can use ttf format alone, there is no need to have fonts converted to web-font-formats.

 

So, my idea was "use the original ttf, conversion is likely to have issue of those kind". Seems it has indeed. I put on the original, non-converted ttf-Font file from the original source Montserrat.zip online, editied the css that the ttf Format is loaded only @Font-face- and ... Bingo! My issue was gone. 🙂

 

thanks everyone for helping me as being a total newbie on this forum. 🙂

best,

TOPICS
Create PDFs, General troubleshooting, Print and prepress

Views

93

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 02, 2020 0
Adobe Community Professional ,
Nov 02, 2020

Copy link to clipboard

Copied

In the future, So people don't have to download the image you have attached, please use the Insert Photos icon found in the Tool Bar of the Post and Reply text entry dialog window as pictured below.
Since you Can't Edit your original post to remove the Attached screen shot Please include the screen shot you attached to a new reply to this conversation by clicking the Blue Reply button under your original post and use the Insert Photos icon in the tool bar.
The Insert Photos icon is this one in the Tool Bar.
2020-10-06 16_53_14-2020-10-06 - Adobe Support Community_Updated.png

Thank you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 02, 2020 1
Community Beginner ,
Nov 02, 2020

Copy link to clipboard

Copied

oh, i see.... thanks for the hint, Just Shoot me! 🙂

 

inversCharacters-PDF.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 02, 2020 0
Explorer ,
Nov 02, 2020

Copy link to clipboard

Copied

When you exported the PDF, did you check the option to embed all fonts? When they're not embedded in the PDF, Acrobat and other PDF renderers will not render all or some characters correctly.

 

Design + Accessibility | Author | Designer | Programmer | Trainer

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 02, 2020 0
Community Beginner ,
Nov 03, 2020

Copy link to clipboard

Copied

Hey The Accessible Dezinah,

thank you for your reply! Good Point, i did not checked that. Yes, they are embedded (embedded subset) I use both Montserrat-Regular and Montserrat-bold (it is the bold one where the issue occurs btw) - but in Acrobat it shows me 2x embedded Montserrat Fonts but they are both named the same "Montserrat-Identity-H" ... i wonder why they are named like this. (curious. will google identity-h next)...

best,

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 03, 2020 0
Community Beginner ,
Nov 03, 2020

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 03, 2020 0
Adobe Community Professional ,
Nov 03, 2020

Copy link to clipboard

Copied

"Since you Can't Edit your original post to remove the Attached screen shot"

Moderators can.

😉

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 03, 2020 1
Adobe Community Professional ,
Nov 03, 2020

Copy link to clipboard

Copied

Untick the "Use local fonts" option and try to play with the 2 other.

 

Acrobat_t8LAGpTLCg.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 03, 2020 0
Community Beginner ,
Nov 03, 2020

Copy link to clipboard

Copied

Hey JR Boulay

Thank you for your response too. This one, i've already checked. i found it at a prior research on this forum 🙂

This Montserrat Font is not on my local machine anyway. (To get more context: The PDF is created on a server using PDF Reactor)... Also the enhance thin lines nor smooth line art option does not make any difference on my issue..

best,

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 03, 2020 0
Community Beginner ,
Nov 03, 2020

Copy link to clipboard

Copied

**** SOLVED ****

meanwhile i've solved the issue - intuitively 🙂

 

Here is what happend:

 

tldr: This Issue was - assumetly - from a bad font conversion.

 

Originally, the Font Family Montserat was downloaded from google fonts (ttf format) 

To use it for web, i once utilized a online font converter (font-converter.net) to get web-compatible formats; Open Type, woff, woff2, svg... etc. This online Tool does not just convert any ttf-Font, it creates a @Font-face-css snippet accordingly. Comes in handy!

 

As i've said, the PDFs were created on a server utilizing PDF Reactor (really great service by the way). After some reasearching (RTFM! 😉 i've found out, PDF Reactor can use ttf format alone, there is no need to have fonts converted to web-font-formats.

 

So, my idea was "use the original ttf, conversion is likely to have issue of those kind". Seems it has indeed. I put on the original, non-converted ttf-Font file from the original source Montserrat.zip online, editied the css that the ttf Format is loaded only @Font-face- and ... Bingo! My issue was gone. 🙂

 

thanks everyone for helping me as being a total newbie on this forum. 🙂

best,

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 03, 2020 0
Explorer ,
Nov 03, 2020

Copy link to clipboard

Copied

Glad you figured it out!

Lesson to learn: PDF is NOT HTML. Therefore use regular fonts.

Design + Accessibility | Author | Designer | Programmer | Trainer

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 03, 2020 0