Highlighted

Select entire field when tabbing in acrobat

New Here ,
Aug 06, 2020

Copy link to clipboard

Copied

Hello,

 

I have a fillable PDF and when I tab from field to field the entire field is highlighted so anything I type overwrites the previous value, which is what I want but that does not happen with 1 field. Is there anything I can do to make it happen for the field as well? I have access to Acrobat Pro version so I can edit the file, change field properties etc.

 

Background: I need to create a bunch of files (1000+) and everytime I use Excel macros to create them with personalized data, the field in question, the contents are being appended instead of being cleared. So, the field contains usernames and assuming a sequence of un1, un2, un3 etc. - the first file is correct with un1 but the second one contains un1un2, the third one contains un1un2un3 and so on, in that field.

 

The rest of the fields (there are about 15) work correctly with the values getting overwritten.

 

Kinda urgent. Any help would be greatly appreciated

TOPICS
How to

Views

32

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Select entire field when tabbing in acrobat

New Here ,
Aug 06, 2020

Copy link to clipboard

Copied

Hello,

 

I have a fillable PDF and when I tab from field to field the entire field is highlighted so anything I type overwrites the previous value, which is what I want but that does not happen with 1 field. Is there anything I can do to make it happen for the field as well? I have access to Acrobat Pro version so I can edit the file, change field properties etc.

 

Background: I need to create a bunch of files (1000+) and everytime I use Excel macros to create them with personalized data, the field in question, the contents are being appended instead of being cleared. So, the field contains usernames and assuming a sequence of un1, un2, un3 etc. - the first file is correct with un1 but the second one contains un1un2, the third one contains un1un2un3 and so on, in that field.

 

The rest of the fields (there are about 15) work correctly with the values getting overwritten.

 

Kinda urgent. Any help would be greatly appreciated

TOPICS
How to

Views

33

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 06, 2020 0
Most Valuable Participant ,
Aug 06, 2020

Copy link to clipboard

Copied

That's very strange. What kind of a field is it? What happens when you tab into it? Can you share the file with us?

Also, what application (including the exact version number) are you using?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 06, 2020 0
New Here ,
Aug 06, 2020

Copy link to clipboard

Copied

1. Field type: A multi-line text field

2, If I have content in the field, tabbing into it, causes the text cursor to be placed at the end of the text. Other fields, when tabbed into, the text is highlighted, so any edits will overwrite that content.

3. US Government Form file - not sure I can share it. I will try to create a temp file and post it

4. File creator: Adobe Acrobat 2017 - this is acting up and I cannot bring it up to give you the exact version not can I create a temp file at this moment.

5. Using the following to tab around -

Adobe Reader DC Version: 2020.009.20074

 

FWIW, this does not happen with Foxit Reader (Unfortunately I cannot install any software on my PC at work - Federal Govt standards and some such crap)

 

Regards

 

Thank you

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 06, 2020 0
Most Valuable Participant ,
Aug 06, 2020

Copy link to clipboard

Copied

OK, it's just how Acrobat (and Reader) handle multiline fields. There's nothing that can be done to change it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 06, 2020 0
ramanr LATEST
New Here ,
Aug 06, 2020

Copy link to clipboard

Copied

Thank you for the clarification and education.

I will uncheck the "Multi-line" option. I truly do not need multi-line capability for that field.

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 06, 2020 0