Smooth scrolling through pages

Explorer ,
Dec 27, 2012 Dec 27, 2012

Copy link to clipboard

Copied

Hello,

I am using Acrobat X. I have noticed that with some PDF documents I can smoothly scroll from one page to the next.  That is, as I scroll I see the last part of one page and the first part of the next page, but they are definitely separate pages.  In other PDF documents, however, I cannot do this.  Instead, I can only see one complete page on the screen at a time.  When I scroll it simply jumps to the entire next page all at once.  In most cases my preference is the smooth scrolling behavior.  I assume the different behavior lies in how the PDF file was created.  Could someone please tell me what causes this difference?  I actually have the source code for a custom PDF file creator and I want to make sure I create PDFs with the smooth scrolling behavior.

Thanks,

Ray

TOPICS
Create PDFs, Windows

Views

83.9K

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Dec 27, 2012 Dec 27, 2012
If the document is not locked from editing, do this in Acrobat X:Ctrl D or File > PropertiesClick on the Initial View tab  > and from the Page Layout drop-down menu,choose: Default or Single Page ContinuousClick OK, Close and Save the document to keep changes.When you open the document, it should have the continuous scrolling you want.You may want to  lock the document afterwards,if you do not want other Acrobat users tampering with the settings.

Likes

translate

Translate

Translate
Adobe Community Professional ,
Dec 27, 2012 Dec 27, 2012

Copy link to clipboard

Copied

If the document is not locked from editing, do this in Acrobat X:

Ctrl D or File > Properties

Click on the Initial View tab  > and from the Page Layout drop-down menu,choose: Default or Single Page Continuous

Click OK, Close and Save the document to keep changes.

When you open the document, it should have the continuous scrolling you want.

You may want to  lock the document afterwards,if you do not want other Acrobat users tampering with the settings.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 27, 2012 Dec 27, 2012

Copy link to clipboard

Copied

Thanks for the suggestion, but I had already tried this and it had no affect on any of my documents.  The ones that already scroll smoothly are not affected by changing the setting to "Single Page" and the ones that don't scroll smoothly are not affected by changing the setting to "Single Page Continuous".

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Dec 28, 2012 Dec 28, 2012

Copy link to clipboard

Copied

I assume you definitely are saving, CLOSING and reopening?  Does it help to change the settings under View > Page Display (which are NOT saved).

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 28, 2012 Dec 28, 2012

Copy link to clipboard

Copied

I must have been doing something wrong.  I tried it again by saving and reopening and it worked as desired.  It also worked by going to the View->Page Display and selecting Enable Scrolling.  Is there any way to have Acrobat always open documents in the scrolling mode rather than having to select it for each individual document?  Thanks a lot for all your help!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 28, 2012 Dec 28, 2012

Copy link to clipboard

Copied

Yes you can set a default for page view/smooth scroll for all docs, but it will be just for your Acrobat Pro.

Edit > Edit Preferences (ctrl k) > Page Display

page display.png

Click OK and that will be the default.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 05, 2017 Sep 05, 2017

Copy link to clipboard

Copied

The one that worked for me was written by Gener7.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 02, 2020 May 02, 2020

Copy link to clipboard

Copied

This does not work for me. I have used the Cntrl D procedure as well as changing the defaults to continuous scrolling in Preferences. I am using Windows 10 and have a high-end workstation, only a few months old, so the hardware is not at issue. This is crazy. How can it be so clunky?!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 03, 2020 Jun 03, 2020

Copy link to clipboard

Copied

Here's what worked for me: Adobe Pro (9.x) View=>Page Display=>Single Page Continuous Adobe Acrobat Reader DC (20.009) View=>Page Display=>Enable Scrolling Neither of the documents I just tested are locked from editing (that I know of). Windows 10 OS

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 03, 2020 Jun 03, 2020

Copy link to clipboard

Copied

Here's what worked for me: Adobe Pro (9.x) View=>Page Display=>Single Page Continuous Adobe Acrobat Reader DC (20.009) View=>Page Display=>Enable Scrolling Neither of the documents I just tested are locked from editing (that I know of). Windows 10 OSAdobe Screenshot.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 17, 2020 Sep 17, 2020

Copy link to clipboard

Copied

only this one works for me

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 22, 2020 Jul 22, 2020

Copy link to clipboard

Copied

Hi All,


Thank you for reporting this issue.

 

We see that this has been an ongoing issue and long-tailed.

We have tried to replicate this issue on our end. However, the issue cannot be reproduced in-house. That is why we need a few details for further investigation on this. It would be helpful if you can share the following information:

- Please share any sample PDF on which the issue can be reproduced.

- If possible, share the screen recording of the issue occurring on your end.

- Application (https://helpx.adobe.com/acrobat/kb/identify-product-version.html) and OS version used on the machine.

- If you are using the Windows machine, please collect the Process Monitor logs. Download the Process monitor tool from this link: https://labs.adobe.com/downloads/acrobatmonitor.html on your machine and run it. Then reproduce the issue and save the logs. Share the logs with us.

 

We will be waiting for your response.

 

Regards,

Meenakshi

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 30, 2020 Jul 30, 2020

Copy link to clipboard

Copied

I stumbled across this thread looking for a setting to change this behaviour.  I look at a lot of PDF files daily and the pages are packed with information, including important header information.  When I scroll through documents, it seems like way more work than necessary to read information near the top and bottom margins of each page.  I believe it is specific to the document since I just loaded Reader and the welcome document scrolls fine in Reader and my Pro 2020 version.  I can also add that the files I am having issues with are converted from excel through the Adobe plugin.  So maybe it is a setting in the plug-in.  If so, it would be nice to fix existing PFDs.  It may also be affected that the page orientation is not the same for all pages.  Hope this helps.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 10, 2020 Aug 10, 2020

Copy link to clipboard

Copied

I think the issue that is not entirely being addressed here is that CONTINUOUS SCROLLING can be chalged globally in PREFERENCES.  SMOOTH scrolling is not a global setting and most of the questions here are about SMOOTH scrolling.  As I recall, in preveious versions, it was a default.  Could be wrong, but I haven't had issues with SMOOTH scrolling until recently (last 12 months or so?).  So how do we make scrolling both CONTINUOUS and SMOOTH?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 01, 2020 Oct 01, 2020

Copy link to clipboard

Copied

I have had this problem recently as well. I have a movement disorder and so I am prone to overscrolling and whipping past pages unless I am go to view-> page display and Enable Scrolling. I have to make this change for every PDF I open and save, and then usually it will remain when I return to that document. It seems like sometime in the past few months it became the default for all documents, even ones I downloaded years ago. Certainly everything I download fresh opens with that setting and must be changed.

 

changes in Edit->Preferences do not change this.

Chages in File->Properties-> Initial View (Page layout) do not change this either.

 

I am using Acrobat Pro DC Continuous Release, currently at version 2020.012.20048

I'll be happy to provide files before and after the modification I use.

The link for the Process Monitor is dead however.

 

Thanks

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Oct 01, 2020 Oct 01, 2020

Copy link to clipboard

Copied

This is not a problem or a bug, it works as espected. In many cases when you generate a complex (VERY COMPLEX 300 MB vector pdfs with Wide Gamut, etc, like books on Biochemistry or Colorimitry or Functional Analsys) it is not generated as a book, but more like a PowerPoint Presentation, where you while scrolling activate animation or change objects. Here, as I understand, the part of the pdf page is the same and so when you scroll (fast wheel scrolling is blocked, BTW) the default behaviour is to go just to another page. See for example the book "Color Appearance Models" by Mark Fairchild on Library Genesis. And many many other books.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Oct 02, 2020 Oct 02, 2020

Copy link to clipboard

Copied

Disregard the powerpoint part, apparently there is just some metadata that defines the default. It actually changes the preference in View menu. So all is good.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 29, 2021 Apr 29, 2021

Copy link to clipboard

Copied

Can I ask you, if your in-house experience works like this:

1. You view the document zoomed in so you see about 1/2 of the page. (Why? because almost all screens are landscape orientation, so viewing the whole page at once makes the text too small to read).

 

2. You drop a cursor in a document, and as you read, you hit the arrow down button to make the text scroll so you can read it.  

 

3. The cursor gets tot he end of the page.

 

4. Tapping the down arrow, the cursor arrives at the top of the next page.

 

5. [THIS IS THE KEY] Tapping the down arrow the cursor moves down to the second line of that page?

 

Because that's were things go wrong for me.  In step 5 the cursor jumps from the first line of the page all the way to the bottom of the same page.  Combined witht the fact that I am not viewing the whole page at once, this causes my view to jump from the bottom half of one page to the bottom half of the next page.

 

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 27, 2021 Mar 27, 2021

Copy link to clipboard

Copied

With the document open, click on "View" on top, click on "Page Display", from the drop down menu, choose (click on) "enable scrolling"

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines