When using Edit tool in Acrobat, punctuation jumps to beginning of sentence.

New Here ,
Apr 25, 2021 Apr 25, 2021

Copy link to clipboard

Copied

Regarding Adobe Acrobat Pro DC (Continuous Release, Version 2021.001.20135) I am on a desktop using Windows 10 Enterprise.  The local language is Hebrew, a right-to-left language.  When using the "Edit" tool to edit PDFs in English, as soon as I start editing, the punctuation of the sentence jumps to the front of the sentence.  I have tried all of the solutions already posted in this forum, and all of my settings are for "English" and left-to-write reading.  I have not found a solution yet in this forum.  I don't know if Adobe actually has a solution to this problem.  I would like to find a person at Adobe technical support, who can work with me on fixing this.  If there is no solution, I would like to know that too.  We are wasting far too much time in my office with this punctuation issue.  Thank you.

TOPICS
Edit and convert PDFs

Views

119

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Apr 25, 2021 Apr 25, 2021

Copy link to clipboard

Copied

You should not try to edit a PDF file directly in this way. They were never meant to be edited like that, and doing so is always going to be problematic, especially in RTL languages.

You should edit the original file and then create a new PDF file from that file when done.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 25, 2021 Apr 25, 2021

Copy link to clipboard

Copied

Thank you so much for your reply.  I'm not sure what you mean "not meant to be edited that way".  Isn't that what the "Edit" tool is for?

Unfortunately, the PDF file is generated by U.S. Tax preparation software.  We try to set preferences for specific language in the software as much as possible before generating a PDF, but there are always a few tweaks necessary, which is when the punctuation jumps.  

What I hear you saying is that you are not aware of a fix for this, so we should use workarounds.  Thank you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Apr 25, 2021 Apr 25, 2021

Copy link to clipboard

Copied

It is, but should only be used as a last resort, if no other option is possible, which might be the situation in your case, it seems... There are no easy fixes for such issues, though.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 25, 2021 Apr 25, 2021

Copy link to clipboard

Copied

LATEST

For anyone else having this problem, the simplest workaround I have found so far is to copy the text in the original PDF, then in the "Comment" tool, draw a text box (with invisible/transparent borders) over the PDF original text, paste the text back in, and edit.  The punctuation doesn't jump in the new text box.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines