Our panel for AME doesn't work properly in audio mapping for sequential jobs

New Here ,
Dec 06, 2021 Dec 06, 2021

Copy link to clipboard

Copied

Hi, 

We've developed the AME panel take the encoding job from our desktop app(Mac/Windows) and process it as @Bruce Bullis advised last year.

It's really helpful.

We would like to thank Dan too.

 

Unfortunately, Our panel has two problems sometimes(one is major, and another is minor).

Firstly, under the situation like below output's audio mapping doesn't work correctly. Let me explain the situation the problem occurs.

 

versions:

# AME 15.4.1(build 5)

 

inputs: 

#video1 (XD4C.MXF)

XDCAM HD422 MXF, 4 x mono audio

 

#video2 (XD8C.MXF)

XDCAM HD422 MXF, 8 x mono audio

 

presets(The forum can't accept .epr files, so they're attacted as .docx):

#preset1 (Apple ProRes 422 LT_4CH.epr)

for 4 x mono audio input(#video1)

#preset2 (Apple ProRes 422 LT_8CH.epr)

for 8 x mono audio input(#video2)

 

the situation :

1. Our desktop app sends #video1/#preset1 info to the panel  and the panel runs the code below

 

 

 

 

csLib.evalScript(`app.getFrontend().addFileToBatch('/Users/admin/Documents/AME-REST/XD4C.MXF', 'Apple ProRes 422 LT_4CH', '/Library/Application Support/Adobe/CEP/extensions/com.malgn.ame-rest-service/preset/Apple ProRes 422 LT_4CH.epr', '/Users/admin/Documents/AME-REST/output/test')`, res => console.log(res));



csLib.evalScript(`app.getEncoderHost().runBatch()`, res => console.log(res));

 

 

 

 

=> The output is created by 'Apple ProRes 422 LT_4CH.epr' successfully(4 X mono -> 4 X mono).

 

2. Our desktop app sends #video2#preset2 info to the panel  and the panel runs the code below

 

 

 

 

csLib.evalScript(`app.getFrontend().addFileToBatch('/Users/admin/Documents/AME-REST/XD8C.MXF', 'Apple ProRes 422 LT_8CH', '/Library/Application Support/Adobe/CEP/extensions/com.malgn.ame-rest-service/preset/Apple ProRes 422 LT_8CH.epr', '/Users/admin/Documents/AME-REST/output/test')`, res => console.log(res));



csLib.evalScript(`app.getEncoderHost().runBatch()`, res => console.log(res));

 

 

 

 

=> We tell the panel to use 'Apple ProRes 422 LT_8CH.epr', but it creates output has 4 X mono audio like the job before(8 X mono -> 4 X mono, we want to same 8 X mono audio as output).

Additionaly, if we tried .epr with 2 X Mono Audio setting before it, it creates output has 2 X mono audio(8 X mono -> 2 X mono).

 

It seems like the second job use the .epr right before, but log from AME said us it uses the proper preset file.

 

log(from AME) :

 

 

 

 

 - 소스 파일(source file): /Users/admin/Documents/AME-REST/XD4C.MXF
 - 출력 파일(output file): /Users/admin/Documents/AME-REST/output/test_1.mov
 - 적용된 사전 설정(applied preset) : Apple ProRes 422 LT_4CH
 - 비디오(video): 1920x1080 (1.0), 29.97fps, 위쪽, 100 (63% HLG, 51% PQ), 품질 100, Apple ProRes 422 LT, 00:00:54:13
 - 오디오(audio): 비압축, 48000 Hz, 4 x mono, 16비트
 - 비트 전송률(bitrate): 
 - 인코딩 시간(encode time): 00:00:58
12/06/2021 02:30:03 PM : 파일 인코딩 성공(encoding the file is succeeded)

12/06/2021 02:30:04 PM : 대기열 중지됨(queue stopped)

12/06/2021 02:30:14 PM : 대기열 시작됨(queue started)

 - 소스 파일(source file): /Users/admin/Documents/AME-REST/XD8C.MXF
 - 출력 파일(output file): /Users/admin/Documents/AME-REST/output/test_2.mov
 - 적용된 사전 설정(applied preset): Apple ProRes 422 LT_8CH
 - 비디오(video): 1920x1080 (1.0), 29.97fps, 위쪽, 100 (63% HLG, 51% PQ), 품질 100, Apple ProRes 422 LT, 00:01:00:00
 - 오디오(audio): 비압축, 48000 Hz, 4 x mono, 16비트
 - 비트 전송률(bitrate): 
 - 인코딩 시간(encode time): 00:01:05
12/06/2021 02:31:20 PM : 파일 인코딩 성공(encoding the file is succeeded)


12/06/2021 02:31:20 PM : 대기열 중지됨(queue stopped)


12/06/2021 02:42:59 PM : 대기열 시작됨(queue started)

 

 

 

 

*attached translation for Korean in parenthesis

 

We don't think threre's a problem in the preset file, It doesn't occur when we do same thing manually with mouse, not through the panel. 

 

when we use XDCAM HD422 preset with same audio preset, it works well like below.

 

log(from AME) :

 

 

 

 

 - 소스 파일(source file): /Users/admin/Documents/AME-REST/XD4C.MXF
 - 출력 파일(output file): /Users/admin/Documents/AME-REST/output/Test-.mxf
 - 적용된 사전 설정(applied preset): XDCAM HD 50 NTSC 60i_4CH
 - 비디오(video): 1920x1080 (1.0), 29.97fps, 위쪽, 203 (75% HLG, 58% PQ), 00:00:54:13
 - 오디오(audio): 48000 Hz, 4ch, 24비트
 - 비트 전송률(bitrate): 
 - 인코딩 시간(encode time): 00:00:08
12/06/2021 02:43:07 PM : 파일 인코딩 성공(encoding the file is succeeded)


12/06/2021 02:43:07 PM : 대기열 중지됨(queue stopped)


12/06/2021 02:43:14 PM : 대기열 시작됨(queue started)


 - 소스 파일(source file): /Users/admin/Documents/AME-REST/XD8C.MXF
 - 출력 파일(output file): /Users/admin/Documents/AME-REST/output/Test-_1.mxf
 - 적용된 사전 설정(applied preset): XDCAM HD 50 NTSC 60i_8CH
 - 비디오(video): 1920x1080 (1.0), 29.97fps, 위쪽, 203 (75% HLG, 58% PQ), 00:01:00:00
 - 오디오(audio): 48000 Hz, 8ch, 24비트
 - 비트 전송률(bitrate): 
 - 인코딩 시간(encode time): 00:00:15
12/06/2021 02:43:29 PM : 파일 인코딩 성공(encoding the file is succeeded)


12/06/2021 02:43:30 PM : 대기열 중지됨(queue stopped)

 

 

 

 

 

Lastly, after we clean the queue manually, job request from the panel always fails. We must restart AME. 

 

Please let us know if you have solutions.

Thanks.

TOPICS
Error or problem

Views

75

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 07, 2021 Dec 07, 2021

Copy link to clipboard

Copied

LATEST

We're investigating a potential problem in the sample panel...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines