Can't select hardware accelerated encoding in Create Preset menu with a 1080 Ti?

New Here ,
Apr 19, 2018 Apr 19, 2018

Copy link to clipboard

Copied

Hardware:

Ryzen Threadripper 1950X @ 4.0GHz

Nvidia GeForce GTX 1080 Ti @ 1757MHz

64GB 3733Mhz RAM

If more specs would help with your input let me know and I can give a more thorough accounting.

To clarify, when I open media encoder, the "Renderer: _____" dropdown defaults to Mercury GPU Acceleration (CUDA), so it is showing up. I can manually set that to Software Only. But when I go to create a new preset, or edit the *ENCODING* settings of any existing preset, the dropdown menu for "Performance:" is grayed out and inaccessible. I'm not sure if this stops me from actually recruiting the GPU for encoding. Or if it's just grayed out because it's going to use whatever I pick for rendering anyway. That would be kind of a problem if I want to use GPU for rendering and CPU for encoding, which I've heard affects quality for some codecs. And if my system is not actually using the GPU for rendering then I have a serious problem obviously. There is nothing wrong with the GPU or my drivers. I have the latest Nvidia drivers and in fact I never had any older drivers to begin with since I built this PC a month ago. Every aspect of the system works perfectly for every other program I've tried. There definitely isn't a problem recognizing the GPU for anything else, it shows up readily on various monitoring/system info programs like CPU-Z, HWMonitor, hwinfo64, etc. and performance in benchmarks is exactly in line with what I'd expect from an overclocked 1080 Ti with 375W power delivery. I never even suspected there might be a problem until I went into the preset settings menu. So, is this normal? I'd normally assume it's normal, since how can a 1080 Ti not be supported hardware, but when rendering with mercury (CUDA) I'm not seeing very much GPU usage relative to idle.

I have one other question too. This is the wrong forum for it, but since it's a secondary question I'm going to ask anyway. In after effects, I am unable to use ray-traced rendering. It doesn't give me an error message or anything, it just makes all 3D object layers become invisible, as if opacity were set to 0%. If I untick the 3D layer checkbox, the layer becomes visible again. If I switch to C4D renderer, the layer becomes visible again. Yes, I've made sure there are light sources. I researched this topic but couldn't find any mention of it after ~2014. People said at the time that adobe was phasing ray tracing out (why??? it's only just becoming viable) so nvidia stopped installing specific modules which support it on their chips. There was also the suggestion to enable unsupported GPU acceleration in AE preferences, which did nothing, or to add your GPU to some whitelist .ini or txt file, but no instructions on where to find it. I'm pretty skeptical that adobe products even use hardware whitelists, let alone through text files. So, is ray-traced rendering just not a thing in AE anymore? Or am I doing something wrong?

Views

507

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation