Encoder gamma (color/contrast shift?) ...one more time with feeling!

New Here ,
Dec 30, 2016 Dec 30, 2016

Copy link to clipboard

Copied

Issue.JPG

Screenshot speaks for himself!

Just simply adding from AE to ME. Its' darker ...or more contrast ...or gamma shifting...

Tried everything:

- nvidia DR 0-255 / 16-235

- software / Mercure CUDA engine

- in AE working space is "none"

- in ME any codec, any settings

Adobe Media Encoder just makes a different look to the image!

Any suggestions?

But don't tell me that h264 changes colors... and some player issues... CAUSE IT'S OBVIOUSLY NOT THE CASE!

ME renders that way! His own different way))

Views

674

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 22, 2017 Feb 22, 2017

Copy link to clipboard

Copied

We have been doing a lot of testing regarding this because its terrible. Our exports look flat and lifeless. Turns out, its definitely an adobe problem although they like to blame quicktime.

Open your exported mp4 in a player like VLC. It looks fine.

I'm not sure exactly how its happening but the files that media encoder creates, either send information to quicktime to gamma shift or, more likely, don't have information that other H264 files created by other encoders have which tell quicktime the correct gamma.

Seeing that this has been a problem for years now and adobe doesn't see the need to address it, is disheartening to say the least.

It renders media encoder useless for rendering H264. We export ProRes and then use MPEG Streamclip, an application that hasn't been updated in years, to output our H264 files.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 22, 2017 Feb 22, 2017

Copy link to clipboard

Copied

Ok)

Well, first of all, I don't care about QT. No fruits in my house, just windows)

And I actually found out the reason for this particular case of mine - contrasty looks. But I wanted at least someone to reply something first))

My problem lies here:

Project settings -> Color settings -> Working space

I was never used any working space in my projects. Never. But one day YouTube enabled support for HDR videos. So I've read the official requirements for the videos to be recognisable as HDR by YouTube service. Something about color space... REC.2020 for example. And here where I've messed my project:

1. I've changed project Working Space from NONE to REC.2020 and before inactive "Compensate for Scene-reffered Profiles" option became active and checked.

2. I've played around with new REC.2020 project state, but decided to revert to default NONE. So I went back to that menu, changed project Working Space from REC.2020 to NONE and active "Compensate for Scene-reffered Profiles" option became inactive and but still checked.
And after that I've began to get in AME that contrasty looks in this particular project.

But my thinking was - it is something about Working Space menu, but I've reverted everything like it was before and "Compensate for Scene-reffered Profiles" is greyed out and it doesn't matter if it checked or not!! ...I was wrong )))

Yes, it's greyed out BUT IT IS CHECKED!

3. For some stupid "what da hell" I went once again to project settings and changed Working Space from NONE to REC.2020, "Compensate for Scene-reffered Profiles" became active, I UNCHECKED it and set Working Space to NONE again.

AME started to render exact same looks like I see it in AE.

and here's the tricky part. After that victory, I decided to make the same "uncheck operation" in my other project where I DIDN'T touch Working Space option ever before. So "Compensate for Scene-reffered Profiles" option was greyed out and checked. I've made it active and unchecked it ...and I received just the opposite effect in AME. When before it rendered proper image, after "uncheck operation" it began to render contrasty )))

So, if shorter))

If I make any changes in Working Space option then "Compensate for Scene-reffered Profiles" option should be unchecked even if it greyed out (inactive).

So stupid and unscientific ))) and probably not strictly true method, but for my AE it works!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines