Exporting H.264

New Here ,
Dec 14, 2016 Dec 14, 2016

Copy link to clipboard

Copied

hey,

I have a short clip on AE 2017 (around 7 sec) and in 1920x1080 resolution. Simple slide in and fade animations.
I used to export all my animations from AME because usually it made small file sizes and so on.
But suddenly it got very bad. AME estimates my file size to 3M and when its done - its over 130M.
ONLY thing what kept the file size down was changing the Metadata info (no metadata at all) - then the estimation and the actual result matched.
But this also messed up the quality of the result.

What the heck happened?

Thanks.

Views

465

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Community Beginner , Dec 15, 2016 Dec 15, 2016
I have a solution for this. It's a super lame default setting in the 2017 version of Premiere (from what I can tell)In short; check you metadata when exporting, especially if you have any photoshop files in your original sequence. Make sure the "create sidecar file" is changed to "none" in the metadata export options.Long story; We would go to export a :30 second spot to MP4 with the android 960x540 settings, it estimated the file size to be around 8MB which is usual. I noticed it would export t...

Likes

translate

Translate

Translate
Most Valuable Participant ,
Dec 14, 2016 Dec 14, 2016

Copy link to clipboard

Copied

Please post screen shot of Export Settings panel for review of encoding settings.

Thanks

Jeff

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 14, 2016 Dec 14, 2016

Copy link to clipboard

Copied

If I render with these settings (even with half of the resolution) it makes the file size around 120M.
I kept my eye on the process and it keeps the file size around 7-8M till the very end. Basically, the rendering is done, remaining time is 0, last frame is rendered, but AME keeps calculating something and as soon as it's done - file size is 120M.

AMEerror.jpg

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Dec 14, 2016 Dec 14, 2016

Copy link to clipboard

Copied

I do see estimated file size listed at 8mb and I don't see any issue with encoding settings, so your results are strange. Please try this - rather than encoding to H.264 direct from After Effects project, try encoding to an intermediate codec, such as Cineform (.mov) or DNxHD (.mxf) then make the H.264 file from that file.

Thanks

Jeff

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 14, 2016 Dec 14, 2016

Copy link to clipboard

Copied

It is weird and it happened basically over night. I didn't change settings. I can't remember if there was a AME update before that or not. Funny thing is that exporting from Premiere the h.264 codec works fine. And file size is also normal.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 14, 2016 Dec 14, 2016

Copy link to clipboard

Copied

Can't it be connected to XMP metadata settings somehow? Because before the Export Settings open up, it reads a quite long (up to 10 sec) time the XMP info. Usually it didn't take so much time.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 15, 2016 Dec 15, 2016

Copy link to clipboard

Copied

I have a solution for this. It's a super lame default setting in the 2017 version of Premiere (from what I can tell)

In short; check you metadata when exporting, especially if you have any photoshop files in your original sequence. Make sure the "create sidecar file" is changed to "none" in the metadata export options.

Long story; We would go to export a :30 second spot to MP4 with the android 960x540 settings, it estimated the file size to be around 8MB which is usual. I noticed it would export to about 99% and hang for a second and then complete. If you were to watch the actual file being written in finder, you would notice the size would jump from 8MB to about 60MB all of the sudden.

So what we started to do was take out elements from the sequence and re-export to see if we could isolate the problem. The last thing we took out was any and all graphics, including Photoshop files and suddenly the file size was 8MB like we had intended. Put the PS file back in the sequence, it would be 60MB again.

So we figured it was writing some sort of metadata with the photoshop files because even after exporting a ProRes Quicktime and then taking that file and converting to the Android 960x540 MP4, it was still 60MB. So it was keeping the photoshop information (or something) in the metadata and passing it along, even after compressing it to an entirely different format.

Anyways, we went into Metadata in the export settings and saw that "create sidecar file" was selected on under "Export Options". Changed that shiz to "none" and suddenly we got our 8MB file.

ADOBE: PLEASE MAKE "NONE" THE DEFAULT EXPORT OPTION FOR METADATA EXPORT

This should be an opt-in feature. We either make sure our exports have the sidecar file turned off or have recreated our previous presets we made. At any rate, it's not very efficient.

Thanks, man. Hope this helps because we were tearing out our hair.

Here's where those options are:

Export like usual, make your export settings or select a preset. Then click on "Meta Data" at the bottom, near "Cancel" and "OK"

Screen Shot 2016-12-15 at 4.22.04 PM.png

Click on the "Export Options" drop down at the top of the window and select "None" and hit "OK".

Screen Shot 2016-12-15 at 4.22.23 PM.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 16, 2016 Dec 16, 2016

Copy link to clipboard

Copied

Thanks.
Yes, thats the way it should work.
I checked it and it works. I even tested it like that in the beginning because it seemed logical. But my mp4 result was in very bad quality when I tested it. I think I messed some setting up while rendering it without Metadata.
But now.. it's  as it should be.

So, thanks again.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines