How do I install the DNxHD and Cineform codecs? (Missing from AME 6 )

Community Beginner ,
Jun 08, 2012 Jun 08, 2012

Copy link to clipboard

Copied

I have downloaded the free versions of both of these codecs in the hopes of being able to transcode to each as an intermediate codec for my AVCHD files. The problem is that neither shows up in either my Premiere Pro CS6 or Adobe Media Encoder Import/Export options? What gives? Did I miss something here? How do I get the option to transcode or encode to DnxHD or Cineform on a PC version of CS6?

TOPICS
Download and install, Formats

Views

119.9K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Community Beginner , Jun 24, 2014 Jun 24, 2014
Problem solved.After another night of googling and experimenting I managed to figure out what the problem was. So finally AViD DNxHD codec for QT works like a charm on my machine.Turns out the problem was with Avid's codecs installers (tried LE 2.3.7, 2.3.8, 2.3.9, as well as PE 2.3.7). They install the actual codec files (extension *.qtx) to the wrong directory: "C:\Program Files (x86)\QuickTime\QTComponents\"The correct location however is: "C:\Program Files (x86)\QuickTime\QTSystem\"Therefore...

Likes

Translate

Translate
Adobe Community Professional ,
Jun 08, 2012 Jun 08, 2012

Copy link to clipboard

Copied

Does this help?

ChooseDNxHD.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 08, 2012 Jun 08, 2012

Copy link to clipboard

Copied

CS6 doesn't install Quicktime  by default on Windows, you'll need to install it separately for it show up as an export format.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 11, 2012 Jun 11, 2012

Copy link to clipboard

Copied

Have a similar problem. My pc cant even read the file. Can someone point me to which codec I could use. I have installed Quicktime pro on my PC, but I still cant read the file, and  dont have the option to export to DNxHD. Im on CS6.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 11, 2012 Jun 11, 2012

Copy link to clipboard

Copied

Welcome to the forum.

You have to install the Avid codecs separately.  Go here:

Avid Codecs 2.3.7 Download

Jeff

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 15, 2013 May 15, 2013

Copy link to clipboard

Copied

Hi

i have installed the avid dnxhd codec separately (official avid site - AvidCodecsLESetup.exe) . Premiere pro 6 can now import dnxhd-videos - but premiere 6 can not export in quicktime format - regardless the format or codec. There is an error "can not create a target movie" - in german "Fehler beim Erstellen des Films. Es kann keine Ausgabedatei erstellt oder geöffnet werden. "

If i remove the dnxhd codec i am able to export in quicktime.

Do you have any suggestions?

THX, Oliver

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 15, 2013 May 15, 2013

Copy link to clipboard

Copied

Have you loaded any other codecs on the system? There might be conflict. What OS are you running?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 15, 2013 May 15, 2013

Copy link to clipboard

Copied

Hi,  - no other external codec. I am running the master collection on Windows 7 64bit.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 15, 2013 May 15, 2013

Copy link to clipboard

Copied

Try uninstalling DNxHD and QuickTime, then install a down-rev version of QT based on Adobe system specifications:

CS6/CC - QT 7.6.6 for Windows (I use 7.6.9)

CS5.5 - QT 7.6.2

CS5 - QT 7.6.2

CS4 - QT 7.4.5

Restart your computer after re-installing QuickTime and DNxHD, and see if it works.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 16, 2013 May 16, 2013

Copy link to clipboard

Copied

Hi

thank you for this great advice. Works perfect !!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 16, 2013 May 16, 2013

Copy link to clipboard

Copied

Happy to help, and glad it worked out.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 25, 2013 Sep 25, 2013

Copy link to clipboard

Copied

I wasn't sure which older version I needed to install.

I'm running Windows 7 64-bit and newest version of QT and Adobe CC.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 09, 2015 Jul 09, 2015

Copy link to clipboard

Copied

Cheers

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 13, 2013 Apr 13, 2013

Copy link to clipboard

Copied

I am having the same problem on Mac OS X 10.7 (Lion). I verified and the codecs are isntalled in the quicktime folder. I also rebooted the computer after installing the codecs. I want to use Adobe Media Encoder to transcode avchd files to Avid DNXHD.  I have transcoded to ProRes sucessfuly but don't see the option for Avid DNXHD.. Is this possible on the Mac or do I have to wait for the next version of Adobe Premiere Pro and Media Encoder?.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 13, 2013 Apr 13, 2013

Copy link to clipboard

Copied

Never mind... I checked again and noticed I have the same Avid codecs I had before on CS5.5... No presets, just the codecs to create a custom preset. I guess I have to wait for the new version they showed at NAB to get a list of Avid presets like we do now with Apple ProRes.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 07, 2013 May 07, 2013

Copy link to clipboard

Copied

I'm having this exact same issue. I've installed 2.3.7 and the new 2.3.8. Selecting "Quicktime", no DNxHD presets show up in Media Encoder.

media encoder no dnxhd.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 07, 2013 May 07, 2013

Copy link to clipboard

Copied

Look under the Video Codec setting further down (where you currently have H.264 selected). The codec names start with "AVID".

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 07, 2013 May 07, 2013

Copy link to clipboard

Copied

It's not there either.

codec.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 07, 2013 May 07, 2013

Copy link to clipboard

Copied

After downloading the codec pack, did you run the executable installation program? After running the program, did you restart the computer?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 07, 2013 May 07, 2013

Copy link to clipboard

Copied

Yes and yes.

control panel.jpg

I tried to see if maybe the codec showed up in MPET StreamClip, but I don't see it there either.

streamclip.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 07, 2013 May 07, 2013

Copy link to clipboard

Copied

Well, I uninstalled the codecs, reinstalled, restarted, and now they show up under Video Codec. :face palm: So... there you go.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 23, 2014 Jun 23, 2014

Copy link to clipboard

Copied

still doesn't work for me

tried:

  • AME CC 2014 + QT 7.7.5 + DNxHD 2.3.9
  • AME CC 2014 + QT 7.7.5 + DNxHD 2.3.8
  • AME CC 2014 + QT 7.7.5 + DNxHD 2.3.7
  • AME CC 2014 + QT 7.6.9 + DNxHD 2.3.7
  • AME CC 2014 + QT 7.6.9 + DNxHD 2.3.9

I just can't get it to work. Sick of all the reboots. So far I was only able to make a DNxHD MOV with FFMPEG and I was able to play it perfectly with MPC-HC. However QT Player fails to render the video even though it detects the right resolution and can decode audio from the file. It seems to be a QT issue but I've no more clues what else to try out. Apparently I can't encode to DNxHD with AME as the "AVID DNxHD" option is missing in the Video Codec list. I'll try to downgrade QT further to 7.6.6 tomorrow as suggested by the requirements and see if it helps. But if this fails too, I don't know where else to search for the solution.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 24, 2014 Jun 24, 2014

Copy link to clipboard

Copied

Problem solved.

After another night of googling and experimenting I managed to figure out what the problem was. So finally AViD DNxHD codec for QT works like a charm on my machine.

Turns out the problem was with Avid's codecs installers (tried LE 2.3.7, 2.3.8, 2.3.9, as well as PE 2.3.7). They install the actual codec files (extension *.qtx) to the wrong directory:

"C:\Program Files (x86)\QuickTime\QTComponents\"

The correct location however is:

"C:\Program Files (x86)\QuickTime\QTSystem\"

Therefore, one has to copy/move the avid's *.qtx files to this folder manually and you'll be able to play/import your DNxHD media in MOV containers as well as compress videos into DNxHD via QT in AME, PP, or any other software that can deal with QT.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Mar 10, 2015 Mar 10, 2015

Copy link to clipboard

Copied

The solution by @soulelle above worked for me. I didn't even have to reboot.

Win 7 x 64

Pr Pro CS6

LE 2.3.7

I ran the installer, moved the files from "C:\Program Files (x86)\QuickTime\QTComponents\" to "C:\Program Files (x86)\QuickTime\QTSystem\", launched Premiere, and the Avid codecs were in the list!

Also, so the next persons doesn't have to track down the links, here they are for 2.3.7, 2.3.8, and 2.3.9.

2.3.7

2.3.8

2.3.9

Cheers,

Shane

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Jul 07, 2015 Jul 07, 2015

Copy link to clipboard

Copied

Soulelle,

Thank you so much, and all the other posters in this thread. I dont know what happened, but after the latest CC update of summer 2015, Adobe bridge and all the other applications are not properly displaying my DNxHD files anymore, or simply refusing to work with them. I followed most of the steps given in the various answers here. And at least now Adobe Media Encoder works again with the DNxHD files, although Bridge still displays them wrong as extremely elongated and thin versions of the originals. I am a starter with digital video, and for my first 30 or so clips I used the DNxHD codec for editing and for saving the final master files. And I really liked this codec, good quality for storage and editing speed. But after losing some sidecar files, difficulties with installation, finding information and other issues, I decided to change my master file format to PNG: much saver, simpler, lossless compression and no sidecar files to mess things up or other extreme difficulties like just simply getting this DNxHD codec to work!! So now I am recoding my first 30 masters from DNxHD into PNG-sequences, and for the near future I am going to stay away from this DNxHD codecs, until I really have a more professional level of understanding.

Greetz Sebastiaan.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines