Media Encoder Crashing

New Here ,
Jun 13, 2019 Jun 13, 2019

Copy link to clipboard

Copied

Media Encoder is crashing...it happens about five minutes into the render. It's a new thing and I simply cannot figure out why it is happening.  I have changed none of my editing habits or software.  Everything (apps, drivers, etc.) have been updated.  Here are snapshots of my system and app settings.  Please help!

File Capture.JPGAdobe Version.JPGSystem Info.JPGWindow.JPGDriver Info.2.JPGCrash Report.JPGEncoder Error Log.JPGExport Settings.JPGEncoder Settings.JPGOutput Preview.JPG

Views

4.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 13, 2019 Jun 13, 2019

Copy link to clipboard

Copied

I've had the same issue for approximately 2 months now. But it wouldn't only crash Media Encoder, it will sometimes crash my actual PC.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 13, 2019 Jun 13, 2019

Copy link to clipboard

Copied

Try clearing your Encoder and Premiere preferences in Documents. Possibly reinstall both. Also, if it's a certain project that seems to crash AME, try importing that project into a new one.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 15, 2019 Jun 15, 2019

Copy link to clipboard

Copied

All updates, re-installs and new projects led to the same issues.  Will keep trying...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 14, 2019 Jun 14, 2019

Copy link to clipboard

Copied

Experiencing something similar, made a change, got the render to complete.

Here's the deal: I have two computers, a Windows Desktop and a Macbook Pro and I'm running Adobe Media Encoder on both of them (Windows version on the Windows machine, Mac version on the Macbook, naturally). On both machines AME is crashing pretty early in the render. In both cases it's the same file crashing.

I'm trying to render a 360° video, about 2 minutes in duration at a resolution of 5760 x 2880. I have the file pulled into Premiere Pro, and then queued up to Media Encoder (a couple of effects applied in PP) with a bitrate set 15 and 25 on the H.264 preset in AME.

So all of this is happening with AME version 13.1 Build 173 (Same version number / build on both systems, both updated via their respective Creative Cloud apps).

Let's deal with the Windows Machine First

It's crashed several times so I got a clean boot and ensured that nothing was running except AME and Task Manager (Ctrl + Alt + Delete > Task Manager). As I got the render going in AME I opened up the view in Task Manager to see more details on the Processes tab. There I noticed that AME was running up around 98%, 98.7%, 99%, etc. of the CPU. Then it would crash.

After some research I found that AME appears to be able to, and actually will, ask for ALL THE POWER of the CPU! Well, the motherboard won't be hearing that nonsense, so she shuts it all down. In my case I'm getting the Blue Screen of Death (BSoD) with an error code that reads WHE_UNCORRECTABLE_ERROR.

A Couple of Ways to Deal With This:

  • You should be able to go into your system's BIOS Setting and turn off any Turbo Boost settings - This I was unwilling to do because I don't know which "turbo boost" settings are in my UEFI BIOS to turn off. I have a preset for higher performance turned on, and I don't want to crank that back down to normal because I do want to game on this machine a little (when I'm not rendering video or 3D) and I don't want to mess with the BIOS every time I want some entertainment. However it may be something you want to try.
  • You can go into Windows and Change the Settings for High Performance - This is what I actually did. In Windows 10 go to Control Panel > Hardware and Sound > Power Options > Edit Plan Settings > Change Advanced Power Settings > Processor Power Management >
    • Set your Maximum Processor State down from 100% to 99% or 98%
    • Set your Minimum Processor State down to something lower than your Maximum Processor State. I did 50%, but I think as long as it isn't the same as, or higher than, your maximum, you'll be fine.
  • It's worth noting that before I got to this state I had also updated my Nvidia drivers, applied some pending updates to Windows, etc. The updates themselves didn't prevent the crashing in AME, but they can't hurt.

Then I attempted the render again and it completed with no problem. This is weird because I've been rendering out of AME with no issues until today, and today I updated AME and started having render issues.

<rant>Why the hell does AME do this? Why can't Adobe develop AME to NOT crash my frickin' machine? It's been fine until today, but now its starts crashing this way. I mentioned doing some "research." The "research" that led me down this path is some forum postings from about 2 - 3 years ago, but I figured that those were issues that would since be solved in the software itself. I guess not! I mean what's the point of letting AME request so much power that the chip runs so hot that the MB shuts it all down? At least there should be a way in AME's preferences to say, as you can with the RAM, "Look, AME, you can't request it ALL! You have to leave some of it for other services, so just run up to around 9x%, but not 100%." </rant>

Windows System:

Intel Core i9-7980XE @ 2.6GHz

32 GB RAM

Windows 10 - Version 1903 - OS Build 18362.175

Macbook

Now, for the Macbook Pro, I'm seeing the same behaviour from AME (Also version 13.1 Build 173), also updated today via the little CC updater app that runs on the system). I think it's basically the same issue because the fans on that thing are running like crazy before it crashes. Currently I'm looking for a similar solution in MacOS Mohave 10.14, but haven't found it yet.

It may take me some time, but while I'm looking for it, someone else may see this who knows how to do it, and / or some Windows users may try the Windows version of this fix and get a good result. So why hold up that progress?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 15, 2019 Jun 15, 2019

Copy link to clipboard

Copied

Ok, I got a successful render of that output on the Macbook Pro by changing my Renderer:

  • From - Mercury Playback Engine GPU Acceleration (Metal)
  • To - Mercury Playback Engine GPU Acceleration (OpenCL).

Since the Macbook Pro has the Radeon GPU I figured OpenCL would be the way to go, and that got the render to complete pretty normally.

The Renderer pulldown setting on AME is at the bottom-right corner of the Queue, just above the Encoding panel.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 15, 2019 Jun 15, 2019

Copy link to clipboard

Copied

To:  JB.5549.att

I've made the suggested changes to my Windows system by changing the processor system max and min., then re-started, opened a new project and exported within PP with a successful render.  However, due to time, I have not attempted to render in AME.  I will do this later when I have time.

You are correct that these issues with AME are simply unacceptable.  Adobe really needs to debug all apps before sending out a new version or version update.

Thanks for your help!

UPDATE:

I am not sure if this actually fixed the issue or not, but after making the above changes, exiting and creating a new project file, I have not had any render issues.  I am glad and hope it takes care of the problem I was having until Adobe can provide a software update to debug the challenges between AME and PP.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 21, 2020 Mar 21, 2020

Copy link to clipboard

Copied

LATEST

Thanks for sharing your results. Judging by the other comments, you'll save others a lot of troubleshooting time. I agree that Media Encoder should be stable enough to use as much of the processor that's available without crashing. Another thing you could try is going to Preferences > Memory and adjusting RAM Reserved For Other Applications. From Adobe's website: "Increase this value to leave more RAM available for the operating system and for applications other than After Effects and the application with which it shares a memory pool. If you know that you will be using a specific application along with After Effects, check its system requirements and set this value to at least the minimum amount of RAM required for that application. Because performance is best when adequate memory is left for the operating system, you can’t set this value below a minimum baseline value."

 

As far as switching from Metal to OpenCL, I too feel that OpenCL works a little better on some Apple computers. The problem is more with Apple that they've decided to do their own thing with graphics cards. Apple is going with Metal, and will be discontinuing OpenCL, which makes a lot of us grumpy. Be careful if you ever consider updating your macOS to make sure you'll still have OpenCL. Personally, I'm on Mojave and use OpenCL, also.

 

In Premiere Pro 14.0 and later, the Renderer choice for OpenCL shows "(OpenCL) Deprecated." Generally 'deprecated' means that it's going bye-bye. For example with the removal of Ray-traced 3D renderer in After Effects, Adobe left it in for a year or so with 'deprecated' noted behind it, sort of like a friendly warning to plan appropriately. So in summary, similar to my last paragraph, be careful updating your software, too. Nothing wrong with having multiple versions of the software on your computer. Whatever get the job done and works best for you!

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 20, 2020 Mar 20, 2020

Copy link to clipboard

Copied

OMG, this works! Didnt bother with any Windows/Driver updates (they were probably already up to date tbh) and ba-bam, rendered! Your a scholar and a gentleman for sharing this ❤️

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines