Media Encoder CS6 Not using all CPU Cores or RAM

Participant ,
Jun 18, 2012 Jun 18, 2012

Copy link to clipboard

Copied

I'm currently exporting a 90 second video (using the Vimeo HD 1080p preset), and it is taking about 30 minutes. This is extremely strange as I have an i7-990x OC'ed @4.5, 12GB RAM, SSD, etc.

I looked at Performance tab in Windows Task Manager, and saw 4 threads were not being used at all, only 20-25% of the CPU was in use, and only 6GB out of the 9GB I specified was being used.

Why isn't Media Encoder making full use of my CPU and RAM?

ME.jpg

Views

27.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Participant , Jun 18, 2012 Jun 18, 2012
After playing around with it a bit more, it looks like the problem is with Adobe's new Adjustment Layer in Premiere Pro.Initially, I had an Adjustment Layer sitting across my entire 90 second video with the USM effect in it. This took 30 minutes to render.As a test, I deleted the Adjustment Layer and applied USM to each individual clip in the 90 second sequence. This cut the rendering time in half, and Media Encoder finished the video in just under 15 minutes.

Likes

Translate

Translate
LEGEND ,
Jun 18, 2012 Jun 18, 2012

Copy link to clipboard

Copied

It'll use whatever it needs.  If it didn't use all resources, then it doesn't need them all.  Possibly because of a bottleneck somewhere else, or a third party effect that isn't very well multithreaded, etc.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jun 18, 2012 Jun 18, 2012

Copy link to clipboard

Copied

After playing around with it a bit more, it looks like the problem is with Adobe's new Adjustment Layer in Premiere Pro.

Initially, I had an Adjustment Layer sitting across my entire 90 second video with the USM effect in it. This took 30 minutes to render.

As a test, I deleted the Adjustment Layer and applied USM to each individual clip in the 90 second sequence. This cut the rendering time in half, and Media Encoder finished the video in just under 15 minutes.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jun 20, 2012 Jun 20, 2012

Copy link to clipboard

Copied

However, in terms of the resources, I've done additional rendering tests on video without any effects, just raw footage clips together in a sequence, and Media Encoder still doesn't use all available RAM, or all cores/threads, to do the encoding.

As with the other threads with CS6 problems, it sure would be nice to hear from Adobe on this.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 21, 2012 Jun 21, 2012

Copy link to clipboard

Copied

USM effect

What's that?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jun 21, 2012 Jun 21, 2012

Copy link to clipboard

Copied

Unsharpen Mask.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 06, 2012 Oct 06, 2012

Copy link to clipboard

Copied

I'm having the same problem. But even worst.

For the test, I take a 10 min .mov or mp4 file, simply modify the "scale", and hit the export.

a 10 min file is taking 4 hours to render.

This is on a:

2012 MacBookPro i7 2.3Ghz, 16 GB 1600 DDR3, SSD disk. - Mac OSX 10.7.5

and a:

2011 iMac i7 3.7Ghz, 16 GB 1333 Mhz, 7200 RPM HD - Mac OSX 10.7.5

The CPU stays at 90% idle the whole time.

I know this is an old thread, but maybe someone could give me a hand.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 15, 2015 May 15, 2015

Copy link to clipboard

Copied

This is an old thread, but just in case you never found your answer...

Scaling is handled best by the GPU as it's a really intense task. So upping your core usage won't really impact it much, the best way to deal with it is by having a great GPU with the Mercury engine enabled.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Oct 10, 2012 Oct 10, 2012

Copy link to clipboard

Copied

have a look at this post I make a week or so ago on what it takes to max out the cpus and even if that is a good thing...

http://forums.adobe.com/message/4688869#4688869

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 13, 2012 Oct 13, 2012

Copy link to clipboard

Copied

Thanks for the info

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Aug 16, 2015 Aug 16, 2015

Copy link to clipboard

Copied

I have like all of you searched the web for ways to increase performance in Adobe Premiere or Media Encoder

The only thing i have found to increase CPU usage is to change the programs Affinity in windows task manager.

(This only works if you have multiple CPU cores, in my case i have 8)

Ctrl + Alt +Del   and open Task Manager

Go to the Processes Tab and sort by CPU the highest should be System Idle and in my case PProHeadless.exe which is Adobe media encoder

Now right click on your render program in this window, in my case PProHeadless.exe and select "Set Affinity" then de-select the first 2 cores, and i used to have between 15-25% CPU usage, and now i have 20-35% not a big increase but its something.

(System Idle Process is just the CPU usage available and not being used on your machine, this isnt some random intensive OS program)


I use this trick for rendering in Maya in the background, or for better game performance, since as i understand your computer loads up your first cores with OS and low level tasks so the other cores are practically unused and wont be slowed down by other background programs since your PC will assign them to the first available cores. To make you all feel better a 6min video im making is going to take 41 hours to encode and took 12 hours to render entire work area... Ulta High res video with effects is something i will forever more avoid.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 02, 2015 Sep 02, 2015

Copy link to clipboard

Copied

LATEST

‌disabling cores doesn't speed up you renders. You only see an increase in overall usage because you disabled two out of whatever amount if cores you have. If you disable 2 more you'll see an increase of usage because you are using less cores. This is not a trick It's counter productive.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines