MP4 only GREEN SCREEN - Codec H.264 (I think)

New Here ,
Nov 23, 2020 Nov 23, 2020

Copy link to clipboard

Copied

Hello!

I tried everything to fix this problem but it still contains.

 

When opening a MP4 video file (2 kinds of videos: recorded by smartphone and recorded from screen (streaming)) and encode it, I always have a green screen and can only hear the sound from the video. The same problem happens in After Effects. MP4 files can't be edited because I only habe a green picture - sound works fine.

 

All codecs are installed (I think - I'm not an expert on this field). The files can be opened in all my media players (Media Player Classic, VLC Media Player, Windows Media Player) and are working fine. Just in After Effects and Media Encoder I have this green screen error. I get no error messages or something like that. I think the program itself thinks, that everything is OK.

 

I searched every possible way I know for a solution, but nothing is completely similar to my problem. The problem solving tipps from other boards or websites didn't work too.

 

I'm using Win10 and have After Effects CS6.

 

Greetings from Austria! 🙂

 

Mike

TOPICS
Error or problem, Export or render, Formats

Views

367

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Nov 24, 2020 Nov 24, 2020
Please use the free MediaInfo and post a screenshot the properties of your media in tree view:https://mediaarea.net/en/MediaInfoMany users are having issues with VFR. If the file is variable frame rate, use Hand brake to convert to constant frame rate:https://handbrake.fr/downloads.phpHere is a tutorial:https://www.youtube.com/watch?time_continue=34&v=xlvxgVREX-Y

Likes

translate

Translate

Translate
New Here ,
Nov 24, 2020 Nov 24, 2020

Copy link to clipboard

Copied

Here are 2 screenshots from the problem. After Effects & Media Encoder:

1.jpg2.jpg

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 24, 2020 Nov 24, 2020

Copy link to clipboard

Copied

Please use the free MediaInfo and post a screenshot the properties of your media in tree view:
https://mediaarea.net/en/MediaInfo

Many users are having issues with VFR. If the file is variable frame rate, use Hand brake to convert to constant frame rate:
https://handbrake.fr/downloads.php
Here is a tutorial:
https://www.youtube.com/watch?time_continue=34&v=xlvxgVREX-Y

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 26, 2020 Nov 26, 2020

Copy link to clipboard

Copied

Thank you, Peru Bob! With the help of "Hand Brake" a qualityloss free encoding was possible and now my videos are working in After Effects! 🙂 Thank you very much!

 

Greetings from Austria! 🙂

 

Mike

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 26, 2020 Nov 26, 2020

Copy link to clipboard

Copied

You're welcome. icon_biggrin.gif

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines