No Audio From Source

New Here ,
Jul 17, 2012 Jul 17, 2012

Copy link to clipboard

Copied

Hi guys,

I'm trying to convert .mts files to .f4v or some other working format in AME but AME shows that there is No Audio in the source as below.

noaudio.jpg

When I click the encode button, true enough, the output file doesn't have any audio in them.

I'm 100% sure my .mts files have audio in them, I can hear them pretty loudly when played in VLC.

Any idea why and how to resolve this? Thank you.

Views

30.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 17, 2012 Jul 17, 2012

Copy link to clipboard

Copied

Hmmm, the file header might be corrupted.

Might also be Metadata. Try the following:

   - Edit menu -> Preferences... -> Metadata

    - Uncheck "Write XMP ID to Files on Import"

    - Source Metadata -> Preservation Rules: Exclude All

Let us know if it works.

Also, do you know what encoded this file?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 17, 2012 Jul 17, 2012

Copy link to clipboard

Copied

Hey Dima,

Thanks for the reply but it didn't work. I have no idea what encoded this file, it might be a direct recording from the the camera itself.

I got it off from a client who has these raw footages in .mts and wanted to import them into AE CS6. I know there are some issues with .mts audio in AE CS6, I ran into them, so I was hoping to batch convert these .mts into something workable.

Thank you for the idea. Will it help if i upload the file for you to try out? Any other solutions?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 17, 2012 Jul 17, 2012

Copy link to clipboard

Copied

Could you also tell me which Adobe CS6 applications are installed?  I was wondering if the file contains the Dolby audio.  AME needs Premiere Pro CS6 to be installed to process Dolby.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 16, 2013 Nov 16, 2013

Copy link to clipboard

Copied

No Audio From Source


I'm a newby,  I'm having the same problem. I have a clip from a Sony AX2000E. The sound is there when I play the original .MTS file with different media players, even Premiere CC plays the sound, and I get no sound when I want to encode it with Media Encoder CC or CS6.

Then I converted the original file through  ProCoder 3 to H264 and then put it back to Media Encoder CC and the sound worked fine. What could be the problem?

I presume it is from the AC-3 audio codec... media encoder has some problems with recognizing it, but I am not sure

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 03, 2018 Dec 03, 2018

Copy link to clipboard

Copied

Solution: VLC

I have the answer to you problem: transform the MTS file into an MP4 file (or a readable high quality format for Adobe programs) with VLC following this process: https://www.guidingtech.com/8848/use-vlc-player-to-convert-videos-from-one-format-to-anoth er/

Important:

Also, once you've added the files you want to convert, and clicked the "Save/Convert" button I suggest you to change the settings of the "Audio codec" shown in the "edit selected profile" button

Change the Audio codec to the "MPEG 4 Audio (AAC)" format, so that the audio could be compatible with any Adobe video app.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 03, 2018 Dec 03, 2018

Copy link to clipboard

Copied

LATEST

Solution: VLC

I have the answer to you problem: transform the MTS file into an MP4 file (or a readable high quality format for Adobe programs) with VLC following this process: https://www.guidingtech.com/8848/use-vlc-player-to-convert-videos-from-one-format-to-anoth er/

Important:

Also, once you've added the files you want to convert, and clicked the "Save/Convert" button I suggest you to change the settings of the "Audio codec" shown in the "edit selected profile" button

Change the Audio codec to the "MPEG 4 Audio (AAC)" format, so that the audio could be compatible with any Adobe video app.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 27, 2012 Aug 27, 2012

Copy link to clipboard

Copied

I am having a similar problem.  If I export a timeline fom premiere pro using media encoder the output file has audio.  If I feed the same clip I used in premiere directly into media encoder it has no audio.

I've tried every setting I can and have disabled the metadata output but nothing works.  I believe media encoder is failing to conform the audio.  Does anyone have any suggestions?  I cannot believe that there's not a solution for this yet!  Common adobe fix this!!!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 28, 2012 Aug 28, 2012

Copy link to clipboard

Copied

Lockwood,

Exactly what type of clip is it? Is it muxed or demuxed? Please provide a test clip and specify your exact export settings so that we can try to reproduce the issue.

Also, let me note that in your lament that we haven't fixed "this" yet, you're making two assumptions that are far from substantiated:

  1. that you and Lonefencer are encountering exactly the same issue.
  2. that the cause of the issue is a bug in AME (or another Adobe app).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 28, 2012 Aug 28, 2012

Copy link to clipboard

Copied

Hi Mark,

This footage was shot using a Sony NX5.  It is AVCHD muxed .MTS.  It's faily large, over 300MB, but theres a link to it here: www.orderlockwood.com/AMEaudio.zip.

I've been doing further testing and I'm having a hard time replicating this problem.  I've tried recording clips in the camera and encoding them, and they all seem to work.  It appears that there is something peculiar with this batch of files, which were all shot on one SD card.  Footage from the second day of shooting is all fine.

All of the clips in question will not export audio from AME CS6 on both of my computers.  They will export audio through Premiere Pro, and through AME CS5 on a third computer.  I do not recall if the audio format for this clip was Dolby or LPCM, but I wonder if that could play a part.

What could cause something like this?  A bad SD card?  A setting on the camera?  Can you elaborate as to why it would work when exported from Premiere and AME CS5 but not CS6?  Thanks for your help!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 28, 2012 Aug 28, 2012

Copy link to clipboard

Copied

When I import the clip you posted directly into AME 6.0.0 (as well as a more recent build), the Export  Setting dialog shows that it has audio--as you can see in the screenshot below--and the resulting output clip also has audio.

Untitled-1.jpg

What format & preset are you encoding to?

By the way, according to MediaInfo, the audio format in the source clip is AC-3, constant bitrate of 256 Kbps, 48KHz stereo, 16 bit

I can't begin to speculate on why you're having this problem with a particular set of clips, particularly given that you have no such issue with the same content in CS5 and I have no issue in CS6. The closest thing I have to a hypothesis is that in CS6 you inadvertently encoded to a demuxed format/preset and then opened only the video component of the resulting output--but that's obviously wild speculation and not meant to impugn your video chops in any way.

Again, what app or player are you using to check whether the audio is present?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 28, 2012 Aug 28, 2012

Copy link to clipboard

Copied

Hmm that's odd.  Now I'm really baffled.  On my machine it the audio track is there but it is totally silent, no waveform or level.

I have confirmed the output clip has no sound by playing the output file in windows media player, VLC and importing the clip into premiere pro.  I am using the ipad2 1080p preset.  I can guarantee you that I did not accidentally demux and export audio was selected. 

I have also tried outputting wave audio and I get the same thing.  It creates the file, but there is no waveform or level, just silence.

Have you imported the clip into Premiere Pro and listened to it?  Can you hear sound?

Here's a link to the file AME outputs for me: www.orderlockwood.com/AMEnoaudio.zip  If you download it you will see that it has an audio track attached with no waveform or levels, it's totally silent.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 28, 2012 Aug 28, 2012

Copy link to clipboard

Copied

I also sent your source clip to AME (CS5.5) and encoded using the Apple iPad 640x360 29.97 preset.  The encoded output file has audio in Pr, VLC and WMP.

I'll check your output file soon.

Jeff

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 28, 2012 Aug 28, 2012

Copy link to clipboard

Copied

Your output file is as you described.  I have no idea how you got it into that state.  The most likely culprit is an audio or video codec that is interfering with the AME.  It's also possible you have audio drivers or Operating System settings that are interfering at some level.

Do you have any codec packs installed?

Jeff

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 28, 2012 Aug 28, 2012

Copy link to clipboard

Copied

Hi Jeff,

I do not have any codec packs installed.  I even uninstalled all Adobe products on my computer, ran the Adobe cleaner tool, and re-installed Premiere while testing this issue.

My guess is that it will work for you in CS5.5, I know it works in CS5.

What has me stuck is that other clips from my NX5 with the same settings work just fine.  If it was a CODEC issue or audio drivers wouldn't one expect that it should never work?  I can do the exact same thing with a different clip and get sound.....

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 28, 2012 Aug 28, 2012

Copy link to clipboard

Copied

I too wondered about a codec pack being the fly in this ointment, but the developer whom I've been consulting says that's not at all likely.

Given that other content off the same camera has no such problem, we suspect that there's some subtle difference in that particular batch of clips. We say "subtle" because AME CS5 and PPRO CS6 are able to handle these clips without issue.

Of course, undermining our it's-the-source hypothesis is the fact that using your original source clip, I can't repro in CS6.0 or CS6.0.1, which points to something system-specific or install-specific..

One curious data point is that MediaInfo says that your silent output's audio is CBR whereas my output w/ audio is VBR. That's may well be a red herring--maybe the glitch is preventing MediaInfo from knowing whether it's constant or variable, so it guesses constant.

Can you make do by either importing this batch of funky files into PPRO and then exporting from there, or falling back to CS5 for these clips?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 28, 2012 Aug 28, 2012

Copy link to clipboard

Copied

Hi Lockwood,

You might be right about conforming.

You could have corrupt conformed audio files preventing conforming again.

Please try to encode again after deleting the following folder: "%AppData%\Adobe\Common"

Make sure to backup your custom presets if you value any of them.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 29, 2012 Aug 29, 2012

Copy link to clipboard

Copied

Hi Dima,

Thanks for your input.  I've tried deleting the common files but it makes no difference.

I can move on since I know this isn't happening on other machines, but I'm happy to try anything else to try to fix this... I'm baffled by this.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 29, 2012 Aug 29, 2012

Copy link to clipboard

Copied

I have confirmed that this issue deffinately relates to conforming.

I looked into the folders containing the source clips that have been working in AME and they have a .cfa and .pek file.  The source clips that have not been working do not have either file.

I have copied the "bad" clips into a new folder, renamed them, and ran them through again.  The source clips have the .cfa and .pek files, and the audio is working fine.

Could it be that the database for conformed audio is messed up?  Can anyone shed some light onto this?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 29, 2012 Aug 29, 2012

Copy link to clipboard

Copied

Glad to hear that worked!

It's possible that it's because of the database but we don't know how it got in that state.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 28, 2012 Aug 28, 2012

Copy link to clipboard

Copied

I duplicated the test using AME CS6.  AME CS6 produces an output file with audio, just like CS5.5.  I used the iPad 2 preset.  The encoded file from AME has audio in VLC, WMP and Premiere Pro CS6.  So it's not the source file that's the problem.  FWIW I also shoot with an NX5 and I've never run into this issue.

Jeff

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 28, 2012 Aug 28, 2012

Copy link to clipboard

Copied

Thanks Jeff!  This confirms it's something with my system that is causing the issue.  I'm going to try Dima's suggestion and see what happens.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 31, 2012 Aug 31, 2012

Copy link to clipboard

Copied

Hi all,

It is not worked also to me on OS X 10.8.1. I see into Activity Monitor that AME, while encoding, uses QuickTime resources. QT now also has sound problem (VLC does not). Might be it is because QuickTime.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 31, 2012 Aug 31, 2012

Copy link to clipboard

Copied

I'm a newby, but I think I'm having the same problem. I have a clip from a Sony RX100. The sound is there when I play the original .MTS file, but I've tried several different settings, and I get no sound when rendered by Adobe Media Encoder. CS6.01, OS10.7.4.

Is this a bug, or an unsupported feature?Clip-NoAudio.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 02, 2012 Sep 02, 2012

Copy link to clipboard

Copied

Hi,

Have had this exact same problem for a few months.
I've tried everything to solve it, but none of them worked.

I do have audio now, how?
well.. it isn't the easiest way, by totally restore your pc/laptop to the factory settings.
1. Copy documents, videos, music, and more important files to an external hhd (or make a windows.old file)
2. Restore and set to factory settings (http://www.youtube.com/watch?v=rcQYC948AzA)
3. Install your windows version again
4. Install master collection again

Voila

Takes a couple of hours to do this but... it's worth it.
Your PC performance will increase drastically as well

Not the easiest way, I know

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines