No Audio From Source

New Here ,
Jul 17, 2012 Jul 17, 2012

Copy link to clipboard

Copied

Hi guys,

I'm trying to convert .mts files to .f4v or some other working format in AME but AME shows that there is No Audio in the source as below.

noaudio.jpg

When I click the encode button, true enough, the output file doesn't have any audio in them.

I'm 100% sure my .mts files have audio in them, I can hear them pretty loudly when played in VLC.

Any idea why and how to resolve this? Thank you.

Views

30.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 02, 2012 Sep 02, 2012

Copy link to clipboard

Copied

Please don't post multiple times -- I deleted your duplicate posts.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 14, 2012 Sep 14, 2012

Copy link to clipboard

Copied

I had the same issue when encoding m2ts files (using Media Encoder CS6). But the issue got RESOLVED after installing the latest trial version of "Adobe Premier Pro".  Now AME works fine and there is no missing audio issue. Looks like "Adobe Premier Pro" updated/installed some system files required for "Media Encoder". The nice thing is that even after uninstalling the "Premier Pro" trial version, AME still works.

Try it and see if it reolves your issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 14, 2012 Sep 14, 2012

Copy link to clipboard

Copied

We fixed several Audio related issues in AME 6.0.2 patch that was released last week. Here is a list of some of the fixes:

- TS muxer outputs m4v file if audio isn't exported.

- Can't encode specific m2t source to other format

- Cannot create a custom multichannel audio export preset

- AME encodes N-channel audio into mono, stereo and 5.1ch differently than PPro

- Encoding N channel audio source to some formats fails due to incompatible audio channels

These are just some of the audio related fixes in AME 6.0.2 patch. This patch has dozens of other bug fixes

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 15, 2012 Sep 15, 2012

Copy link to clipboard

Copied

I can confirm that the latest AME version 6.0.2.81 did NOT RESOLVED the missing audio issue in my case (for m2ts file types).  I updated to the latest version and were having the same issue. 

But after installing the trial version of Premier Pro CS6, the issue got resolved.  So, it is very clear that AME installation was missing some important files, not sure which ones!!! Adobe developers are not able to reproduce the issue just because they may be having AME and Premier Pro on the same machine. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 14, 2012 Sep 14, 2012

Copy link to clipboard

Copied

The problem was resolved after installing A52Codec.component

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 15, 2012 Sep 15, 2012

Copy link to clipboard

Copied

Hi Kletsel,

Looks like A52Codec.component link in your post is for Mac. Can you post the linkk for Windows OS? Thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 15, 2012 Sep 15, 2012

Copy link to clipboard

Copied

It is indeed a QuickTime component for Mac. Unfortunately, I do not know a solution for Windows environment.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 04, 2012 Oct 04, 2012

Copy link to clipboard

Copied

Having the same problem, been trying to convert mts. files into some type of H.246 File and after encoding had finished I viewed it and the video looked great but no audio....

Adobe needs to fix this problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 30, 2012 Oct 30, 2012

Copy link to clipboard

Copied

I have this problem with most any file I try to encode into a .flv or .mp4 - NO AUDIO!

Stop blaming all the users and their machines and fix your software.

LOL the media encoder that can't ecode anything.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 13, 2012 Nov 13, 2012

Copy link to clipboard

Copied

I'm having the same problem with MTS files.

I have installed A52 Codec Component -- no source audio.

I installed Perian -- same.

I installed the AME 6.0.2 patch -- same.

Using a Mac 10.8.2

3.2 GHz quad-core intel xeon

32 GB ram

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 29, 2012 Nov 29, 2012

Copy link to clipboard

Copied

My workaround was to re-transcode everything using Roxio Toast Titanium.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 03, 2012 Dec 03, 2012

Copy link to clipboard

Copied

******************************************************************

                                                 found it

******************************************************************

First i tried to convert it normally but no sound no matter what I tried. MTS file plays normally with sound in bs player or vlc BUT NOT in windows player. That means thats some kind of win7 codec problem.

After that the easiest solution would be to try on someWIN XP machine but also on internet so I used this page (clik it) where I converted and downloaded my file. It has the sound.

I am only affraid because my test file was only 63mb but when I will need the other it has 800mb so I hope they dont have size limit.

yes I know...lucky bastard


Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 11, 2013 Feb 11, 2013

Copy link to clipboard

Copied

I have a Mac and I had the same problem. I figured it out, with a little help from above. I found the Adobe Common File. I then went in the cache folders. I deleted all the caches from the dates that my files were originally encoded. Then, I reimported them. When they were remimported the sound showed in all my audio clips, including the short piece that had been missing. I'm going to guess that something interupted the importation of the files the first time and then since they were in the cache, reimporting them didn't solve my problem. Since they played fine in VLC, I knew it wasn't the file.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 28, 2013 Mar 28, 2013

Copy link to clipboard

Copied

Hello Lebertyninmo,

I have th same problem. I tried your solution but I don't understand it. Were can I find the adobe Common File and the cache folders?

Hope you can help me.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 28, 2013 Mar 28, 2013

Copy link to clipboard

Copied

If you are using a Mac, screennamean, you will find those files here:  Your mac user name, Library folder, Application Support Folder, Adobe Folder, Common Folder. In the common folder, there are two cache folders. The Media Cache file folder holds the cache for the files that you have imported into Premier Elements. Find the file that you have a problem with and delete it. I also deleted the files with the same date that were in the Media Cache file that have unintelligible names.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 23, 2013 Aug 23, 2013

Copy link to clipboard

Copied

Hi, I had exact same problem on Mac 10.7.5 and both Media Encoder cs6 and cc. I followed Libertyinmo's method and it worked.

HOW TO (for mac):

Finder -> Click 'Go' on the menu bar ->  Click 'Go to Folder' under Go (or Shift+apple+G) -> Type '~/Library/Application Support/Adobe/Common' -> Enter key -> Delete two folders (Media Cache and Media Cache Files) in the Finder.

Thank you all for the solution.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 29, 2014 Dec 29, 2014

Copy link to clipboard

Copied

Same here.   Mac running 10.6.8

No audio output....  I threw out the cache folders as described above.   I have tried multiple settings in audio - including no compression.   I get nothing.   video was shot on a Lumix Camera.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 29, 2014 Dec 29, 2014

Copy link to clipboard

Copied

Tried just exporting audio - aiff and aac  - got error saying that target was nil -

went back and updated everything and still didn't work.   then threw out cache files as stated above - now works!

oh well....

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Jan 04, 2015 Jan 04, 2015

Copy link to clipboard

Copied

No standard system I know of supports native MTS with AC3 audio.  However, if you output the audio to another format, make sure the target you output to matches what your camera outputs (match camera settings).  If this file gives you errors, check file size limits.  I usually output the audio to a downsample with the video, then separately output a full audio WAV or MOV file (audio only).  Then I code that audio into an Empty Movie, with the same frame rate as the full movie file, and save it as MOV or another type with PCM uncompressed audio.  It is now a Stream type file, and overcomes the File Size limits for an audio file, matches up with your other video file in the sequence, and you can swap for the better of audio and link it. Also, if you link the audio, targeting it into a sequence, it is cached the first time and the effects are applied on the fly.  When you recode the audio, either render it out, or dump the cache and play through it a few times in it's own sequence to cache it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 24, 2013 Apr 24, 2013

Copy link to clipboard

Copied

There is an eaay way to convert to mp4 with audio to use in Premiere Pro, you use a freeware program "HANDBRAKE"  to convert it, then use the MP4 in Premiere Pro.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 24, 2013 Apr 24, 2013

Copy link to clipboard

Copied

Confirmed I just used it and it worked first time no problem.  Using premiere pro to convert to YouTube!  I don't take credit for the resolve, it was on YouTube already how to fix this.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 25, 2014 Apr 25, 2014

Copy link to clipboard

Copied

I have the same experiences trying to use AME to convert MTS files.  No audio.

Try this software... it does the encoding with no loss of audio!  HandBrake: Open Source Video Transcoder

It works perfectly converting video and audio from MTS to MP4.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 18, 2014 Nov 18, 2014

Copy link to clipboard

Copied

I am sorry, but why you convert MTS to F4V. Are you sure that your computer has installed F4V audio codec? According to result, it seems that your computer does not have F4V codec installed. As far as I know, the most friend video format for AE is MPEG-2, you can have a try to encode MTS to MPEG-2 via some tools on Google so that MTS can be accepted by AE. Good luck!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Dec 27, 2014 Dec 27, 2014

Copy link to clipboard

Copied

I can confirm that NOBODY in the encoding world supports AC3 natively on a mac accept to pass it out to AAC when recoding.  Remember to change the encoding of your audio to something supported by your system.  If you have a WinPC and cannot process it, it is unsupported.  I can only guess at the reason, but this format is heavily compressed.  When playing through VLC, you are not "Playing" the AC3, but instead playing the STREAM of DATA coming from it, along with the video stream.  This supports only one conclusion, AC3 is the audio equivalent of .MTS video streams.  It isn't a format for a file.  It's a format for a data dump.  The difference is that a File has only one major packet, the file itself, while the data dump stream is made up of chunks (each chunk be a split file) that only has function when the data is interpreted and recoded.  A stream must be placed into something that interprets it (a program) or codes it into a single understandable file.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 03, 2018 Dec 03, 2018

Copy link to clipboard

Copied

Solution: VLC

I have the answer to you problem: transform the MTS file into an MP4 file (or a readable high quality format for Adobe programs) with VLC following this process: https://www.guidingtech.com/8848/use-vlc-player-to-convert-videos-from-one-format-to-another/

Important:

Also, once you've added the files you want to convert, and clicked the "Save/Convert" button I suggest you to change the settings of the "Audio codec" shown in the "edit selected profile" button

Change the Audio codec to the "MPEG 4 Audio (AAC)" format, so that the audio could be compatible with any Adobe video app.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines