Running an AE CC rendering through Media Encoder

Community Beginner ,
Jun 25, 2013 Jun 25, 2013

Copy link to clipboard

Copied

Not sure what I need to be concerned with.

The Media Encoder CC is taking about 10 times longer than when I rendered this AE cs6 project in the past.

The AE cc project is 34 seconds and the media encoder is saying it will take 10 hours to render.

It's a H.264 going to YT HD.

Any tweaks for improvement?

it's the only thing running using 6 gig memory.

Views

20.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Jun 25, 2013 Jun 25, 2013

Copy link to clipboard

Copied

Are you experiencing the same delay with other output formats, or just H.264? Does this happen with all compositions from After Effects? How long does the same composition take to render and export through the After Effects render queue?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 25, 2013 Jun 25, 2013

Copy link to clipboard

Copied

I only tried h.264 high bit and medium bitrate, I also tried YouTube HD 29. All of them would get stuck. Would you like me to try something different?

AEcc only allows these options to render in the image below. Doesn't mention any of the options Media mentions (and not like the AE CS6)

ae options.jpg

For the Media, it's still "counting up" on the time elapsed as well as the remaining. yet, the bar doesn't seem to be moving. I finally (after 6 hours) decided to kill the job.

What else would you like me to try? I'm desparate and willing to try anything at this point.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 26, 2013 Jun 26, 2013

Copy link to clipboard

Copied

The MPEG2, MPEG4, and H.264 outputs (and Windows Media) are hidden by default in After Effects CC but you can bring them back by turning on "Show depricated formats" in the Output section of Preferences:

After Effects Output prefs.png

This will re-enabled these output choices in the Output Module settings menu:

After Effects more outputs.png

In general tho' you should use AME to export to these formats.  They were "depricated"  in After Effects because they're legacy versions of the exporters while AME uses newer versions that are still being actively developed.  Only re-enable them if you need to troubleshoot an output issue, like this one, or have older AE projects that are dependent on them.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 26, 2013 Jun 26, 2013

Copy link to clipboard

Copied

Thank you Larry. I will give that a try now.

So far, I tried to rerun using AME without the refine edge. Same thing happenned. It would run about 1/4 of the processing and then stop. Then both counters would just keep on ticking up at the same time. After over 2 hours, I decided to kill the job.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 27, 2013 Jun 27, 2013

Copy link to clipboard

Copied

Using the AE rendering for h.264, this 34 second piece has been rendering now for 11 hours and 29 minutes and stuck at frame 322 of 1024 for the last 9 hours. The timer it says to finish is now 25 hours and 8 minutes.

I only have the rotoscope selected and NOT the refine edge.

I'm thinking of trying next is spliting the 34 second piece into 5 second chunks to try this out.

Does anyone else have any suggestions? Did I uncover a bug of sorts?

FYI, I'm runing on an HP Touchsmart 600 with windows 7 with all the updates. It has an i7 intel core with 8 gb of ram. It's the only app I have running. Also, the rotoscoping alone of this piece took under 2 hours in CS6.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 27, 2013 Jun 27, 2013

Copy link to clipboard

Copied

OK, it looks like 05:15 seconds is the max AME can handle. Going from 5:00 to 5:15 doubles the rendering time.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jun 27, 2013 Jun 27, 2013

Copy link to clipboard

Copied

Prior to exporting save the file, purge the image cache memory, empty the disk cache, and, if possible, increase the size of the disk cache and the amount of memory dedicated to Adobe applications. Also try rendering to an all intra-frame intermediate format like ProRes, DNxHD, AVC-Intra, or uncompressed V210 or DPX and then transcode to H.264.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 27, 2013 Jun 27, 2013

Copy link to clipboard

Copied

Thank you so much for your idea. You are a little beyond my knowledge, Profitic.

FYI, the original video is already in H.264, if that makes a difference.

I do not know how to purge image cache memor or empty the disk cache. I already have the machine set for performance preference.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jun 27, 2013 Jun 27, 2013

Copy link to clipboard

Copied

Edit > Purge > Image Cache Memory

Edit > Preferences > Media & Disk Cache:

  • if you have not already done so, check "Enable Disk Cache" and set the size of cache. The sze you choose will depend on the amount of space available on your hard drive.
  • Moving forward click "Empty Disk Cache" before rendering.
  • Under "Conformed Media Cache" click "Clean Database & Cache" before opening a new project and after closing the current project.

Also, how big is your hard disk and how much space is available? AE might be slowing down because of drive issues.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 28, 2013 Jun 28, 2013

Copy link to clipboard

Copied

Ah, thanks Profitic. I was thinking about the PC not within AE. My apologies.

I have over 503 gb of free space on my  C drive. If need be, I have an external 2tb drive. I didn't use that because I thought that would make things even slower.

I'm even wondering if one of my memory cards is going bad.

In the meantime, I'm going to clean cache before/after as you suggested. Great suggestion, BTW.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 29, 2013 Jun 29, 2013

Copy link to clipboard

Copied

Hi All,  This is the error message I'm now getting.

The rendering of all 34 seconds with just rotoscope (no refine edge) ran in under 30 minutes. However, I did see these error messages afterwards.

HardwareBlitpipe disengaged.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 30, 2015 Jun 30, 2015

Copy link to clipboard

Copied

Hey I have a question my problem is that since h.264 is unavailable by default I looked up some tutorials and I didn't seem to see anything that solved the problem I was having but I saw your picture and I tried to find the show depreciated formats box and I couldn't find where it is I know you have to go to the preferences and output settings or something like that but the thing is the box that says show depreciated formats box isn't there any ideas someone please help thanks ☺

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 30, 2015 Jun 30, 2015

Copy link to clipboard

Copied

Hi,

This Preference was removed from After Effects CC 2014 (13.X) and the current version CC 2015 (13.5)

It is still available in After Effects CC (12.X) version.

So, if you need to render in H.264 from CC 2014 and 2015 you need to render it from Adobe Media Encoder.

//Vinay

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 30, 2015 Jun 30, 2015

Copy link to clipboard

Copied

Hey, when I render it its fine but when it gets to about 60% done the render time increases any fixes always appreciated, cory

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 26, 2013 Jun 26, 2013

Copy link to clipboard

Copied

I just tried running within AE CC to quicktime. Same thing happens.  Therefore, it may not be AME but After Effects.

I will say that the 34 seconds has 2 layers. One of the layers has rotoscope and refine edge.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Jun 26, 2013 Jun 26, 2013

Copy link to clipboard

Copied

> One of the layers has rotoscope and refine edge.

How can that be, when you were comparing rendering times to After Effects CS6, and the Refine Edge feature is new in After Effects CC (12.0)?

If you're comparing rendering times between two versions, you need to use a composition that can actually exist in both versions.

The Refine Edge tool can add considerably to rendering time.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 26, 2013 Jun 26, 2013

Copy link to clipboard

Copied

Good point. I will try that now.

I do think something else is going on. it looks more that the rendering actually stalls. to take over 10 hours to render 34 seconds is a guess. it actually looks like it hung after 3 minutes of processing. Both counters just seem to go up and up with no movement on the frames.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 27, 2013 Jun 27, 2013

Copy link to clipboard

Copied

OK, this looks like a memory issue.

I ran a 5 second composition of the 34 second file. It processed with rotobrush/refine edge in less than 20 minutes in AME.

I'm going to try going up a second to see where the problem occurs.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 02, 2013 Jul 02, 2013

Copy link to clipboard

Copied

I have a similar slow render issue using ME vs. the AE renderer.

Win 7, i7-3770k @ 4.22 ghz, 32 gb ram. 15 seconds of animation 1080p, 29.97. I'm constantly cleaning the cache and have it on an ssd.

After effects CC completes a .mov using the h.264 codec with 100% quality, in just under 20 min.

The same project with the same render settings takes over 12 hrs in Media Encoder CC. (I didn't let it complete though, that was the eta) 

Filter-wise I'm not using much, just 1 layer of optical flares and 1 light in the scene. It's a fairly simple scene with a 3d floor, 2d back wall, and a customers logo in the spotlight.  There is a single optical flare layer in 3d space behind the logo.  The logo has 10 copies offset by 1 pixel in z-space to make a fake 3d logo.  They all have shadows on and I adjusted some of the material settings.

Having said all that, media encoder is severely lagging for some reason, and I don't believe it's a filter issue.  If after effects can complete the task in 20 min, media encoder should not take 720 min (12 hrs), or more, using the exact same project and specs.  That's almost 40 times longer. 

As was discussed above with the "refine edge" feature, I don't think that's the problem as I am not using refine edge for my project.  To me It seems like the link between ME and AE is broken/slow.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 02, 2013 Jul 02, 2013

Copy link to clipboard

Copied

What I uncovered yesterday was success. These are the rules I followed and I was able to process in AEcc and AMEcc. AMEcc did take longer but not 40x longer.

  1. If possible, restart your machine.
  2. Changed the time to never for the machine to got sleep or darken display (I'm going to try to avoid this tomorrow and go back to my older 1 hour/15 minute timers)
  3. Closed all other programs on my PC (including internet...why I have my smartphone and tablet and kindle near my computer as I work).
  4. Upped my cache storage. Though it was at 91g and I never saw usage more than 15g, I upped it to150g.
  5. Save work.
  6. Clean media cache.
  7. Keep rotoscope area segments less than 5 seconds (so I had 7 segments of about 5 seconds each in the file).
  8. Clean media cache again (just in case I forgot step 3).
  9. Export to AMEcc from AEcc (I also closed AEcc and opened AMEcc to import ... same timings for export/import process).
  10. Clean AMEcc cache.
  11. Render
  12. Go take a nap.

I need to make some changes to my file tomorrow. I'm hoping for the same results.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 02, 2013 Jul 02, 2013

Copy link to clipboard

Copied

Thanks for the input.  My cache size is 500 gb, an entire ssd used for nothing but Adobe cache.  There is nothing else on the drive and I clean the cache several times throughout a project to keep things moving.

My machine is always on, no screensavers or sleep modes.

Roto areas some times need to be more than 5 seconds per the clients specs, so this is not an option as I can't tell them their shot won't work because it's more than 5 seconds. 

This isn't a cache issue in my opinion as I have more than enough drive space available on a very fast ssd, more than capable i7 3770k, and maxed out ram, with a mid-range Nvidia card. It also doesn't explain why the after effects renderer performs Much faster than media encoder with all of that empty space just sitting there.  I could see if the cache drive was full, but it is barely at 10% capacity because I clean it several times per day. I don't think that is the problem; especially since the problem isn't repeatable inside of after effects.

It's a processing issue between the dynamic link manager and ME/AE I think. I watch all cores at only about 26% of capacity with Media Encoder, After Effects uses all 8 cores at 100% when it is rendering through the internal queue.

Will keep using AE for now until this is resolved.  Thanks for the input!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 02, 2013 Jul 02, 2013

Copy link to clipboard

Copied

I agree with you.

I do want to make one clarification. When I said 5 second limit. My file is 34 seconds. So I have 7 rotobrush segments within the one 34 second file. That is what I noticed was the differnce in success for me.

You may have understood what I meant before. I just wanted to make sure.

PS, I envy your setup!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 16, 2014 May 16, 2014

Copy link to clipboard

Copied

HI ya ...

Same problem here ... trying to output 8sec and AME comes up with a time of 4hours 33min and then starts climbing. I have spent four hours on to Adobe support but no results as yet. At the moment I'm rendering a .mov and taking it to premier pro and then to mp4 through AME where it works fine ... If I get a solution from Adobe I'll post it here ...

After Effects CC

Media Encoder CC

Premier Pro CC

MBP 8gig of ram

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 06, 2014 Jun 06, 2014

Copy link to clipboard

Copied

One thing I have noticed is if I close AE when rendering via AME, the render time drops significantly. I'll set up the render, execute it and then close AE once it starts. I had one render that took over 24 hours with AE open, and finished in an hour and a half yesterday, once I closed After Effects for the day. Not sure if this helps, but in a pinch try closing AE.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines