Highlighted

How to use x-api-user parameter

New Here ,
Oct 25, 2018

Copy link to clipboard

Copied

Hi,

I obtained access-token for master account with scope "account" but I can't make request to subaccounts.

1.) Our site get access-token for master account

2.) we try to POST /agreements (Adobe Sign REST API Version 5)

2a.) If we use access-token only then everything goes well

2b.) If we use access-token and x-api-user parameter we get error.

- email is valid

- subaccount with this email exists and is verified

Code (c#):

var userEmail = "subaccount@test.com";

request.AddHeader( "x-api-user", string.Format("email:{0}", userEmail) );

Response:

{"code":"INVALID_USER","message":"Invalid user ID or email provided in x-api-user header"}

What is wrong in this process?

Thanks for help!

Hi Ufexu,

I have checked that you are using the Adobe Sign developer account.

I would recommend you contact Pre-Sales team to get the settings enabled.

They will be able to provide pre-sales technical assistance to you.

Please refer to this link Adobe Sign plans for individuals and businesses | Adobe Document Cloud to get in contact with them.

Hope that helps.

Let us know if you have any questions.

Regards,

Meenakshi

Topics

Bug Error, Questions Need Help

Views

905

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

How to use x-api-user parameter

New Here ,
Oct 25, 2018

Copy link to clipboard

Copied

Hi,

I obtained access-token for master account with scope "account" but I can't make request to subaccounts.

1.) Our site get access-token for master account

2.) we try to POST /agreements (Adobe Sign REST API Version 5)

2a.) If we use access-token only then everything goes well

2b.) If we use access-token and x-api-user parameter we get error.

- email is valid

- subaccount with this email exists and is verified

Code (c#):

var userEmail = "subaccount@test.com";

request.AddHeader( "x-api-user", string.Format("email:{0}", userEmail) );

Response:

{"code":"INVALID_USER","message":"Invalid user ID or email provided in x-api-user header"}

What is wrong in this process?

Thanks for help!

Hi Ufexu,

I have checked that you are using the Adobe Sign developer account.

I would recommend you contact Pre-Sales team to get the settings enabled.

They will be able to provide pre-sales technical assistance to you.

Please refer to this link Adobe Sign plans for individuals and businesses | Adobe Document Cloud to get in contact with them.

Hope that helps.

Let us know if you have any questions.

Regards,

Meenakshi

Topics

Bug Error, Questions Need Help

Views

906

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Oct 26, 2018

Copy link to clipboard

Copied

Hi Ufexu,

I have checked that you are using the Adobe Sign developer account.

I would recommend you contact Pre-Sales team to get the settings enabled.

They will be able to provide pre-sales technical assistance to you.

Please refer to this link Adobe Sign plans for individuals and businesses | Adobe Document Cloud to get in contact with them.

Hope that helps.

Let us know if you have any questions.

Regards,

Meenakshi

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...