Highlighted

Keep getting "Scopes not enabled for this application" on redirect after initial OAuth step regardless of scopes included in request and enabled in developer account.

New Here ,
Mar 21, 2016

Copy link to clipboard

Copied

We are embedding eSign services into an external app using the REST api.  However, I am having trouble with the first authorization step.  After the request, I am redirected to the Adobe form page where I can enter my account credentials.  From there I am redirected to the specified redirect URI, however, I'm getting an error saying "Scopes are not enabled for this application".  For testing purposes, I have even tried enabling all possible scopes for this application in my eSign dev account.  Am I missing something?

Topics

Bug Error, Questions Need Help

Views

760

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Keep getting "Scopes not enabled for this application" on redirect after initial OAuth step regardless of scopes included in request and enabled in developer account.

New Here ,
Mar 21, 2016

Copy link to clipboard

Copied

We are embedding eSign services into an external app using the REST api.  However, I am having trouble with the first authorization step.  After the request, I am redirected to the Adobe form page where I can enter my account credentials.  From there I am redirected to the specified redirect URI, however, I'm getting an error saying "Scopes are not enabled for this application".  For testing purposes, I have even tried enabling all possible scopes for this application in my eSign dev account.  Am I missing something?

Topics

Bug Error, Questions Need Help

Views

761

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Nov 25, 2017

Copy link to clipboard

Copied

I have the same problem. Were you able to solve it?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jan 25, 2018

Copy link to clipboard

Copied

Just in case you still have it unresolved.

1. Check all the boxes and setup the same modifier (let's say account) on "Configure OAuth" application menu

2. Make sure you have the same modifier in scope parameter in your request (https://secure.na2.echosign.com/public/oauth?redirect_uri=https://yourSite.com&response_type=code&cl...)

Hope this will help.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...