Highlighted

OAuth problem : Unable to authorize access because the client configuration is invalid: invalid_request

New Here ,
May 14, 2019

Copy link to clipboard

Copied

For testing purposes to decide whether to go with this I am at this moment using the free-trial period.

I am trying to get the OAuth token on :

https://secure.na1.echosign.com/public/oauth?redirect_uri=https://onlinegorilla.com&response_type=co...

I tried also other scopes, like user_login:self+agreement_send

Application ID: CBJCHBCAABAAuNaCVzG8tTMkcpuvNo9_aLgrzN4IXJZh

Client secret: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxE_dv

Redirect uri is set the same as it is set in the API application settings. I tried in the browser in Postman and in ARC and get the same result: 'Unable to authorize access because the client configuration is invalid: invalid_request'

Scope settings:

best regards

your endpoint is on eu1.echosign.com, not na1.echosign.com.

I also edited your post to obscure your client secret, as well it should be a secret!

Views

1.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

OAuth problem : Unable to authorize access because the client configuration is invalid: invalid_request

New Here ,
May 14, 2019

Copy link to clipboard

Copied

For testing purposes to decide whether to go with this I am at this moment using the free-trial period.

I am trying to get the OAuth token on :

https://secure.na1.echosign.com/public/oauth?redirect_uri=https://onlinegorilla.com&response_type=co...

I tried also other scopes, like user_login:self+agreement_send

Application ID: CBJCHBCAABAAuNaCVzG8tTMkcpuvNo9_aLgrzN4IXJZh

Client secret: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxE_dv

Redirect uri is set the same as it is set in the API application settings. I tried in the browser in Postman and in ARC and get the same result: 'Unable to authorize access because the client configuration is invalid: invalid_request'

Scope settings:

best regards

your endpoint is on eu1.echosign.com, not na1.echosign.com.

I also edited your post to obscure your client secret, as well it should be a secret!

Views

1.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
May 15, 2019

Copy link to clipboard

Copied

your endpoint is on eu1.echosign.com, not na1.echosign.com.

I also edited your post to obscure your client secret, as well it should be a secret!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jan 24, 2020

Copy link to clipboard

Copied

I am also facing the same issue. I have tried changing the endpoint mentioned in your reply but yet its not working for me. Kindly suggest.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
May 02, 2020

Copy link to clipboard

Copied

I am getting the same issue, even after changing the endpoint. Please help.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
May 12, 2020

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
May 26, 2020

Copy link to clipboard

Copied

Screen Shot 2020-05-26 at 10.40.01 AM.png

I am facing the same problem, and I'm unable to get an access token. I keep seeing this response. Both variations of the base url yield the same error message
Please advise

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 01, 2020

Copy link to clipboard

Copied

Hello i am facing the same error. I using my client id and i noticed the client/applicatoin id doesn't work. Is the application Id the same as Client Id?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Sep 14, 2020

Copy link to clipboard

Copied

https://helpx.adobe.com/sign/using/identify-account-shard.html

Adobe Sign is a distributed application, spanning multiple environments around the globe.  

Each environment is tightly integrated with all of the others, ensuring seamless transactions between senders and recipients, regardless as to which environment each resides in.

However, occasionally it becomes important to know which environment contains your account. During maintenance or upgrade windows for example.

To find which environment holds your account, just log in to Adobe Sign, and check the URL.  

The environment identifier is found in the URL address, just before the echosign.com (or adobesign.com) portion.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...